Update to 4.9.30

* Drop/refresh patches as necessary
* Ignore ABI changes in ccp and hid-sensors
* [mips*el/loongson-3] Revert "MIPS: Loongson-3: Select
  MIPS_L1_CACHE_SHIFT_6" to avoid ABI change
This commit is contained in:
Ben Hutchings 2017-05-31 18:41:56 +01:00
parent dd1408c66d
commit e9619f03d3
6 changed files with 267 additions and 35 deletions

240
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.9.28-1) UNRELEASED; urgency=medium
linux (4.9.30-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.9.26
@ -163,10 +163,248 @@ linux (4.9.28-1) UNRELEASED; urgency=medium
- [arm64, armhf] wlcore: Add RX_BA_WIN_SIZE_CHANGE_EVENT event
- drm/ttm: fix use-after-free races in vm fault handling
- block: get rid of blk_integrity_revalidate()
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.9.29
- [x86] xen: adjust early dom0 p2m handling to xen hypervisor behavior
- target: Fix compare_and_write_callback handling for non GOOD status
- target/fileio: Fix zero-length READ and WRITE handling
- iscsi-target: Set session_fall_back_to_erl0 when forcing reinstatement
- usb: xhci: bInterval quirk for TI TUSB73x0
- usb: host: xhci: print correct command ring address
- USB: Proper handling of Race Condition when two USB class drivers try to
call init_usb_class simultaneously
- USB: Revert "cdc-wdm: fix "out-of-sync" due to missing notifications"
- [x86] staging: vt6656: use off stack for in buffer USB transfers.
- [x86] staging: vt6656: use off stack for out buffer USB transfers.
- [x86] staging: comedi: jr3_pci: fix possible null pointer dereference
- [x86] staging: comedi: jr3_pci: cope with jiffies wraparound
- usb: misc: add missing continue in switch
- usb: gadget: legacy gadgets are optional
- usb: Make sure usb/phy/of gets built-in
- usb: hub: Fix error loop seen after hub communication errors
- usb: hub: Do not attempt to autosuspend disconnected devices
- [x86] boot: Fix BSS corruption/overwrite bug in early x86 kernel startup
- [amd64] pmem: Fix cache flushing for iovec write < 8 bytes
- [x86] perf: Fix Broadwell-EP DRAM RAPL events
- [x86] KVM: fix user triggerable warning in kvm_apic_accept_events()
- [armhf,arm64] KVM: fix races in kvm_psci_vcpu_on
- [arm64] KVM: Fix decoding of Rt/Rt2 when trapping AArch32 CP accesses
- block: fix blk_integrity_register to use template's interval_exp if not 0
- crypto: algif_aead - Require setkey before accept(2)
- [x86] crypto: ccp - Use only the relevant interrupt bits
- [x86] crypto: ccp - Disable interrupts early on unload
- [x86] crypto: ccp - Change ISR handler method for a v3 CCP
- [x86] crypto: ccp - Change ISR handler method for a v5 CCP
- dm era: save spacemap metadata root after the pre-commit
- dm rq: check blk_mq_register_dev() return value in
dm_mq_init_request_queue()
- dm thin: fix a memory leak when passing discard bio down
- vfio/type1: Remove locked page accounting workqueue
- iov_iter: don't revert iov buffer if csum error
- IB/core: Fix sysfs registration error flow
- IB/core: For multicast functions, verify that LIDs are multicast LIDs
- IB/IPoIB: ibX: failed to create mcg debug file
- IB/mlx4: Fix ib device initialization error flow
- IB/mlx4: Reduce SRIOV multicast cleanup warning message to debug level
- IB/hfi1: Prevent kernel QP post send hard lockups
- perf auxtrace: Fix no_size logic in addr_filter__resolve_kernel_syms()
- ext4: evict inline data when writing to memory map
- fs/xattr.c: zero out memory copied to userspace in getxattr
- ceph: fix memory leak in __ceph_setxattr()
- fs/block_dev: always invalidate cleancache in invalidate_bdev()
- mm: prevent potential recursive reclaim due to clearing PF_MEMALLOC
- Fix match_prepath()
- Set unicode flag on cifs echo request to avoid Mac error
- SMB3: Work around mount failure when using SMB3 dialect to Macs
- CIFS: fix mapping of SFM_SPACE and SFM_PERIOD
- cifs: fix leak in FSCTL_ENUM_SNAPS response handling
- cifs: fix CIFS_ENUMERATE_SNAPSHOTS oops
- CIFS: fix oplock break deadlocks
- cifs: fix CIFS_IOC_GET_MNT_INFO oops
- CIFS: add misssing SFM mapping for doublequote
- padata: free correct variable
- device-dax: fix cdev leak
- fscrypt: fix context consistency check when key(s) unavailable
- [armhf] serial: samsung: Use right device for DMA-mapping calls
- [armhf] serial: omap: fix runtime-pm handling on unbind
- [armhf] serial: omap: suspend device on probe errors
- tty: pty: Fix ldisc flush after userspace become aware of the data already
- Bluetooth: Fix user channel for 32bit userspace on 64bit kernel
- Bluetooth: hci_bcm: add missing tty-device sanity check
- Bluetooth: hci_intel: add missing tty-device sanity check
- ipmi: Fix kernel panic at ipmi_ssif_thread()
- libnvdimm, region: fix flush hint detection crash
- libnvdimm, pmem: fix a NULL pointer BUG in nd_pmem_notify
- libnvdimm, pfn: fix 'npfns' vs section alignment
- [powerpc*/*64*] pstore: Fix flags to enable dumps on powerpc
- pstore: Shut down worker when unregistering
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.9.30
- usb: misc: legousbtower: Fix buffers on stack
- usb: misc: legousbtower: Fix memory leak
- USB: ene_usb6250: fix DMA to the stack
- watchdog: pcwd_usb: fix NULL-deref at probe
- char: lp: fix possible integer overflow in lp_setup() (CVE-2017-1000363)
- USB: core: replace %p with %pK
- tpm_tis_core: Choose appropriate timeout for reading burstcount
- ALSA: hda: Fix cpu lockup when stopping the cmd dmas
- [armhf] tegra: paz00: Mark panel regulator as enabled on boot
- fanotify: don't expose EOPENSTALE to userspace
- tpm_tis_spi: Use single function to transfer data
- tpm_tis_spi: Abort transfer when too many wait states are signaled
- tpm_tis_spi: Check correct byte for wait state indicator
- tpm_tis_spi: Remove limitation of transfers to MAX_SPI_FRAMESIZE bytes
- tpm_tis_spi: Add small delay after last transfer
- tpm: msleep() delays - replace with usleep_range() in i2c nuvoton driver
- tpm: add sleep only for retry in i2c_nuvoton_write_status()
- tpm_crb: check for bad response size
- mlx5: Fix mlx5_ib_map_mr_sg mr length
- infiniband: call ipv6 route lookup via the stub interface
- dm btree: fix for dm_btree_find_lowest_key()
- dm raid: select the Kconfig option CONFIG_MD_RAID0
- dm bufio: avoid a possible ABBA deadlock
- dm bufio: check new buffer allocation watermark every 30 seconds
- dm mpath: split and rename activate_path() to prepare for its expanded use
- dm cache metadata: fail operations if fail_io mode has been established
- dm bufio: make the parameter "retain_bytes" unsigned long
- dm thin metadata: call precommit before saving the roots
- dm space map disk: fix some book keeping in the disk space map
- md: update slab_cache before releasing new stripes when stripes resizing
- md: MD_CLOSING needs to be cleared after called md_set_readonly or
do_md_stop
- rtlwifi: rtl8821ae: setup 8812ae RFE according to device type
- mwifiex: MAC randomization should not be persistent
- mwifiex: pcie: fix cmd_buf use-after-free in remove/reset
- ima: accept previously set IMA_NEW_FILE
- [x86] KVM: Fix load damaged SSEx MXCSR register
- [x86] KVM: Fix potential preemption when get the current kvmclock
timestamp
- [x86] KVM: Fix read out-of-bounds vulnerability in kvm pio emulation
- [i386] fix 32-bit case of __get_user_asm_u64()
- [armhf] regulator: rk808: Fix RK818 LDO2
- [s390x] kdump: Add final note
- [s390x] cputime: fix incorrect system time
- ath9k_htc: Add support of AirTies 1eda:2315 AR9271 device
- ath9k_htc: fix NULL-deref at probe
- [x86] drm/amdgpu: Make display watermark calculations more accurate
- [x86] drm/amdgpu: Avoid overflows/divide-by-zero in latency_watermark
calculations.
- [x86] drm/amdgpu: Add missing lb_vblank_lead_lines setup to DCE-6 path.
- drm/nouveau/therm: remove ineffective workarounds for alarm bugs
- drm/nouveau/tmr: ack interrupt before processing alarms
- drm/nouveau/tmr: fix corruption of the pending list when rescheduling an
alarm
- drm/nouveau/tmr: avoid processing completed alarms when adding a new one
- drm/nouveau/tmr: handle races with hw when updating the next alarm time
- [armhf] gpio: omap: return error if requested debounce time is not
possible
- cdc-acm: fix possible invalid access when processing notification
- ohci-pci: add qemu quirk
- [powerpc*] cxl: Force context lock during EEH flow
- [powerpc*] cxl: Route eeh events to all drivers in
cxl_pci_error_detected()
- proc: Fix unbalanced hard link numbers
- of: fix sparse warning in of_pci_range_parser_one
- of: fix "/cpus" reference leak in of_numa_parse_cpu_nodes()
- of: fdt: add missing allocation-failure check
- [powerpc*/*64*] ibmvscsis: Do not send aborted task response
- [x86] IIO: bmp280-core.c: fix error in humidity calculation
- IB/hfi1: Return an error on memory allocation failure
- IB/hfi1: Fix a subcontext memory leak
- pid_ns: Sleep in TASK_INTERRUPTIBLE in zap_pid_ns_processes
- pid_ns: Fix race between setns'ed fork() and zap_pid_ns_processes()
- USB: serial: ftdi_sio: fix setting latency for unprivileged users
- USB: serial: ftdi_sio: add Olimex ARM-USB-TINY(H) PIDs
- USB: chaoskey: fix Alea quirk on big-endian hosts
- f2fs: check entire encrypted bigname when finding a dentry
- fscrypt: avoid collisions when presenting long encrypted filenames
- libnvdimm: fix clear length of nvdimm_forget_poison()
- xhci: remove GFP_DMA flag from allocation
- usb: host: xhci-plat: propagate return value of platform_get_irq()
- xhci: apply PME_STUCK_QUIRK and MISSING_CAS quirk for Denverton
- usb: host: xhci-mem: allocate zeroed Scratchpad Buffer
- net: irda: irda-usb: fix firmware name on big-endian hosts
- usbvision: fix NULL-deref at probe
- mceusb: fix NULL-deref at probe
- ttusb2: limit messages to buffer size
- [armhf,arm64] usb: dwc3: gadget: Prevent losing events in event cache
- [armhf] usb: musb: tusb6010_omap: Do not reset the other direction's
packet size
- [armhf] usb: musb: Fix trying to suspend while active for OTG
configurations
- USB: iowarrior: fix info ioctl on big-endian hosts
- usb: serial: option: add Telit ME910 support
- USB: serial: qcserial: add more Lenovo EM74xx device IDs
- USB: serial: mct_u232: fix big-endian baud-rate handling
- USB: serial: io_ti: fix div-by-zero in set_termios
- USB: hub: fix SS hub-descriptor handling
- USB: hub: fix non-SS hub-descriptor handling
- ipx: call ipxitf_put() in ioctl error path (CVE-2017-7487)
- iio: hid-sensor: Store restore poll and hysteresis on S3
- gspca: konica: add missing endpoint sanity check
- dib0700: fix NULL-deref at probe
- zr364xx: enforce minimum size when reading header
- dvb-frontends/cxd2841er: define symbol_rate_min/max in T/C fe-ops
- digitv: limit messages to buffer size
- dw2102: limit messages to buffer size
- cx231xx-audio: fix init error path
- cx231xx-audio: fix NULL-deref at probe
- cx231xx-cards: fix NULL-deref at probe
- [powerpc*] mm: Ensure IRQs are off in switch_mm()
- [powerpc*] eeh: Avoid use after free in eeh_handle_special_event()
- [powerpc*] book3s/mce: Move add_taint() later in virtual mode
- [powerpc*] pseries: Fix of_node_put() underflow during DLPAR remove
- [powerpc*] iommu: Do not call PageTransHuge() on tail pages
- [powerpc*] tm: Fix FP and VMX register corruption
- [arm64] KVM: Do not use stack-protector to compile EL2 code
- [armhf] KVM: Do not use stack-protector to compile HYP code
- [armhf] KVM: plug potential guest hardware debug leakage
- [armel,armhf] 8662/1: module: split core and init PLT sections
- [armhf] dts: imx6sx-sdb: Remove OPP override
- [arm64] dts: hi6220: Reset the mmc hosts
- [arm64] xchg: hazard against entire exchange variable
- [arm64] ensure extension of smp_store_release value
- [arm64] armv8_deprecated: ensure extension of addr
- [arm64] uaccess: ensure extension of access_ok() addr
- [arm64] documentation: document tagged pointer stack constraints
- [x86] staging: rtl8192e: rtl92e_fill_tx_desc fix write to mapped out
memory.
- [x86] staging: rtl8192e: fix 2 byte alignment of register BSSIDR.
- [x86] staging: rtl8192e: rtl92e_get_eeprom_size Fix read size of
EPROM_CMD.
- [x86] staging: rtl8192e: GetTs Fix invalid TID 7 warning.
- [x86] iommu/vt-d: Flush the IOTLB to get rid of the initial kdump mappings
- stackprotector: Increase the per-task stack canary's random range from 32
bits to 64 bits on 64-bit platforms
- uwb: fix device quirk on big-endian hosts
- genirq: Fix chained interrupt data ordering
- nvme: unmap CMB and remove sysfs file in reset path
- [alpha] osf_wait4(): fix infoleak
- tracing/kprobes: Enforce kprobes teardown after testing
- [x86] PCI: hv: Allocate interrupt descriptors with GFP_ATOMIC
- [x86] PCI: hv: Specify CPU_AFFINITY_ALL for MSI affinity when >= 32 CPUs
- PCI: Fix pci_mmap_fits() for HAVE_PCI_RESOURCE_TO_USER platforms
- PCI: Fix another sanity check bug in /proc/pci mmap
- PCI: Only allow WC mmap on prefetchable resources
- PCI: Freeze PME scan before suspending devices
- [armel,armhf] mtd: nand: orion: fix clk handling
- [armhf] mtd: nand: omap2: Fix partition creation via cmdline mtdparts
- mtd: nand: add ooblayout for old hamming layout
- [x86] drm/edid: Add 10 bpc quirk for LGD 764 panel in HP zBook 17 G2
- NFSv4: Fix a hang in OPEN related to server reboot
- NFS: Fix use after free in write error path
- NFS: Use GFP_NOIO for two allocations in writeback
- nfsd: fix undefined behavior in nfsd4_layout_verify
- nfsd: encoders mustn't use unitialized values in error cases
- drivers: char: mem: Check for address space wraparound with mmap()
- [x86] drm/i915/gvt: Disable access to stolen memory as a guest
[ Aurelien Jarno ]
* [mips*/*-malta] Enable POWER_RESET and POWER_RESET_SYSCON.
[ Ben Hutchings ]
* Ignore ABI changes in ccp and hid-sensors
* [mips*el/loongson-3] Revert "MIPS: Loongson-3: Select
MIPS_L1_CACHE_SHIFT_6" to avoid ABI change
-- Ben Hutchings <ben@decadent.org.uk> Mon, 08 May 2017 21:11:08 +0200
linux (4.9.25-1) unstable; urgency=medium

View File

@ -8,7 +8,9 @@ ignore-changes:
register_cxl_calls
unregister_cxl_calls
module:arch/x86/kvm/*
module:drivers/crypto/ccp/*
module:drivers/hv/*
module:drivers/iio/common/hid-sensors/*
module:drivers/iio/common/st_sensors/**
module:drivers/net/wireless/**
module:drivers/nvdimm/*

View File

@ -1,29 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 17 Feb 2017 02:51:21 +0000
Subject: [media] dvb-usb-dibusb-mc-common: Add MODULE_LICENSE
Bug-Debian: https://bugs.debian.org/853110
Forwarded: https://patchwork.kernel.org/patch/9580907/
dvb-usb-dibusb-mc-common is licensed under GPLv2, and if we don't say
so then it won't even load since it needs a GPL-only symbol.
Reported-by: Dominique Dumont <dod@debian.org>
References: https://bugs.debian.org/853110
Cc: stable@vger.kernel.org # 4.9+
Fixes: e91455a1495a ("[media] dvb-usb: split out common parts of dibusb")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/media/usb/dvb-usb/dibusb-mc-common.c | 2 ++
1 file changed, 2 insertions(+)
--- a/drivers/media/usb/dvb-usb/dibusb-mc-common.c
+++ b/drivers/media/usb/dvb-usb/dibusb-mc-common.c
@@ -12,6 +12,8 @@
#include <linux/kconfig.h>
#include "dibusb.h"
+MODULE_LICENSE("GPL");
+
/* 3000MC/P stuff */
// Config Adjacent channels Perf -cal22
static struct dibx000_agc_config dib3000p_mt2060_agc_config = {

View File

@ -0,0 +1,21 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 31 May 2017 20:59:05 +0100
Subject: Revert "MIPS: Loongson-3: Select MIPS_L1_CACHE_SHIFT_6"
Forwarded: not-needed
This reverts commit 07d8aabff4903065bb472df9b040b8688fdc75a2 which was
commit 17c99d9421695a0e0de18bf1e7091d859e20ec1d upstream. This
changed L1_CACHE_SHIFT which is used for structure alignment in many
places, thus would break ABI.
---
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -1368,7 +1368,6 @@ config CPU_LOONGSON3
select WEAK_ORDERING
select WEAK_REORDERING_BEYOND_LLSC
select MIPS_PGD_C0_CONTEXT
- select MIPS_L1_CACHE_SHIFT_6
select GPIOLIB
help
The Loongson 3 processor implements the MIPS64R2 instruction

View File

@ -28,7 +28,7 @@ Signed-off-by: Matthew Garrett <mjg59@srcf.ucam.org>
if (off > dev->cfg_size)
return 0;
if (off + count > dev->cfg_size) {
@@ -1007,6 +1010,9 @@ static int pci_mmap_resource(struct kobj
@@ -1011,6 +1014,9 @@ static int pci_mmap_resource(struct kobj
resource_size_t start, end;
int i;
@ -38,7 +38,7 @@ Signed-off-by: Matthew Garrett <mjg59@srcf.ucam.org>
for (i = 0; i < PCI_ROM_RESOURCE; i++)
if (res == &pdev->resource[i])
break;
@@ -1106,6 +1112,9 @@ static ssize_t pci_write_resource_io(str
@@ -1110,6 +1116,9 @@ static ssize_t pci_write_resource_io(str
struct bin_attribute *attr, char *buf,
loff_t off, size_t count)
{
@ -80,13 +80,13 @@ Signed-off-by: Matthew Garrett <mjg59@srcf.ucam.org>
ret = pci_domain_nr(dev->bus);
@@ -233,7 +240,7 @@ static int proc_bus_pci_mmap(struct file
struct pci_filp_private *fpriv = file->private_data;
int i, ret, write_combine;
int i, ret, write_combine = 0, res_bit;
- if (!capable(CAP_SYS_RAWIO))
+ if (!capable(CAP_SYS_RAWIO) || (get_securelevel() > 0))
return -EPERM;
/* Make sure the caller is mapping a real resource for this device */
if (fpriv->mmap_state == pci_mmap_io)
--- a/drivers/pci/syscall.c
+++ b/drivers/pci/syscall.c
@@ -10,6 +10,7 @@

View File

@ -72,7 +72,6 @@ bugfix/all/disable-some-marvell-phys.patch
bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/kbuild-do-not-use-hyphen-in-exported-variable-name.patch
bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/media-dvb-usb-dibusb-mc-common-add-module_license.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
# Miscellaneous features
@ -117,6 +116,7 @@ bugfix/powerpc/powerpc-fix-missing-crcs-add-yet-more-asm-prototypes.patch
bugfix/all/module-disable-matching-missing-version-crc.patch
# ABI maintenance
debian/revert-mips-loongson-3-select-mips_l1_cache_shift_6.patch
# Tools bug fixes
bugfix/all/usbip-document-tcp-wrappers.patch