speakup: Update to match Debian package version 3.1.5.dfsg.1-1

svn path=/dists/trunk/linux-2.6/; revision=16309
This commit is contained in:
Ben Hutchings 2010-09-18 16:48:22 +00:00
parent 32f1dc52a9
commit e935dba032
6 changed files with 397 additions and 162 deletions

3
debian/changelog vendored
View File

@ -2,6 +2,9 @@ linux-2.6 (2.6.36~rc4-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate
[ Ben Hutchings ]
* speakup: Update to match Debian package version 3.1.5.dfsg.1-1
-- Ben Hutchings <ben@decadent.org.uk> Mon, 13 Sep 2010 01:25:14 +0100
linux-2.6 (2.6.35-1~experimental.3) experimental; urgency=low

View File

@ -1,19 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: [PATCH] keyboard: Export k_handler again
Commit 97f5f0cd8cd0a05449cbb77d1e6f02e026875802 "Input: implement
SysRq as a separate input handler" removed the export of k_handler.
However, speakup currently depends on this.
--- a/drivers/char/keyboard.c
+++ b/drivers/char/keyboard.c
@@ -81,7 +82,8 @@
typedef void (k_handler_fn)(struct vc_data *vc, unsigned char value,
char up_flag);
static k_handler_fn K_HANDLERS;
+k_handler_fn *k_handler[16] = { K_HANDLERS };
+EXPORT_SYMBOL_GPL(k_handler);
-static k_handler_fn *k_handler[16] = { K_HANDLERS };
#define FN_HANDLERS\
fn_null, fn_enter, fn_show_ptregs, fn_show_mem,\

View File

@ -1,30 +0,0 @@
--- a/drivers/staging/speakup/i18n.c 2010-05-18 17:17:16.000000000 +0000
+++ b/drivers/staging/speakup/i18n.c 2010-05-18 17:18:04.000000000 +0000
@@ -1,6 +1,7 @@
/* Internationalization implementation. Includes definitions of English
* string arrays, and the i18n pointer. */
+#include <linux/slab.h>
#include <linux/ctype.h>
#include <linux/module.h>
#include <linux/string.h>
--- a/drivers/staging/speakup/selection.c 2010-05-18 17:20:15.000000000 +0000
+++ b/drivers/staging/speakup/selection.c 2010-05-18 17:20:29.000000000 +0000
@@ -2,6 +2,7 @@
#include <linux/interrupt.h>
#include <linux/sched.h>
#include <linux/selection.h>
+#include <linux/slab.h>
#include "speakup.h"
--- a/drivers/staging/speakup/kobjects.c 2010-05-18 17:19:00.000000000 +0000
+++ b/drivers/staging/speakup/kobjects.c 2010-05-18 17:19:21.000000000 +0000
@@ -13,6 +13,7 @@
*/
#include <linux/kernel.h>
#include <linux/kobject.h>
+#include <linux/slab.h>
#include <linux/string.h>
#include <linux/sysfs.h>
#include <linux/ctype.h>

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,38 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: [PATCH] speakup: Fix references to vc_data::vc_tty
--- a/drivers/staging/speakup/buffers.c
+++ b/drivers/staging/speakup/buffers.c
@@ -30,8 +30,8 @@
for (i = 0; i < MAX_NR_CONSOLES; i++) {
if (speakup_console[i] && speakup_console[i]->tty_stopped)
continue;
- if ((vc_cons[i].d != NULL) && (vc_cons[i].d->vc_tty != NULL))
- start_tty(vc_cons[i].d->vc_tty);
+ if ((vc_cons[i].d != NULL) && (vc_cons[i].d->port.tty != NULL))
+ start_tty(vc_cons[i].d->port.tty);
}
unlock_kernel();
}
@@ -53,8 +53,8 @@
return;
}
for (i = 0; i < MAX_NR_CONSOLES; i++)
- if ((vc_cons[i].d != NULL) && (vc_cons[i].d->vc_tty != NULL))
- stop_tty(vc_cons[i].d->vc_tty);
+ if ((vc_cons[i].d != NULL) && (vc_cons[i].d->port.tty != NULL))
+ stop_tty(vc_cons[i].d->port.tty);
if (!in_atomic())
unlock_kernel();
return;
--- a/drivers/staging/speakup/main.c
+++ b/drivers/staging/speakup/main.c
@@ -2010,7 +2010,7 @@
return 0;
spk_lock(flags);
- tty = vc->vc_tty;
+ tty = vc->port.tty;
if (type >= 0xf0)
type -= 0xf0;
if (type == KT_PAD &&

View File

@ -23,10 +23,7 @@
# diff -ur --unidirectional-new-file nonexistent src | filterdiff --strip=1 --addoldprefix=a/drivers/staging/speakup/ --addnewprefix=b/drivers/staging/speakup/
+ features/all/speakup/speakup-add.patch
+ features/all/speakup/speakup-kbuild.patch
# made manually
+ features/all/speakup/slab-build-fix.patch
# speakup also needs this
+ debian/keyboard-export-k_handler.patch
+ features/all/speakup/speakup-fix-vc_tty.patch
+ bugfix/ia64/hardcode-arch-script-output.patch
+ bugfix/mips/disable-advansys.patch