Update to 4.4-rc4

This commit is contained in:
Ben Hutchings 2015-12-14 00:48:40 +00:00
parent d68eb02a7b
commit e808d0a3f7
3 changed files with 6 additions and 20 deletions

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux-tools (4.4~rc4-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
-- Ben Hutchings <ben@decadent.org.uk> Mon, 14 Dec 2015 00:48:22 +0000
linux-tools (4.3.1-1) unstable; urgency=medium
* New upstream stable update

View File

@ -1,19 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 13 Aug 2015 20:48:12 +0200
Subject: liblockdep: Define WRITE_ONCE(), used by <linux/rbtree_augmented.h>.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/lib/lockdep/uinclude/linux/compiler.h
+++ b/tools/lib/lockdep/uinclude/linux/compiler.h
@@ -4,4 +4,10 @@
#define __used __attribute__((__unused__))
#define unlikely
+#define __ACCESS_ONCE(x) ({ \
+ __attribute__((__unused__)) typeof(x) __var = (__force typeof(x)) 0; \
+ (volatile typeof(x) *)&(x); })
+#define ACCESS_ONCE(x) (*__ACCESS_ONCE(x))
+#define WRITE_ONCE(x, val) (ACCESS_ONCE(x) = (val))
+
#endif

View File

@ -7,7 +7,6 @@ kbuild-fix-recordmcount-dependency.patch
usbip-include-uninstalled-linux-usbip-h.patch
tools-perf-man-date.patch
lockdep-fix-oot-build.patch
lockdep-fix-headers.patch
lockdep-fix-soname.patch
tools-perf-remove-shebangs.patch
tools-lib-traceevent-use-ldflags.patch