[NETFILTER] nf_queue: Fix Ooops when no queue handler registered

This is a regression introduced in 2.6.14.
    net-nf_queue-oops.patch. (Closes: #337713)

svn path=/dists/trunk/linux-2.6/; revision=4736
This commit is contained in:
Simon Horman 2005-11-07 09:18:08 +00:00
parent 1d9aac96b0
commit e7a56cf1d4
3 changed files with 31 additions and 1 deletions

5
debian/changelog vendored
View File

@ -24,12 +24,15 @@ linux-2.6 (2.6.14-3) UNRELEASED; urgency=low
automatically compenste for. (Closes: #336450)
* Redisable CONFIG_SOFTWARE_SUSPEND on ppc/miboot as it required
CONFIG_PM to compile.
* [NETFILTER] nf_queue: Fix Ooops when no queue handler registered
This is a regression introduced in 2.6.14.
net-nf_queue-oops.patch. (Closes: #337713)
[ dann frazier ]
* net-ipconntrack-nat-fix.patch - fix compilation of
ip_conntrack_helper_pptp.c when NAT is disabled. (Closes: #336431)
-- Simon Horman <horms@debian.org> Mon, 7 Nov 2005 18:05:10 +0900
-- Simon Horman <horms@debian.org> Mon, 7 Nov 2005 18:17:47 +0900
linux-2.6 (2.6.14-2) unstable; urgency=low

View File

@ -0,0 +1,26 @@
From: Harald Welte <laforge@netfilter.org>
Date: Thu, 3 Nov 2005 19:03:24 +0000 (+0100)
Subject: [NETFILTER] nf_queue: Fix Ooops when no queue handler registered
X-Git-Url: http://www.kernel.org/git/?p=linux/kernel/git/acme/net-2.6.git;a=commitdiff;h=1758ee0ea26561943813c5f5a7b27272f2cbc4cf
[NETFILTER] nf_queue: Fix Ooops when no queue handler registered
With the new nf_queue generalization in 2.6.14, we've introduced a bug
that causes an oops as soon as a packet is queued but no queue handler
registered. This patch fixes it.
Signed-off-by: Harald Welte <laforge@netfilter.org>
Signed-off-by: Arnaldo Carvalho de Melo <acme@mandriva.com>
---
--- a/net/netfilter/nf_queue.c
+++ b/net/netfilter/nf_queue.c
@@ -117,7 +117,7 @@ int nf_queue(struct sk_buff **skb,
/* QUEUE == DROP if noone is waiting, to be safe. */
read_lock(&queue_handler_lock);
- if (!queue_handler[pf]->outfn) {
+ if (!queue_handler[pf] || !queue_handler[pf]->outfn) {
read_unlock(&queue_handler_lock);
kfree_skb(*skb);
return 1;

View File

@ -1 +1,2 @@
+ net-ipconntrack-nat-fix.patch
+ net-nf_queue-oops.patch