[armel/kirkwood+orion] Reenable MARVELL_PHY (Closes: #723177)

svn path=/dists/sid/linux/; revision=20881
This commit is contained in:
Ian Campbell 2013-12-13 10:55:37 +00:00
parent 5922cb6f0b
commit e7151304b4
5 changed files with 69 additions and 4 deletions

3
debian/changelog vendored
View File

@ -33,6 +33,9 @@ linux (3.12.4-1) UNRELEASED; urgency=medium
- [/parisc64-smp] Enable PATA_SIL680, AGP, AGP_PARISC, DRM,
DRM_RADEON as modules
[ Ian Campbell ]
* [armel/kirkwood+orion] Reenable MARVELL_PHY (Closes: #723177)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 11 Dec 2013 06:04:49 +0000
linux (3.12.3-1~exp1) experimental; urgency=medium

View File

@ -458,8 +458,7 @@ CONFIG_MVMDIO=m
##
## file: drivers/net/phy/Kconfig
##
#. Turned off because this causes networking on some Kirkwood machines to fail
# CONFIG_MARVELL_PHY is not set
CONFIG_MARVELL_PHY=m
##
## file: drivers/net/wireless/mwifiex/Kconfig

View File

@ -412,8 +412,7 @@ CONFIG_MVMDIO=m
##
## file: drivers/net/phy/Kconfig
##
#. Turned off because this causes networking on some Orion machines to fail
# CONFIG_MARVELL_PHY is not set
CONFIG_MARVELL_PHY=m
##
## file: drivers/pcmcia/Kconfig

View File

@ -0,0 +1,63 @@
From: Ian Campbell <ijc@hellion.org.uk>
Subject: phy/marvell: disable 4-port phys
Date: Wed, 20 Nov 2013 08:30:14 +0000
Forwarded: no
See 723177 for more details. Briefly:
The Marvell PHY was originally disabled because it can cause networking
failures on some systems. According to Lennert Buytenhek this is because some
of the variants added did not share the same register layout. Since the known
cases are all 4-ports disable those variants (indicated by a 4 in the
penultimate position of the model name) until they can be audited for
correctness.
--- a/drivers/net/phy/marvell.c
+++ b/drivers/net/phy/marvell.c
@@ -963,6 +963,7 @@
.set_wol = &m88e1318_set_wol,
.driver = { .owner = THIS_MODULE },
},
+#if 0
{
.phy_id = MARVELL_PHY_ID_88E1145,
.phy_id_mask = MARVELL_PHY_ID_MASK,
@@ -976,6 +977,8 @@
.config_intr = &marvell_config_intr,
.driver = { .owner = THIS_MODULE },
},
+#endif
+#if 0
{
.phy_id = MARVELL_PHY_ID_88E1149R,
.phy_id_mask = MARVELL_PHY_ID_MASK,
@@ -989,6 +992,8 @@
.config_intr = &marvell_config_intr,
.driver = { .owner = THIS_MODULE },
},
+#endif
+#if 0
{
.phy_id = MARVELL_PHY_ID_88E1240,
.phy_id_mask = MARVELL_PHY_ID_MASK,
@@ -1002,6 +1007,7 @@
.config_intr = &marvell_config_intr,
.driver = { .owner = THIS_MODULE },
},
+#endif
{
.phy_id = MARVELL_PHY_ID_88E1116R,
.phy_id_mask = MARVELL_PHY_ID_MASK,
@@ -1051,9 +1057,9 @@
{ MARVELL_PHY_ID_88E1111, MARVELL_PHY_ID_MASK },
{ MARVELL_PHY_ID_88E1118, MARVELL_PHY_ID_MASK },
{ MARVELL_PHY_ID_88E1121R, MARVELL_PHY_ID_MASK },
- { MARVELL_PHY_ID_88E1145, MARVELL_PHY_ID_MASK },
- { MARVELL_PHY_ID_88E1149R, MARVELL_PHY_ID_MASK },
- { MARVELL_PHY_ID_88E1240, MARVELL_PHY_ID_MASK },
+/* { MARVELL_PHY_ID_88E1145, MARVELL_PHY_ID_MASK }, */
+/* { MARVELL_PHY_ID_88E1149R, MARVELL_PHY_ID_MASK }, */
+/* { MARVELL_PHY_ID_88E1240, MARVELL_PHY_ID_MASK }, */
{ MARVELL_PHY_ID_88E1318S, MARVELL_PHY_ID_MASK },
{ MARVELL_PHY_ID_88E1116R, MARVELL_PHY_ID_MASK },
{ MARVELL_PHY_ID_88E1510, MARVELL_PHY_ID_MASK },

View File

@ -77,3 +77,4 @@ bugfix/all/UAPI-include-asm-byteorder.h-in-linux-raid-md_p.h.patch
bugfix/all/rds-prevent-bug_on-triggered-by-congestion-update-to-loopback.patch
bugfix/all/xfs-underflow-bug-in-xfs_attrlist_by_handle.patch
bugfix/arm/ahci-imx-Explicitly-clear-IMX6Q_GPR13_SATA_MPLL_CLK_.patch
bugfix/all/disable-some-marvell-phys.patch