Enable BCMA as module, BCMA_HOST_PCI and B43_BCMA (Closes: #649567)

But limit these to devices not supported by brcmsmac.

svn path=/dists/sid/linux-2.6/; revision=18314
This commit is contained in:
Ben Hutchings 2011-11-24 07:59:05 +00:00
parent ce522b033c
commit e714f93eb8
4 changed files with 41 additions and 1 deletions

4
debian/changelog vendored
View File

@ -7,6 +7,10 @@ linux-2.6 (3.1.2-1) UNRELEASED; urgency=low
* [armel] Set the priority of pata-modules to standard since the
GLAN Tank uses PATA.
[ Ben Hutchings ]
* Enable BCMA as module, BCMA_HOST_PCI and B43_BCMA (Closes: #649567)
but limit these to devices not supported by brcmsmac
-- Ben Hutchings <ben@decadent.org.uk> Tue, 22 Nov 2011 05:26:25 +0000
linux-2.6 (3.1.1-1) unstable; urgency=high

View File

@ -197,7 +197,10 @@ CONFIG_EXTRA_FIRMWARE=""
##
## file: drivers/bcma/Kconfig
##
# CONFIG_BCMA is not set
CONFIG_BCMA=m
CONFIG_BCMA_HOST_PCI=y
# CONFIG_BCMA_DRIVER_PCI_HOSTMODE is not set
# CONFIG_BCMA_DEBUG is not set
##
## file: drivers/block/Kconfig
@ -2000,6 +2003,7 @@ CONFIG_CARL9170_LEDS=y
## file: drivers/net/wireless/b43/Kconfig
##
CONFIG_B43=m
CONFIG_B43_BCMA=y
CONFIG_B43_PCMCIA=y
CONFIG_B43_SDIO=y
CONFIG_B43_PHY_N=y

View File

@ -0,0 +1,31 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 24 Nov 2011 07:45:52 +0000
Subject: [PATCH] bcma: Do not claim PCI device IDs also claimed by brcmsmac
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/bcma/host_pci.c | 4 +++-
1 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/drivers/bcma/host_pci.c b/drivers/bcma/host_pci.c
index ac4bc62..e75e78d 100644
--- a/drivers/bcma/host_pci.c
+++ b/drivers/bcma/host_pci.c
@@ -224,11 +224,13 @@ static void bcma_host_pci_remove(struct pci_dev *dev)
}
static DEFINE_PCI_DEVICE_TABLE(bcma_pci_bridge_tbl) = {
+#if !IS_ENABLED(CONFIG_BRCMSMAC)
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x0576) },
- { PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4331) },
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4353) },
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4357) },
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4727) },
+#endif
+ { PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4331) },
{ 0, },
};
MODULE_DEVICE_TABLE(pci, bcma_pci_bridge_tbl);
--
1.7.7.3

View File

@ -72,3 +72,4 @@
+ features/arm/imx53_ahci4.patch
+ features/arm/imx53_ahci5.patch
+ debian/bcma-Do-not-claim-PCI-device-IDs-also-claimed-by-brc.patch