Update to 4.11.9

This commit is contained in:
Salvatore Bonaccorso 2017-07-09 10:25:21 +02:00
parent 49173dac27
commit e70c79cce5
3 changed files with 93 additions and 80 deletions

94
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.11.8-1) UNRELEASED; urgency=medium
linux (4.11.9-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.11.7
@ -128,6 +128,98 @@ linux (4.11.8-1) UNRELEASED; urgency=medium
- netfilter: xtables: fix build failure from COMPAT_XT_ALIGN outside
CONFIG_COMPAT
- brcmfmac: fix uninitialized warning in brcmf_usb_probe_phase2()
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.11.9
- net: don't call strlen on non-terminated string in dev_set_alias()
- net: Fix inconsistent teardown and release of private netdev state.
- [s390x] net: fix up for "Fix inconsistent teardown and release of
private netdev state"
- mac80211: free netdev on dev_alloc_name() error
- decnet: dn_rtmsg: Improve input length sanitization in
dnrmg_receive_user_skb
- net: Zero ifla_vf_info in rtnl_fill_vfinfo()
- net: ipv6: Release route when device is unregistering
- net: vrf: Make add_fib_rules per network namespace flag
- af_unix: Add sockaddr length checks before accessing sa_family in bind
and connect handlers
- Fix an intermittent pr_emerg warning about lo becoming free.
- sctp: disable BH in sctp_for_each_endpoint
- net: caif: Fix a sleep-in-atomic bug in cfpkt_create_pfx
- net: tipc: Fix a sleep-in-atomic bug in tipc_msg_reverse
- net/mlx5: Remove several module events out of ethtool stats
- net/mlx5e: Added BW check for DIM decision mechanism
- net/mlx5e: Fix wrong indications in DIM due to counter wraparound
- net/mlx5: Enable 4K UAR only when page size is bigger than 4K
- proc: snmp6: Use correct type in memset
- igmp: acquire pmc lock for ip_mc_clear_src()
- igmp: add a missing spin_lock_init()
- qmi_wwan: new Telewell and Sierra device IDs
- net: don't global ICMP rate limit packets originating from loopback
- ipv6: fix calling in6_ifa_hold incorrectly for dad work
- sctp: return next obj by passing pos + 1 into sctp_transport_get_idx
- net/mlx5e: Fix min inline value for VF rep SQs
- net/mlx5e: Avoid doing a cleanup call if the profile doesn't have it
- net/mlx5: Wait for FW readiness before initializing command interface
- net/mlx5e: Fix timestamping capabilities reporting
- decnet: always not take dst->__refcnt when inserting dst into hash table
- net: 8021q: Fix one possible panic caused by BUG_ON in free_netdev
- ipv6: Do not leak throw route references
- rtnetlink: add IFLA_GROUP to ifla_policy
- netfilter: synproxy: fix conntrackd interaction
- NFSv4.x/callback: Create the callback service through svc_create_pooled
- xen/blkback: don't use xen_blkif_get() in xen-blkback kthread
- [mips*] head: Reorder instructions missing a delay slot
- [mips*] Avoid accidental raw backtrace
- [mips*] pm-cps: Drop manual cache-line alignment of ready_count
- [mips*] Fix IRQ tracing & lockdep when rescheduling
- ALSA: hda - Fix endless loop of codec configure
- ALSA: hda - set input_path bitmap to zero after moving it to new place
- NFSv4.2: Don't send mode again in post-EXCLUSIVE4_1 SETATTR with umask
- NFSv4.1: Fix a race in nfs4_proc_layoutget
- Revert "NFS: nfs_rename() handle -ERESTARTSYS dentry left behind"
- ovl: copy-up: don't unlock between lookup and link
- gpiolib: fix filtering out unwanted events
- [x86] intel_rdt: Fix memory leak on mount failure
- [x86] perf/x86/intel/uncore: Fix wrong box pointer check
- [x86] drm/vmwgfx: Free hash table allocated by cmdbuf managed res mgr
- dm thin: do not queue freed thin mapping for next stage processing
- [x86] mm: Fix boot crash caused by incorrect loop count calculation in
sync_global_pgds()
- [arm64] pinctrl/amd: Use regular interrupt instead of chained
- mm/vmalloc.c: huge-vmap: fail gracefully on unexpected huge vmap
mappings
- xen/blkback: don't free be structure too early
- xfrm6: Fix IPv6 payload_len in xfrm6_transport_finish
- xfrm: move xfrm_garbage_collect out of xfrm_policy_flush
- xfrm: fix stack access out of bounds with CONFIG_XFRM_SUB_POLICY
- xfrm: NULL dereference on allocation failure
- xfrm: Oops on error in pfkey_msg2xfrm_state()
- [arm64] PCI: Fix struct acpi_pci_root_ops allocation failure path
- [arm64] ACPI: Fix BAD_MADT_GICC_ENTRY() macro implementation
- [arm*] 8685/1: ensure memblock-limit is pmd-aligned
- [arm*] davinci: PM: Free resources in error handling path in
'davinci_pm_init'
- [arm*] davinci: PM: Do not free useful resources in normal path in
'davinci_pm_init'
- Revert "x86/entry: Fix the end of the stack for newly forked tasks"
- [x86] boot/KASLR: Fix kexec crash due to 'virt_addr' calculation bug
- [x86] perf: Fix spurious NMI with PEBS Load Latency event
- [x86] mpx: Correctly report do_mpx_bt_fault() failures to user-space
- [x86] mm: Fix flush_tlb_page() on Xen
- ocfs2: o2hb: revert hb threshold to keep compatible
- ocfs2: fix deadlock caused by recursive locking in xattr
- iommu/dma: Don't reserve PCI I/O windows
- [amd64] iommu/amd: Fix incorrect error handling in
amd_iommu_bind_pasid()
- [amd64] iommu/amd: Fix interrupt remapping when disable guest_mode
- mtd: nand: brcmnand: Check flash #WP pin status before nand
erase/program
- mtd: nand: fsmc: fix NAND width handling
- [x86] KVM: fix emulation of RSM and IRET instructions
- [x86] KVM: vPMU: fix undefined shift in intel_pmu_refresh()
- [x86] KVM: zero base3 of unusable segments
- KVM: nVMX: Fix exception injection
- esp4: Fix udpencap for local TCP packets.
- [armhf] hsi: Fix build regression due to netdev destructor fix.
[ Ben Hutchings ]
* [m68k] udeb: Use only the common module list for nic-shared-modules

View File

@ -1,78 +0,0 @@
From: Kinglong Mee <kinglongmee@gmail.com>
Date: Thu, 27 Apr 2017 11:13:38 +0800
Subject: NFSv4.x/callback: Create the callback service through
svc_create_pooled
Origin: https://git.kernel.org/linus/df807fffaabde625fa9adb82e3e5b88cdaa5709a
Bug-Debian: https://bugs.debian.org/862357
As the comments for svc_set_num_threads() said,
" Destroying threads relies on the service threads filling in
rqstp->rq_task, which only the nfs ones do. Assumes the serv
has been created using svc_create_pooled()."
If creating service through svc_create(), the svc_pool_map_put()
will be called in svc_destroy(), but the pool map isn't used.
So that, the reference of pool map will be drop, the next using
of pool map will get a zero npools.
[ 137.992130] divide error: 0000 [#1] SMP
[ 137.992148] Modules linked in: nfsd(E) nfsv4 nfs fscache fuse tun bridge stp llc ip_set nfnetlink vmw_vsock_vmci_transport vsock snd_seq_midi snd_seq_midi_event vmw_balloon coretemp crct10dif_pclmul crc32_pclmul ppdev ghash_clmulni_intel intel_rapl_perf joydev snd_ens1371 gameport snd_ac97_codec ac97_bus snd_seq snd_pcm snd_rawmidi snd_timer snd_seq_device snd soundcore parport_pc parport nfit acpi_cpufreq tpm_tis tpm_tis_core tpm vmw_vmci i2c_piix4 shpchp auth_rpcgss nfs_acl lockd(E) grace sunrpc(E) xfs libcrc32c vmwgfx drm_kms_helper ttm crc32c_intel drm e1000 mptspi scsi_transport_spi serio_raw mptscsih mptbase ata_generic pata_acpi [last unloaded: nfsd]
[ 137.992336] CPU: 0 PID: 4514 Comm: rpc.nfsd Tainted: G E 4.11.0-rc8+ #536
[ 137.992777] Hardware name: VMware, Inc. VMware Virtual Platform/440BX Desktop Reference Platform, BIOS 6.00 07/02/2015
[ 137.993757] task: ffff955984101d00 task.stack: ffff9873c2604000
[ 137.994231] RIP: 0010:svc_pool_for_cpu+0x2b/0x80 [sunrpc]
[ 137.994768] RSP: 0018:ffff9873c2607c18 EFLAGS: 00010246
[ 137.995227] RAX: 0000000000000000 RBX: ffff95598376f000 RCX: 0000000000000002
[ 137.995673] RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffff9559944aec00
[ 137.996156] RBP: ffff9873c2607c18 R08: ffff9559944aec28 R09: 0000000000000000
[ 137.996609] R10: 0000000001080002 R11: 0000000000000000 R12: ffff95598376f010
[ 137.997063] R13: ffff95598376f018 R14: ffff9559944aec28 R15: ffff9559944aec00
[ 137.997584] FS: 00007f755529eb40(0000) GS:ffff9559bb600000(0000) knlGS:0000000000000000
[ 137.998048] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 137.998548] CR2: 000055f3aecd9660 CR3: 0000000084290000 CR4: 00000000001406f0
[ 137.999052] Call Trace:
[ 137.999517] svc_xprt_do_enqueue+0xef/0x260 [sunrpc]
[ 138.000028] svc_xprt_received+0x47/0x90 [sunrpc]
[ 138.000487] svc_add_new_perm_xprt+0x76/0x90 [sunrpc]
[ 138.000981] svc_addsock+0x14b/0x200 [sunrpc]
[ 138.001424] ? recalc_sigpending+0x1b/0x50
[ 138.001860] ? __getnstimeofday64+0x41/0xd0
[ 138.002346] ? do_gettimeofday+0x29/0x90
[ 138.002779] write_ports+0x255/0x2c0 [nfsd]
[ 138.003202] ? _copy_from_user+0x4e/0x80
[ 138.003676] ? write_recoverydir+0x100/0x100 [nfsd]
[ 138.004098] nfsctl_transaction_write+0x48/0x80 [nfsd]
[ 138.004544] __vfs_write+0x37/0x160
[ 138.004982] ? selinux_file_permission+0xd7/0x110
[ 138.005401] ? security_file_permission+0x3b/0xc0
[ 138.005865] vfs_write+0xb5/0x1a0
[ 138.006267] SyS_write+0x55/0xc0
[ 138.006654] entry_SYSCALL_64_fastpath+0x1a/0xa9
[ 138.007071] RIP: 0033:0x7f7554b9dc30
[ 138.007437] RSP: 002b:00007ffc9f92c788 EFLAGS: 00000246 ORIG_RAX: 0000000000000001
[ 138.007807] RAX: ffffffffffffffda RBX: 0000000000000002 RCX: 00007f7554b9dc30
[ 138.008168] RDX: 0000000000000002 RSI: 00005640cd536640 RDI: 0000000000000003
[ 138.008573] RBP: 00007ffc9f92c780 R08: 0000000000000001 R09: 0000000000000002
[ 138.008918] R10: 0000000000000064 R11: 0000000000000246 R12: 0000000000000004
[ 138.009254] R13: 00005640cdbf77a0 R14: 00005640cdbf7720 R15: 00007ffc9f92c238
[ 138.009610] Code: 0f 1f 44 00 00 48 8b 87 98 00 00 00 55 48 89 e5 48 83 78 08 00 74 10 8b 05 07 42 02 00 83 f8 01 74 40 83 f8 02 74 19 31 c0 31 d2 <f7> b7 88 00 00 00 5d 89 d0 48 c1 e0 07 48 03 87 90 00 00 00 c3
[ 138.010664] RIP: svc_pool_for_cpu+0x2b/0x80 [sunrpc] RSP: ffff9873c2607c18
[ 138.011061] ---[ end trace b3468224cafa7d11 ]---
Signed-off-by: Kinglong Mee <kinglongmee@gmail.com>
Signed-off-by: J. Bruce Fields <bfields@redhat.com>
---
fs/nfs/callback.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/fs/nfs/callback.c
+++ b/fs/nfs/callback.c
@@ -287,7 +287,7 @@ static struct svc_serv *nfs_callback_cre
printk(KERN_WARNING "nfs_callback_create_svc: no kthread, %d users??\n",
cb_info->users);
- serv = svc_create(&nfs4_callback_program, NFS4_CALLBACK_BUFSIZE, sv_ops);
+ serv = svc_create_pooled(&nfs4_callback_program, NFS4_CALLBACK_BUFSIZE, sv_ops);
if (!serv) {
printk(KERN_ERR "nfs_callback_create_svc: create service failed\n");
return ERR_PTR(-ENOMEM);

View File

@ -144,7 +144,6 @@ debian/i386-686-pae-pci-set-pci-nobios-by-default.patch
bugfix/all/tracing-Use-strlcpy-instead-of-strcpy-in-__trace_fin.patch
bugfix/all/sunrpc-refactor-svc_set_num_threads.patch
bugfix/all/nfsv4-fix-callback-server-shutdown.patch
bugfix/all/nfsv4.x-callback-create-the-callback-service-through.patch
# Fix exported symbol versions
bugfix/sparc/revert-sparc-move-exports-to-definitions.patch