fix kernelvariables.patch

seems needed by build for non x86..

svn path=/dists/trunk/linux-2.6/; revision=12870
This commit is contained in:
Maximilian Attems 2009-02-19 14:46:05 +00:00
parent a372fabd46
commit e6b0e1dad2
2 changed files with 23 additions and 14 deletions

View File

@ -1,8 +1,8 @@
diff --git a/Makefile b/Makefile
index f3e2065..3cc474a 100644
index 59cf6da..6e1e048 100644
--- a/Makefile
+++ b/Makefile
@@ -193,25 +193,6 @@ export KBUILD_BUILDHOST := $(SUBARCH)
@@ -193,30 +193,6 @@ export KBUILD_BUILDHOST := $(SUBARCH)
ARCH ?= $(SUBARCH)
CROSS_COMPILE ?=
@ -18,20 +18,25 @@ index f3e2065..3cc474a 100644
- SRCARCH := x86
-endif
-
-# Where to locate arch specific headers
-# Additional ARCH settings for sparc
-ifeq ($(ARCH),sparc64)
- hdr-arch := sparc
-else
- hdr-arch := $(SRCARCH)
- SRCARCH := sparc
-endif
-
-# Where to locate arch specific headers
-hdr-arch := $(SRCARCH)
-
-ifeq ($(ARCH),m68knommu)
- hdr-arch := m68k
-endif
-
KCONFIG_CONFIG ?= .config
# SHELL used by kbuild
@@ -329,6 +310,27 @@ CFLAGS_KERNEL =
@@ -334,6 +310,31 @@ LDFLAGS_MODULE =
CFLAGS_KERNEL =
AFLAGS_KERNEL =
+-include .kernelvariables
+
+# Architecture as present in compile.h
@ -46,13 +51,17 @@ index f3e2065..3cc474a 100644
+ SRCARCH := x86
+endif
+
+# Where to locate arch specific headers
+# Additional ARCH settings for sparc
+ifeq ($(ARCH),sparc64)
+ hdr-arch := sparc
+else
+ hdr-arch := $(SRCARCH)
+ SRCARCH := sparc
+endif
+
+# Where to locate arch specific headers
+hdr-arch := $(SRCARCH)
+
+ifeq ($(ARCH),m68knommu)
+ hdr-arch := m68k
+endif
# Use LINUXINCLUDE when you must reference the include/ directory.
# Needed to be compatible with the O= option
LINUXINCLUDE := -Iinclude \

View File

@ -1,5 +1,5 @@
+ debian/version.patch
#+ debian/kernelvariables.patch
+ debian/kernelvariables.patch
+ debian/doc-build-parallel.patch
+ debian/scripts-kconfig-reportoldconfig.patch