nouveau: ACPI support is dependent on X86

The ACPI support code probably wasn't very useful on ia64, and now
depends on mxm-wmi which is definitely x86-only.

svn path=/dists/trunk/linux-2.6/; revision=17603
This commit is contained in:
Ben Hutchings 2011-06-06 00:15:56 +00:00
parent eaebbd1e76
commit e67cd9e6d2
3 changed files with 62 additions and 0 deletions

2
debian/changelog vendored
View File

@ -13,6 +13,8 @@ linux-2.6 (3.0.0~rc1-1~experimental.2) UNRELEASED; urgency=low
* perf: Cancel -Werror compiler option; fixes FTBFS with perl 5.14
* qla4xxx: Remove our fix for #598503; it has now been fixed upstream
in a different way and the two changes resulted in FTBFS
* [ia64] nouveau: Disable ACPI support. It probably wasn't very useful
on ia64, and now depends on mxm-wmi which is definitely x86-only.
-- Ben Hutchings <ben@decadent.org.uk> Wed, 01 Jun 2011 06:41:14 +0100

View File

@ -0,0 +1,59 @@
From 25d4d4e2d243622dfbd35a29e3fee9ce5f099fd2 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 6 Jun 2011 00:58:46 +0100
Subject: [PATCH] nouveau: ACPI support is dependent on X86
The ACPI support code probably wasn't very useful on ia64, and now
depends on mxm-wmi which is definitely x86-only.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/gpu/drm/nouveau/Kconfig | 4 ++--
drivers/gpu/drm/nouveau/Makefile | 2 ++
drivers/gpu/drm/nouveau/nouveau_drv.h | 2 +-
3 files changed, 5 insertions(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/nouveau/Kconfig b/drivers/gpu/drm/nouveau/Kconfig
index ca16399..5a85697 100644
--- a/drivers/gpu/drm/nouveau/Kconfig
+++ b/drivers/gpu/drm/nouveau/Kconfig
@@ -11,8 +11,8 @@ config DRM_NOUVEAU
select FRAMEBUFFER_CONSOLE if !EXPERT
select FB_BACKLIGHT if DRM_NOUVEAU_BACKLIGHT
select ACPI_VIDEO if ACPI && X86 && BACKLIGHT_CLASS_DEVICE && VIDEO_OUTPUT_CONTROL && INPUT
- select ACPI_WMI if ACPI
- select MXM_WMI if ACPI
+ select ACPI_WMI if ACPI && X86
+ select MXM_WMI if ACPI && X86
help
Choose this option for open-source nVidia support.
diff --git a/drivers/gpu/drm/nouveau/Makefile b/drivers/gpu/drm/nouveau/Makefile
index 0583677..797b808 100644
--- a/drivers/gpu/drm/nouveau/Makefile
+++ b/drivers/gpu/drm/nouveau/Makefile
@@ -37,6 +37,8 @@ nouveau-y := nouveau_drv.o nouveau_state.o nouveau_channel.o nouveau_mem.o \
nouveau-$(CONFIG_DRM_NOUVEAU_DEBUG) += nouveau_debugfs.o
nouveau-$(CONFIG_COMPAT) += nouveau_ioc32.o
nouveau-$(CONFIG_DRM_NOUVEAU_BACKLIGHT) += nouveau_backlight.o
+ifdef CONFIG_X86
nouveau-$(CONFIG_ACPI) += nouveau_acpi.o
+endif
obj-$(CONFIG_DRM_NOUVEAU)+= nouveau.o
diff --git a/drivers/gpu/drm/nouveau/nouveau_drv.h b/drivers/gpu/drm/nouveau/nouveau_drv.h
index 9c56331..9ea5a17 100644
--- a/drivers/gpu/drm/nouveau/nouveau_drv.h
+++ b/drivers/gpu/drm/nouveau/nouveau_drv.h
@@ -968,7 +968,7 @@ extern int nouveau_dma_wait(struct nouveau_channel *, int slots, int size);
/* nouveau_acpi.c */
#define ROM_BIOS_PAGE 4096
-#if defined(CONFIG_ACPI)
+#if defined(CONFIG_ACPI) && defined(CONFIG_X86)
void nouveau_register_dsm_handler(void);
void nouveau_unregister_dsm_handler(void);
int nouveau_acpi_get_bios_chunk(uint8_t *bios, int offset, int len);
--
1.7.5.3

View File

@ -1,3 +1,4 @@
+ bugfix/arm/plat-iop-fixes-fail-to-build-from-source.patch
+ bugfix/mips/mips-i8259-use-struct-syscore_ops-instead-of-sysdevs.patch
- bugfix/all/qla4xxx-Fix-build-on-some-architectures-lacking-64-bit-I-O.patch
+ bugfix/ia64/nouveau-ACPI-support-is-dependent-on-X86.patch