Fix GPIOLIB vs GENERIC_GPIO selection for two more architectures

svn path=/dists/trunk/linux-2.6/; revision=18051
This commit is contained in:
Ben Hutchings 2011-09-05 03:36:39 +00:00
parent 8b5ade9bc5
commit e3ab97f0fd
4 changed files with 72 additions and 0 deletions

4
debian/changelog vendored
View File

@ -2,6 +2,10 @@ linux-2.6 (3.1.0~rc5-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate
[ Ben Hutchings ]
* [ia64] Disable GENERIC_GPIO (fixes FTBFS)
* [armel/ixp4xx] Enable GPIOLIB as well as GENERIC_GPIO (fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Mon, 05 Sep 2011 04:18:43 +0100
linux-2.6 (3.1.0~rc4-1~experimental.1) experimental; urgency=low

View File

@ -0,0 +1,38 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 5 Sep 2011 04:05:19 +0100
Subject: [PATCH 2/2] arm: ixp4xx, u300: Select ARCH_REQUIRE_GPIOLIB, not
GENERIC_GPIO
The GPIO implementations for these two machines depend on gpiolib,
so they must not select GENERIC_GPIO directly.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/arm/Kconfig | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
index f23712d..a1dbc4b 100644
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -477,7 +477,7 @@ config ARCH_IXP4XX
depends on MMU
select CLKSRC_MMIO
select CPU_XSCALE
- select GENERIC_GPIO
+ select ARCH_REQUIRE_GPIOLIB
select GENERIC_CLOCKEVENTS
select HAVE_SCHED_CLOCK
select MIGHT_HAVE_PCI
@@ -830,7 +830,7 @@ config ARCH_U300
select GENERIC_CLOCKEVENTS
select CLKDEV_LOOKUP
select HAVE_MACH_CLKDEV
- select GENERIC_GPIO
+ select ARCH_REQUIRE_GPIOLIB
help
Support for ST-Ericsson U300 series mobile platforms.
--
1.7.5.4

View File

@ -0,0 +1,28 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 1 Sep 2011 05:32:51 +0100
Subject: [PATCH 1/2] ia64, gpio: GENERIC_GPIO default must be n
Since GPIOLIB is optional on ia64, GENERIC_GPIO must not be selected by
default. If GPIOLIB is enabled, it will select GENERIC_GPIO.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/ia64/Kconfig | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/arch/ia64/Kconfig b/arch/ia64/Kconfig
index 3ff7785..27489b6 100644
--- a/arch/ia64/Kconfig
+++ b/arch/ia64/Kconfig
@@ -92,7 +92,7 @@ config HAVE_SETUP_PER_CPU_AREA
def_bool y
config GENERIC_GPIO
- def_bool y
+ bool
config DMI
bool
--
1.7.5.4

View File

@ -41,3 +41,5 @@
+ debian/cgroups-Document-the-Debian-memory-resource-controll.patch
+ bugfix/ia64/nouveau-ACPI-support-is-dependent-on-X86.patch
+ bugfix/alpha/alpha-gpio-GENERIC_GPIO-default-must-be-n.patch
+ bugfix/ia64/ia64-gpio-GENERIC_GPIO-default-must-be-n.patch
+ bugfix/arm/arm-ixp4xx-u300-Select-ARCH_REQUIRE_GPIOLIB-not-GENE.patch