[x86] Input: elantech - add Fujitsu Lifebook E556 to force crc_enabled (Closes: #835160)

This commit is contained in:
Ben Hutchings 2016-10-28 20:18:08 +01:00
parent 4456cb3bc3
commit e34c6c01c6
3 changed files with 53 additions and 0 deletions

2
debian/changelog vendored
View File

@ -7,6 +7,8 @@ linux (4.8.4-1~exp2) UNRELEASED; urgency=medium
(Closes: #841357)
* netfilter: xt_NFLOG: fix unexpected truncated packet (Closes: #841261)
* [x86] Input: i8042 - skip selftest on ASUS laptops
* [x86] Input: elantech - add Fujitsu Lifebook E556 to force crc_enabled
(Closes: #835160)
[ Salvatore Bonaccorso ]
* [x86] boot/smp: Don't try to poke disabled/non-existent APIC

View File

@ -0,0 +1,50 @@
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Date: Wed, 5 Oct 2016 22:49:30 -0700
Subject: Input: elantech - add Fujitsu Lifebook E556 to force crc_enabled
Origin: https://git.kernel.org/linus/62837b3c1a95535d1a287c9c8c6563bbd8d37033
Bug-Debian: https://bugs.debian.org/835160
Another Lifebook machine that needs the same quirk as other similar
models to make the driver working.
Also let's reorder elantech_dmi_force_crc_enabled list so LIfebook enries
are in alphabetical order.
Reported-by: William Linna <william.linna@gmail.com>
Tested-by: William Linna <william.linna@gmail.com>
Reviewed-by: Benjamin Tissoires <benjamin.tissoires@redhat.com>
Cc: stable@vger.kernel.org
Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
---
drivers/input/mouse/elantech.c | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)
--- a/drivers/input/mouse/elantech.c
+++ b/drivers/input/mouse/elantech.c
@@ -1503,6 +1503,13 @@ static const struct dmi_system_id elante
},
},
{
+ /* Fujitsu LIFEBOOK E544 does not work with crc_enabled == 0 */
+ .matches = {
+ DMI_MATCH(DMI_SYS_VENDOR, "FUJITSU"),
+ DMI_MATCH(DMI_PRODUCT_NAME, "LIFEBOOK E544"),
+ },
+ },
+ {
/* Fujitsu LIFEBOOK E554 does not work with crc_enabled == 0 */
.matches = {
DMI_MATCH(DMI_SYS_VENDOR, "FUJITSU"),
@@ -1510,10 +1517,10 @@ static const struct dmi_system_id elante
},
},
{
- /* Fujitsu LIFEBOOK E544 does not work with crc_enabled == 0 */
+ /* Fujitsu LIFEBOOK E556 does not work with crc_enabled == 0 */
.matches = {
DMI_MATCH(DMI_SYS_VENDOR, "FUJITSU"),
- DMI_MATCH(DMI_PRODUCT_NAME, "LIFEBOOK E544"),
+ DMI_MATCH(DMI_PRODUCT_NAME, "LIFEBOOK E556"),
},
},
{

View File

@ -50,6 +50,7 @@ bugfix/powerpc/powerpc-xmon-don-t-use-ld-on-32-bit.patch
bugfix/arm64/arm64-mm-limit-task_size_64-for-compatibility.patch
bugfix/x86/x86-boot-smp-Don-t-try-to-poke-disabled-non-existent.patch
bugfix/x86/input-i8042-skip-selftest-on-asus-laptops.patch
bugfix/x86/input-elantech-add-fujitsu-lifebook-e556-to-force-cr.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch