i915: Enable auto-loading even though CONFIG_DRM_I915_KMS is not set

svn path=/dists/trunk/linux-2.6/; revision=14740
This commit is contained in:
Ben Hutchings 2009-12-06 16:28:47 +00:00
parent bd182f9598
commit e1f2840848
3 changed files with 16 additions and 0 deletions

1
debian/changelog vendored
View File

@ -42,6 +42,7 @@ linux-2.6 (2.6.32-1) UNRELEASED; urgency=low
* usbnet: Set link down initially for drivers that update link state
(Closes: #444043)
* aufs2: Update to snapshot from 2009-11-29
* i915: Enable auto-loading even though CONFIG_DRM_I915_KMS is not set
[ dann frazier ]
* mac80211 (CVE-2009-4026, CVE-2009-4027):

View File

@ -0,0 +1,14 @@
diff --git a/drivers/gpu/drm/i915/i915_drv.c b/drivers/gpu/drm/i915/i915_drv.c
index 7f436ec..0c27723 100644
--- a/drivers/gpu/drm/i915/i915_drv.c
+++ b/drivers/gpu/drm/i915/i915_drv.c
@@ -52,9 +52,7 @@ static struct pci_device_id pciidlist[] = {
i915_PCI_IDS
};
-#if defined(CONFIG_DRM_I915_KMS)
MODULE_DEVICE_TABLE(pci, pciidlist);
-#endif
static int i915_suspend(struct drm_device *dev, pm_message_t state)
{

View File

@ -80,3 +80,4 @@
+ bugfix/all/atl1e-remove-broken-tsov6.patch
+ features/all/atl1e-allow-offload-disable.patch
+ bugfix/all/usbnet-link-down-initially-for-drivers-that-update.patch
+ features/all/i915-autoload-without-CONFIG_DRM_I915_KMS.patch