Update to 3.1.1

svn path=/dists/trunk/linux-2.6/; revision=18247
This commit is contained in:
Ben Hutchings 2011-11-12 04:49:59 +00:00
parent acd9830064
commit e1ec2d3c49
4 changed files with 12 additions and 49 deletions

5
debian/changelog vendored
View File

@ -1,4 +1,7 @@
linux-2.6 (3.1.0-1~experimental.2) UNRELEASED; urgency=low
linux-2.6 (3.1.1-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.1.1
[ Aurelien Jarno ]
* [s390x] Add s390x udebs, based on linux-kernel-di-s390x-2.6.

View File

@ -1,39 +0,0 @@
From: Milan Broz <mbroz@redhat.com>
Date: Mon, 22 Aug 2011 15:51:34 +0200
Subject: [PATCH] kobj_uevent: Ignore if some listeners cannot handle message
commit ebf4127cd677e9781b450e44dfaaa1cc595efcaa upstream.
kobject_uevent() uses a multicast socket and should ignore
if one of listeners cannot handle messages or nobody is
listening at all.
Easily reproducible when a process in system is cloned
with CLONE_NEWNET flag.
(See also http://article.gmane.org/gmane.linux.kernel.device-mapper.dm-crypt/5256)
Signed-off-by: Milan Broz <mbroz@redhat.com>
Acked-by: Kay Sievers <kay.sievers@vrfy.org>
Cc: stable <stable@kernel.org>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
lib/kobject_uevent.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/lib/kobject_uevent.c b/lib/kobject_uevent.c
index 70af0a7..ad72a03 100644
--- a/lib/kobject_uevent.c
+++ b/lib/kobject_uevent.c
@@ -282,7 +282,7 @@ int kobject_uevent_env(struct kobject *kobj, enum kobject_action action,
kobj_bcast_filter,
kobj);
/* ENOBUFS should be handled in userspace */
- if (retval == -ENOBUFS)
+ if (retval == -ENOBUFS || retval == -ESRCH)
retval = 0;
} else
retval = -ENOMEM;
--
1.7.5.4

View File

@ -1,8 +0,0 @@
+ bugfix/alpha/alpha-wire-up-accept4-syscall.patch
+ bugfix/all/iwlagn-fix-modinfo-display-for-135-ucode.patch
+ bugfix/powerpc/powerpc-ptrace-Fix-build-with-gcc-4.6.patch
+ bugfix/arm/ARM-add-io-read-write-16-32-be-functions.patch
+ bugfix/all/cifs-freezer-add-wait_event_freezekillable-and-have-.patch
+ bugfix/all/CIFS-Fixup-trivial-checkpatch-warning.patch
+ bugfix/all/Fix-build-break-when-freezer-not-configured.patch
+ bugfix/all/PM-Freezer-Reimplement-wait_event_freezekillable-usi.patch

View File

@ -43,8 +43,15 @@
+ bugfix/ia64/ia64-gpio-GENERIC_GPIO-default-must-be-n.patch
+ features/x86/libertas-prioritize-usb8388_olpc.bin-firmware-on-OLPC-machines.patch
+ bugfix/arm/ARM-ixp4xx-gpiolib-support.patch
+ bugfix/all/kobj_uevent-Ignore-if-some-listeners-cannot-handle-m.patch
+ bugfix/all/ark3116-initialisation-fix.patch
+ bugfix/all/xfs-fix-memory-corruption-in-xfs_readlink.patch
+ bugfix/all/xfs-fix-memory-corruption-in-xfs_readlink-2.patch
+ bugfix/all/oom-fix-integer-overflow-of-points-in-oom_badness.patch
+ bugfix/alpha/alpha-wire-up-accept4-syscall.patch
+ bugfix/all/iwlagn-fix-modinfo-display-for-135-ucode.patch
+ bugfix/powerpc/powerpc-ptrace-Fix-build-with-gcc-4.6.patch
+ bugfix/arm/ARM-add-io-read-write-16-32-be-functions.patch
+ bugfix/all/cifs-freezer-add-wait_event_freezekillable-and-have-.patch
+ bugfix/all/CIFS-Fixup-trivial-checkpatch-warning.patch
+ bugfix/all/Fix-build-break-when-freezer-not-configured.patch
+ bugfix/all/PM-Freezer-Reimplement-wait_event_freezekillable-usi.patch