Update to 4.13-rc7

This commit is contained in:
Uwe Kleine-König 2017-08-29 22:07:26 +02:00
parent b31bdbd377
commit df8a5bf53a
4 changed files with 2 additions and 50 deletions

2
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.13~rc6-1~exp1) UNRELEASED; urgency=medium
linux (4.13~rc7-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate

View File

@ -1,47 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 19 Aug 2017 21:37:18 +0100
Subject: kbuild: Do not use hyphen in exported variable name
Bug-Debian: https://bugs.debian.org/833561
Forwarded: https://marc.info/?l=linux-kbuild&m=150317820622984&w=2
This definition in Makefile.dtbinst:
export dtbinst-root ?= $(obj)
should define and export dtbinst-root when handling the root dts
directory, and do nothing in the subdirectories. However some shells,
including dash, will not pass through environment variables whose name
includes a hyphen. Usually GNU make does not use a shell to recurse,
but if e.g. $(srctree) contains '~' it will use a shell here.
Rename the variable to dtbinst_root.
References: https://bugs.debian.org/833561
Fixes: 323a028d39cdi ("dts, kbuild: Implement support for dtb vendor subdirs")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
scripts/Makefile.dtbinst | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/scripts/Makefile.dtbinst b/scripts/Makefile.dtbinst
index 34614a48b717..993fb85982df 100644
--- a/scripts/Makefile.dtbinst
+++ b/scripts/Makefile.dtbinst
@@ -14,7 +14,7 @@ src := $(obj)
PHONY := __dtbs_install
__dtbs_install:
-export dtbinst-root ?= $(obj)
+export dtbinst_root ?= $(obj)
include include/config/auto.conf
include scripts/Kbuild.include
@@ -27,7 +27,7 @@ dtbinst-dirs := $(dts-dirs)
quiet_cmd_dtb_install = INSTALL $<
cmd_dtb_install = mkdir -p $(2); cp $< $(2)
-install-dir = $(patsubst $(dtbinst-root)%,$(INSTALL_DTBS_PATH)%,$(obj))
+install-dir = $(patsubst $(dtbinst_root)%,$(INSTALL_DTBS_PATH)%,$(obj))
$(dtbinst-files): %.dtb: $(obj)/%.dtb
$(call cmd,dtb_install,$(install-dir))

View File

@ -11,7 +11,7 @@ sources.
+++ b/scripts/Makefile.build
@@ -241,6 +241,11 @@ cmd_record_mcount = \
fi;
endif
endif # CONFIG_FTRACE_MCOUNT_RECORD
+# Don't require recordmcount source for an OOT build.
+ifdef KBUILD_EXTMOD

View File

@ -74,7 +74,6 @@ features/arm64/ARM64-dts-marvell-armada-37xx-Enable-uSD-on-ESPRESSO.patch
bugfix/all/kbuild-use-nostdinc-in-compile-tests.patch
bugfix/all/disable-some-marvell-phys.patch
bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/kbuild-do-not-use-hyphen-in-exported-variable-name.patch
bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
bugfix/all/rtlwifi-fix-memory-leak-when-firmware-request-fails.patch