Update to 3.9.6

svn path=/dists/sid/linux/; revision=20251
This commit is contained in:
Ben Hutchings 2013-06-14 02:05:10 +00:00
parent 54d1d00ecd
commit df6206a096
4 changed files with 19 additions and 68 deletions

20
debian/changelog vendored
View File

@ -1,5 +1,23 @@
linux (3.9.5-2) UNRELEASED; urgency=low
linux (3.9.6-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.9.6
- xhci - correct comp_mode_recovery_timer on return from hibernate
- usb: musb: make use_sg flag URB specific
- USB: keyspan: fix bogus array index
- [arm] 7747/1: pcpu: ensure __my_cpu_offset cannot be re-ordered across
barrier()
- hpfs: fix warnings when the filesystem fills up
- cifs: fix off-by-one bug in build_unc_path_to_root
- ecryptfs: fixed msync to flush data
- eCryptfs: Check return of filemap_write_and_wait during fsync
- hwmon: (adm1021) Strengthen chip detection for ADM1021, LM84 and MAX1617
- drm: fix a use-after-free when GPU acceleration disabled
- [powerpc] pseries: Force 32 bit MSIs for devices that require it
- [powerpc] pseries: Make 32-bit MSI quirk work on systems lacking firmware
support
[ Ben Hutchings ]
* [armel/orion5x] Enable EXPERT; disable FIPS, OABI_COMPAT, PCI_QUIRKS,
VGA_ARB to reduce kernel size (really fixes FTBFS)

View File

@ -1,35 +0,0 @@
From: Guenter Roeck <linux@roeck-us.net>
Date: Sat, 8 Jun 2013 07:23:47 -0700
Subject: powerpc: Fix build error in stable/3.9
Commit e71c42189 (powerpc/tm: Abort on emulation and alignment faults)
introduced a powerpc build error in 3.9.5.
Signed-off-by: Guenter Roeck <linux@roeck-us.net>
---
No upstream commit. Compile tested only.
arch/powerpc/kernel/traps.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/powerpc/kernel/traps.c b/arch/powerpc/kernel/traps.c
index 1c22b2d..29857c6 100644
--- a/arch/powerpc/kernel/traps.c
+++ b/arch/powerpc/kernel/traps.c
@@ -1151,7 +1151,7 @@ void alignment_exception(struct pt_regs *regs)
local_irq_enable();
if (tm_abort_check(regs, TM_CAUSE_ALIGNMENT | TM_CAUSE_PERSISTENT))
- goto bail;
+ return;
/* we don't implement logging of alignment exceptions */
if (!(current->thread.align_ctl & PR_UNALIGN_SIGBUS))
--
1.7.9.7
--
To unsubscribe from this list: send the line "unsubscribe stable" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html

View File

@ -1,30 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 09 Jun 2013 16:54:12 +0100
Subject: s390: Add pgste to ptep_modify_prot_start()
Forwarded: http://article.gmane.org/gmane.linux.kernel.stable/55564
Commit 52f36be0f4e2 's390/pgtable: Fix check for pgste/storage key
handling', which was commit b56433cb782d upstream, added a use of
pgste to ptep_modify_prot_start(), but this variable does not exist.
In mainline, pgste was added by commit d3383632d4e8 's390/mm: add pte
invalidation notifier for kvm' and initialised to the return value of
pgste_get_lock(ptep). Initialise it similarly here.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/arch/s390/include/asm/pgtable.h
+++ b/arch/s390/include/asm/pgtable.h
@@ -1063,11 +1063,12 @@ static inline pte_t ptep_modify_prot_sta
unsigned long address,
pte_t *ptep)
{
+ pgste_t pgste;
pte_t pte;
mm->context.flush_mm = 1;
if (mm_has_pgste(mm))
- pgste_get_lock(ptep);
+ pgste = pgste_get_lock(ptep);
pte = *ptep;
if (!mm_exclusive(mm))

View File

@ -104,7 +104,5 @@ features/arm/imx53-qsb-usb-power.patch
features/arm/0001-thermal-Add-driver-for-Armada-370-XP-SoC-thermal-man.patch
features/arm/0001-ARM-mvebu-Add-thermal-support-to-Armada-XP-device-tr.patch
bugfix/s390/s390-add-pgste-to-ptep_modify_prot_start.patch
bugfix/powerpc/powerpc-fix-build-error-in-stable-3.9.patch
bugfix/all/ath9k-Disable-PowerSave-by-default.patch
bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch