Merge branch 'rename-boston' into 'master'

mips*: enable some new features for Loongson-3; mips*r6*: switch target to boston

See merge request kernel-team/linux!22
This commit is contained in:
Ben Hutchings 2018-05-14 13:11:46 +00:00
commit ded0a7ea09
13 changed files with 67 additions and 8 deletions

9
debian/changelog vendored
View File

@ -31,6 +31,15 @@ linux (4.17~rc4-1~exp1) UNRELEASED; urgency=medium
[ Jason Duerstock ]
* [ia64] udeb: Add compress-modules package (fixes FTBFS)
[ YunQiang Su ]
* [mips{,64}el/loongson-3] enable NUMA, CPU_PM, CPU_IDLE, RS780_HPET,
REGULATOR. (Closes: #898521).
* [mips{,64}r6{,el}] use boston as the target.
Add a patch to disable uImage generation to avoid depend on u-boot-tools.
Fix typo the EL's flavor names in installer: not same within defines
Malta is never used for r6. (Closes: #898523)
Boston also requires relocation table size >= 0x00121000.
-- Luca Boccassi <bluca@debian.org> Wed, 02 May 2018 12:59:01 +0100
linux (4.17~rc3-1~exp1) experimental; urgency=medium

View File

@ -0,0 +1,11 @@
##
## file: arch/mips/Kconfig
##
## choice: System type
CONFIG_MIPS_GENERIC=y
CONFIG_RELOCATION_TABLE_SIZE=0x00121000
## end choice
##
## Common Clock Framework
##
CONFIG_COMMON_CLK_BOSTON=y

View File

@ -11,14 +11,26 @@ CONFIG_64BIT=y
CONFIG_SMP=y
CONFIG_HOTPLUG_CPU=y
CONFIG_NR_CPUS=16
CONFIG_NUMA=y
##
## file: kernel/power/Kconfig
##
CONFIG_CPU_PM=y
##
## file: arch/mips/loongson64/Kconfig
##
## choice: Machine Type
CONFIG_LOONGSON_MACH3X=y
CONFIG_RS780_HPET=y
## end choice
##
## file: drivers/cpuidle/Kconfig
##
CONFIG_CPU_IDLE=y
##
## file: drivers/ata/Kconfig
##
@ -66,6 +78,11 @@ CONFIG_8139TOO=m
##
CONFIG_RTC_DRV_CMOS=y
##
## file: drivers/regulator/Kconfig
##
CONFIG_REGULATOR=y
##
## file: drivers/tty/serial/8250/Kconfig
##

View File

@ -15,6 +15,6 @@ hardware-long: MIPS R6 (64 bit, big endian)
[mips64r6_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips64r6

View File

@ -15,6 +15,6 @@ hardware-long: MIPS R6 (64 bit, little endian)
[mips64r6el_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips64r6

View File

@ -16,7 +16,7 @@ hardware-long: MIPS R6 (32 bit, big endian)
[mips32r6_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips32r6
[mips64r6_description]
@ -25,6 +25,6 @@ hardware-long: MIPS R6 (64 bit, big endian)
[mips64r6_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips64r6

View File

@ -16,7 +16,7 @@ hardware-long: MIPS R6 (32 bit, little endian)
[mips32r6el_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips32r6
[mips64r6el_description]
@ -25,6 +25,6 @@ hardware-long: MIPS R6 (64 bit, little endian)
[mips64r6el_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips64r6

View File

@ -1,2 +1,2 @@
# arch version flavour installedname suffix build-depends
mips64r6el - mips64r6 - y -
mips64r6el - mips64r6el - y -

View File

@ -1,2 +1,2 @@
# arch version flavour installedname suffix build-depends
mipsr6el - mips32r6 - y -
mipsr6el - mips32r6el - y -

View File

@ -0,0 +1,21 @@
From: YunQiang Su <syq@debian.org>
Date: Mon, 14 May 2018 16:16:18 +0800
Subject: Disable uImage generation for mips generic
Forwarded: not-needed
MIPS generic trys to generate uImage when build, which then ask for
u-boot-tools.
Index: b/arch/mips/generic/Platform
===================================================================
--- a/arch/mips/generic/Platform
+++ b/arch/mips/generic/Platform
@@ -11,8 +11,6 @@
platform-$(CONFIG_MIPS_GENERIC) += generic/
cflags-$(CONFIG_MIPS_GENERIC) += -I$(srctree)/arch/mips/include/asm/mach-generic
load-$(CONFIG_MIPS_GENERIC) += 0xffffffff80100000
-all-$(CONFIG_MIPS_GENERIC) := vmlinux.gz.itb
-its-y := vmlinux.its.S
its-$(CONFIG_FIT_IMAGE_FDT_BOSTON) += board-boston.its.S
its-$(CONFIG_FIT_IMAGE_FDT_NI169445) += board-ni169445.its.S

View File

@ -5,6 +5,7 @@ debian/kernelvariables.patch
debian/gitignore.patch
debian/ia64-hardcode-arch-script-output.patch
debian/mips-disable-werror.patch
debian/mips-boston-disable-its.patch
debian/arch-sh4-fix-uimage-build.patch
debian/powerpcspe-omit-uimage.patch
debian/modpost-symbol-prefix.patch