* sym2: only claim "Storage" class devices - the cpqarray driver should be
  used for 5c1510 devices in RAID mode. (closes: #380272)

svn path=/dists/sid/linux-2.6/; revision=7276
This commit is contained in:
dann frazier 2006-08-30 01:02:28 +00:00
parent 62d37caa17
commit db7fe57626
3 changed files with 37 additions and 2 deletions

8
debian/changelog vendored
View File

@ -15,9 +15,13 @@ linux-2.6 (2.6.17-8) UNRELEASED; urgency=low
* ia64: Pull in compile-failure fix from Christian Cotte-Barrot.
Pulled from linux-ia64 mailing list. Fix is correct.
* hppa/alpha/mips: Fix compile-failure due to missing arch_mmap_check. Patch sent
upstream to stable@kernel.org.
upstream to stable@kernel.org.
-- Kyle McMartin <kyle@debian.org> Tue, 29 Aug 2006 12:34:00 -0400
[ dann frazier ]
* sym2: only claim "Storage" class devices - the cpqarray driver should be
used for 5c1510 devices in RAID mode. (closes: #380272)
-- dann frazier <dannf@debian.org> Tue, 29 Aug 2006 18:44:26 -0600
linux-2.6 (2.6.17-7) unstable; urgency=low

View File

@ -2,3 +2,4 @@
+ sound-pci-hda-intel-d965.diff
+ sound-pci-hda-mac-mini-intel945.diff
+ fix-non-asm-generic-mman-h.patch
+ sym2-claim-only-storage.diff

View File

@ -0,0 +1,30 @@
From: Grant Grundler <grundler@parisc-linux.org>
Date: Mon, 17 Jul 2006 13:22:45 +0000 (-0600)
Subject: [SCSI] sym2: claim only "Storage" class
X-Git-Tag: v2.6.18-rc3
X-Git-Url: http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=b2b3c121076961333977f485f0d54c22121df920
[SCSI] sym2: claim only "Storage" class
The follow patch fixes a problem for Matt Taggart.
The Compaq system he had (dl380?) has a SmartArray device that exposes
the 53c1510 device in both RAID and "normal" modes. The difference
is in RAID mode, the smart array driver (IIRC) should claim the
device instead of sym2 driver. Patch below prevents sym2 from
claiming the device when the RAID "daughter board" is attached.
Signed-off-by: Grant Grundler <grundler@parisc-linux.org>
Signed-off-by: James Bottomley <James.Bottomley@SteelEye.com>
---
--- a/drivers/scsi/sym53c8xx_2/sym_glue.c
+++ b/drivers/scsi/sym53c8xx_2/sym_glue.c
@@ -2084,7 +2084,7 @@ static struct pci_device_id sym2_id_tabl
{ PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_NCR_53C860,
PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
{ PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_53C1510,
- PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
+ PCI_ANY_ID, PCI_ANY_ID, PCI_CLASS_STORAGE_SCSI<<8, 0xffff00, 0UL },
{ PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_NCR_53C896,
PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0UL },
{ PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_NCR_53C895,