r8712u: Firmware filename is rtlwifi/rtl8712u.bin (Closes: #602450)

svn path=/dists/trunk/linux-2.6/; revision=16847
This commit is contained in:
Ben Hutchings 2011-01-24 01:54:24 +00:00
parent 3b19bfc2e8
commit db7f6530f1
3 changed files with 53 additions and 0 deletions

1
debian/changelog vendored
View File

@ -4,6 +4,7 @@ linux-2.6 (2.6.37-1~experimental.2) UNRELEASED; urgency=low
* [arm] ixp4xx: Revert build fix, now applied upstream which resulted
in another build failure
* r8169: Keep firmware in memory (Closes: #609538)
* r8712u: Firmware filename is rtlwifi/rtl8712u.bin (Closes: #602450)
[ Aurelien Jarno ]
* [sh4] Export cpu_core_map to fix build failure with CONFIG_SFC=m.

View File

@ -0,0 +1,50 @@
From: Larry Finger <Larry.Finger@lwfinger.net>
Date: Fri, 14 Jan 2011 15:02:18 -0600
Subject: [PATCH] staging: r8712u: Firmware changes for driver
commit b54a28a418b2730bf61554864fee3fb24f79e182 upstream.
* select FW_LOADER in Kconfig - From: Stefan Lippers-Hollmann <s.l-h@gmx.de>
* declare MODULE_FIRMWARE for r8712u and change to correct directory
* delete 10K line farray.h containing internal firmware
Signed-off-by: Larry Finger <Larry.Finger@lwfinger.net>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
[bwh: Strip removal of farray.h]
---
diff --git a/drivers/staging/rtl8712/Kconfig b/drivers/staging/rtl8712/Kconfig
index 1e9a230..041e1e8 100644
--- a/drivers/staging/rtl8712/Kconfig
+++ b/drivers/staging/rtl8712/Kconfig
@@ -3,6 +3,7 @@ config R8712U
depends on WLAN && USB
select WIRELESS_EXT
select WEXT_PRIV
+ select FW_LOADER
default N
---help---
This option adds the Realtek RTL8712 USB device such as the D-Link DWA-130.
diff --git a/drivers/staging/rtl8712/hal_init.c b/drivers/staging/rtl8712/hal_init.c
index 014fbbc..8323c6a 100644
--- a/drivers/staging/rtl8712/hal_init.c
+++ b/drivers/staging/rtl8712/hal_init.c
@@ -40,7 +40,7 @@ static u32 rtl871x_open_fw(struct _adapter *padapter, void **pphfwfile_hdl,
const u8 **ppmappedfw)
{
int rc;
- const char firmware_file[] = "rtl8712u/rtl8712u.bin";
+ const char firmware_file[] = "rtlwifi/rtl8712u.bin";
const struct firmware **praw = (const struct firmware **)
(pphfwfile_hdl);
struct dvobj_priv *pdvobjpriv = (struct dvobj_priv *)
@@ -58,6 +58,7 @@ static u32 rtl871x_open_fw(struct _adapter *padapter, void **pphfwfile_hdl,
*ppmappedfw = (u8 *)((*praw)->data);
return (*praw)->size;
}
+MODULE_FIRMWARE("rtlwifi/rtl8712u.bin");
static void fill_fwpriv(struct _adapter *padapter, struct fw_priv *pfwpriv)
{
--
1.7.2.3

View File

@ -1,3 +1,5 @@
- bugfix/arm/ixp4xx-add-missing-export.patch
+ bugfix/sh4/sh-export-topology-core-cpumask.patch
+ bugfix/all/r8169-keep-firmware-in-memory.patch
- features/all/r8712u-Fix-external-firmware-loading.patch
+ features/all/r8712u-Firmware-changes-for-driver.patch