Fix compilation error in dz serial driver.

svn path=/dists/trunk/linux-2.6/; revision=6896
This commit is contained in:
Martin Michlmayr 2006-06-26 16:20:50 +00:00
parent 431187fa5a
commit da61afde92
3 changed files with 32 additions and 0 deletions

3
debian/changelog vendored
View File

@ -10,6 +10,9 @@ linux-2.6 (2.6.17-2) UNRELEASED; urgency=low
* [powerpc] Added console=hvc0 default commandline option to powerpc64 flavour.
* [powerpc] Now THERM_PM72 and all WINDFARMs are builtin, for better fan control.
[ Martin Michlmayr ]
* [mipsel] Fix compilation error in dz serial driver.
-- Jurij Smakov <jurij@debian.org> Sat, 24 Jun 2006 10:54:59 -0700
linux-2.6 (2.6.17-1) unstable; urgency=low

28
debian/patches/serial-dz.patch vendored Normal file
View File

@ -0,0 +1,28 @@
# Status: submitted to linux-serial
Subject: [PATCH] serial: Fix compilation error in dz.c
Fix the following compilation error in the dz serial driver that got
introduced with the "kernel console should send CRLF not LFCR" change.
CC drivers/serial/dz.o
drivers/serial/dz.c: In function 'dz_console_putchar':
drivers/serial/dz.c:679: error: 'uport' undeclared (first use in this function)
drivers/serial/dz.c:679: error: (Each undeclared identifier is reported only once
drivers/serial/dz.c:679: error: for each function it appears in.)
Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
--- a/drivers/serial/dz.c
+++ b/drivers/serial/dz.c
@@ -674,7 +674,7 @@ static void dz_reset(struct dz_port *dpo
}
#ifdef CONFIG_SERIAL_DZ_CONSOLE
-static void dz_console_putchar(struct uart_port *port, int ch)
+static void dz_console_putchar(struct uart_port *uport, int ch)
{
struct dz_port *dport = (struct dz_port *)uport;
unsigned long flags;

1
debian/patches/series/2 vendored Normal file
View File

@ -0,0 +1 @@
+ serial-dz.patch