drm/nouveau/disp/gf119: add missing drive vfunc ptr

Closes: #880660
This commit is contained in:
Salvatore Bonaccorso 2018-01-13 11:51:52 +01:00
parent 30fe681bff
commit da2cd8b85c
3 changed files with 49 additions and 0 deletions

1
debian/changelog vendored
View File

@ -44,6 +44,7 @@ linux (4.14.13-1) UNRELEASED; urgency=medium
[ Salvatore Bonaccorso ]
* libsas: Disable asynchronous aborts for SATA devices
* drm/nouveau/disp/gf119: add missing drive vfunc ptr (Closes: #880660)
[ Riku Voipio ]
* [arm64] disable CONFIG_HW_RANDOM_OMAP until the IRQ storm bug is fixed

View File

@ -0,0 +1,47 @@
From: Rob Clark <robdclark@gmail.com>
Date: Sat, 6 Jan 2018 10:59:41 -0500
Subject: drm/nouveau/disp/gf119: add missing drive vfunc ptr
Origin: https://git.kernel.org/linus/1b5c7ef3d0d0610bda9b63263f7c5b7178d11015
Bug-Debian: https://bugs.debian.org/880660
Fixes broken dp on GF119:
Call Trace:
? nvkm_dp_train_drive+0x183/0x2c0 [nouveau]
nvkm_dp_acquire+0x4f3/0xcd0 [nouveau]
nv50_disp_super_2_2+0x5d/0x470 [nouveau]
? nvkm_devinit_pll_set+0xf/0x20 [nouveau]
gf119_disp_super+0x19c/0x2f0 [nouveau]
process_one_work+0x193/0x3c0
worker_thread+0x35/0x3b0
kthread+0x125/0x140
? process_one_work+0x3c0/0x3c0
? kthread_park+0x60/0x60
ret_from_fork+0x25/0x30
Code: Bad RIP value.
RIP: (null) RSP: ffffb1e243e4bc38
CR2: 0000000000000000
Fixes: af85389c614a drm/nouveau/disp: shuffle functions around
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=103421
Signed-off-by: Rob Clark <robdclark@gmail.com>
Signed-off-by: Ben Skeggs <bskeggs@redhat.com>
---
drivers/gpu/drm/nouveau/nvkm/engine/disp/sorgf119.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/nouveau/nvkm/engine/disp/sorgf119.c b/drivers/gpu/drm/nouveau/nvkm/engine/disp/sorgf119.c
index a2978a37b4f3..700fc754f28a 100644
--- a/drivers/gpu/drm/nouveau/nvkm/engine/disp/sorgf119.c
+++ b/drivers/gpu/drm/nouveau/nvkm/engine/disp/sorgf119.c
@@ -174,6 +174,7 @@ gf119_sor = {
.links = gf119_sor_dp_links,
.power = g94_sor_dp_power,
.pattern = gf119_sor_dp_pattern,
+ .drive = gf119_sor_dp_drive,
.vcpi = gf119_sor_dp_vcpi,
.audio = gf119_sor_dp_audio,
.audio_sym = gf119_sor_dp_audio_sym,
--
2.15.1

View File

@ -83,6 +83,7 @@ bugfix/all/i40e-fix-flags-declaration.patch
bugfix/all/xen-time-do-not-decrease-steal-time-after-live-migra.patch
bugfix/all/e1000e-fix-e1000_check_for_copper_link_ich8lan-return-value.patch
bugfix/all/libsas-Disable-asynchronous-aborts-for-SATA-devices.patch
bugfix/all/drm-nouveau-disp-gf119-add-missing-drive-vfunc-ptr.patch
# Miscellaneous features