[x86] drm/i915: Only kick out vesafb if we takeover the fbcon with KMS (Closes: #686284)

svn path=/dists/sid/linux/; revision=19487
This commit is contained in:
Ben Hutchings 2012-11-09 05:43:10 +00:00
parent 8168aa3085
commit da2c29d21c
3 changed files with 38 additions and 0 deletions

2
debian/changelog vendored
View File

@ -41,6 +41,8 @@ linux (3.2.33-1) UNRELEASED; urgency=low
* udeb: Add bnx2fc, fnic, pmcraid to scsi-extra-modules
* udeb: Move rtl8180 to nic-extra-modules
* [x86] asus-laptop: Do not call HWRS on init (Closes: #692436)
* [x86] drm/i915: Only kick out vesafb if we takeover the fbcon with KMS
(Closes: #686284)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 24 Oct 2012 14:15:57 +0100

View File

@ -0,0 +1,35 @@
From: Chris Wilson <chris@chris-wilson.co.uk>
Date: Fri, 26 Oct 2012 12:06:41 +0100
Subject: drm/i915: Only kick out vesafb if we takeover the fbcon with KMS
commit 1623392af9da983f3ad088a75076c9da05e5600d upstream.
Otherwise we may remove the only console for a nomodeset system.
We became more aggressive in our kicking with
commit e188719a2891f01b3100dca4ae3a055fb5a7ab52
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date: Tue Jun 12 11:28:17 2012 +0200
drm/i915: kick any firmware framebuffers before claiming the gtt
Reported-and-tested-by: monnier@iro.umontreal.ca
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=54615
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
---
drivers/gpu/drm/i915/i915_dma.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
--- a/drivers/gpu/drm/i915/i915_dma.c
+++ b/drivers/gpu/drm/i915/i915_dma.c
@@ -1955,7 +1955,8 @@ int i915_driver_load(struct drm_device *
goto put_bridge;
}
- i915_kick_out_firmware_fb(dev_priv);
+ if (drm_core_check_feature(dev, DRIVER_MODESET))
+ i915_kick_out_firmware_fb(dev_priv);
/* overlay on gen2 is broken and can't address above 1G */
if (IS_GEN2(dev))

View File

@ -405,3 +405,4 @@ debian/xfrm-avoid-ABI-change-in-3.2.31.patch
bugfix/all/use-clamp_t-in-UNAME26-fix.patch
debian/fs-writeback-avoid-ABI-change-in-3.2.32.patch
bugfix/x86/asus-laptop-Do-not-call-HWRS-on-init.patch
bugfix/x86/drm-i915-Only-kick-out-vesafb-if-we-takeover-the-fbc.patch