[armel/kirkwood] dts: Fix QNAP TS219 power-off (Closes: #807696)

This commit is contained in:
Ben Hutchings 2015-12-11 18:36:54 +00:00
parent dc05a59cb1
commit d89f74a7ba
3 changed files with 33 additions and 0 deletions

1
debian/changelog vendored
View File

@ -10,6 +10,7 @@ linux (4.3.1-1~exp1) UNRELEASED; urgency=medium
* [armhf] Enable MACH_ARMADA_375, MACH_ARMADA_38X, MACH_ARMADA_39X
(Closes: #807633)
* [armhf] net: Enable MVPP2 as module
* [armel/kirkwood] dts: Fix QNAP TS219 power-off (Closes: #807696)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 09 Dec 2015 23:20:32 +0000

View File

@ -0,0 +1,31 @@
From: Helmut Klein <hgkr.klein@gmail.com>
Date: Wed, 11 Nov 2015 15:03:04 +0100
Subject: ARM: dts: Kirkwood: Fix QNAP TS219 power-off
Origin: https://git.kernel.org/linus/5442f0eadf2885453d5b2ed8c8592f32a3744f8e
The "reg" entry in the "poweroff" section of "kirkwood-ts219.dtsi"
addressed the wrong uart (0 = console). This patch changes the address
to select uart 1, which is the uart connected to the pic
microcontroller, which can switch the device off.
Signed-off-by: Helmut Klein <hgkr.klein@gmail.com>
Signed-off-by: Andrew Lunn <andrew@lunn.ch>
Fixes: 4350a47bbac3 ("ARM: Kirkwood: Make use of the QNAP Power off driver.")
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
---
arch/arm/boot/dts/kirkwood-ts219.dtsi | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/kirkwood-ts219.dtsi b/arch/arm/boot/dts/kirkwood-ts219.dtsi
index c56ab6b..0e46560 100644
--- a/arch/arm/boot/dts/kirkwood-ts219.dtsi
+++ b/arch/arm/boot/dts/kirkwood-ts219.dtsi
@@ -40,7 +40,7 @@
};
poweroff@12100 {
compatible = "qnap,power-off";
- reg = <0x12000 0x100>;
+ reg = <0x12100 0x100>;
clocks = <&gate_clk 7>;
};
spi@10600 {

View File

@ -96,3 +96,4 @@ bugfix/all/isdn_ppp-add-checks-for-allocation-failure-in-isdn_p.patch
bugfix/all/ppp-slip-validate-vj-compression-slot-parameters-com.patch
bugfix/all/btrfs-fix-truncation-of-compressed-and-inlined-exten.patch
bugfix/x86/drm-i915-shut-up-gen8-sde-irq-dmesg-noise.patch
bugfix/arm/arm-dts-kirkwood-fix-qnap-ts219-power-off.patch