Revert incorrect change to powerpc clocksource setup

svn path=/dists/trunk/linux-2.6/; revision=15122
This commit is contained in:
Ben Hutchings 2010-02-04 21:08:38 +00:00
parent 3e1c5d2328
commit d80218483d
3 changed files with 23 additions and 0 deletions

1
debian/changelog vendored
View File

@ -9,6 +9,7 @@ linux-2.6 (2.6.32-8) UNRELEASED; urgency=low
[ Ben Hutchings ]
* Build lgs8gxx driver along with cxusb (Closes: #568414)
* Revert incorrect change to powerpc clocksource setup
-- Bastian Blank <waldi@debian.org> Thu, 04 Feb 2010 12:08:47 +0100

View File

@ -0,0 +1,20 @@
--- a/kernel/time/clocksource.c
+++ b/kernel/time/clocksource.c
@@ -466,8 +466,6 @@ void clocksource_touch_watchdog(void)
clocksource_resume_watchdog();
}
-#ifdef CONFIG_GENERIC_TIME
-
/**
* clocksource_max_deferment - Returns max time the clocksource can be deferred
* @cs: Pointer to clocksource
@@ -509,6 +507,8 @@ static u64 clocksource_max_deferment(struct clocksource *cs)
return max_nsecs - (max_nsecs >> 5);
}
+#ifdef CONFIG_GENERIC_TIME
+
/**
* clocksource_select - Select the best clocksource available
*

View File

@ -2,3 +2,5 @@
+ bugfix/powerpc/powerpc-tif_abi_pending-bit-removal.patch
+ bugfix/sparc/sparc-tif_abi_pending-bit-removal.patch
+ bugfix/all/cxusb-select-lgs8gxx.patch
- bugfix/all/clocksource-events-Fix-fallout-of-generic-code-changes.patch
+ bugfix/all/clocksource-always-define-clocksource_max_deferment.patch