Enable write buffer coalescing

svn path=/dists/trunk/linux-2.6/; revision=10908
This commit is contained in:
Martin Michlmayr 2008-03-17 10:08:54 +00:00
parent 98c00a4b82
commit d764ea8854
2 changed files with 32 additions and 0 deletions

1
debian/changelog vendored
View File

@ -50,6 +50,7 @@ linux-2.6 (2.6.25~rc6-1~experimental.1) UNRELEASED; urgency=low
* [mips/r5k-ip32] Use the generic config options for NFS, which will
enable NFSv4. (closes: #471007)
* [mips/r5k-ip32] Enable R8169, requested by Giuseppe Sacco.
* [arm/iop32x] Enable write buffer coalescing (Arnaud Patard).
[ Daniel Baumann ]
* Added patch from unionfs upstream to export release_open_intent symbol.

View File

@ -0,0 +1,31 @@
From: Arnaud Patard <arnaud.patard@rtp-net.org>
[PATCH] Enable write buffer coalescing
RedBoot is disabling write buffer coalescing before giving the hand to
linux. As there's no place in the kernel reenabling it, the performances
are poor (see
http://lists.arm.linux.org.uk/lurker/message/20080308.225920.2ae2af55.en.html).
This patch reenable it.
Signed-off-by: Arnaud Patard <arnaud.patard@rtp-net.org>
---
arch/arm/mm/proc-xscale.S | 4 4 + 0 - 0 !
1 file changed, 4 insertions(+)
Index: linux-2.6/arch/arm/mm/proc-xscale.S
===================================================================
--- linux-2.6.orig/arch/arm/mm/proc-xscale.S 2008-03-09 00:37:05.000000000 +0100
+++ linux-2.6/arch/arm/mm/proc-xscale.S 2008-03-09 12:27:50.000000000 +0100
@@ -114,6 +114,10 @@ clean_addr: .word CLEAN_ADDR
* Nothing too exciting at the moment
*/
ENTRY(cpu_xscale_proc_init)
+ @ enable write buffer coalescing. Some bootloader disable it
+ mrc p15, 0, r1, c1, c0, 1
+ bic r1, r1, #1
+ mcr p15, 0, r1, c1, c0, 1
mov pc, lr
/*