Revert "i40e: Add kconfig dependency to ensure cmpxchg64() is available"

The bug that prompted this was fixed upstream in 4.17 by commit
8f769dd14a43 "i40e: re-number feature flags to remove gaps".
This commit is contained in:
Ben Hutchings 2018-09-16 16:13:00 +01:00
parent 6b3296f897
commit d7423140dd
3 changed files with 1 additions and 27 deletions

1
debian/changelog vendored
View File

@ -150,6 +150,7 @@ linux (4.18.7-1) UNRELEASED; urgency=medium
* debian/watch: Add options for signature validation
* README.Debian: Update URLs that were pointing to Alioth
* README.Debian: Describe where to find patches for a specific version
* Revert "i40e: Add kconfig dependency to ensure cmpxchg64() is available"
[ Salvatore Bonaccorso ]
* mac80211: don't update the PM state of a peer upon a multicast frame

View File

@ -1,26 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 15 Mar 2018 19:02:28 +0000
Subject: i40e: Add kconfig dependency to ensure cmpxchg64() is available
i40e again uses cmpxchg64(), which isn't available in some 32-bit SMP
configurations. It seems reasonable to expect that 40G hardware is
not used on 32-bit systems.
Fixes: 60f481b97038 ("i40e: change flags to use 64 bits")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/net/ethernet/intel/Kconfig | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/net/ethernet/intel/Kconfig b/drivers/net/ethernet/intel/Kconfig
index 1feb54b6d92e..dd17bdf5561e 100644
--- a/drivers/net/ethernet/intel/Kconfig
+++ b/drivers/net/ethernet/intel/Kconfig
@@ -215,6 +215,7 @@ config I40E
tristate "Intel(R) Ethernet Controller XL710 Family support"
imply PTP_1588_CLOCK
depends on PCI
+ depends on 64BIT || X86_CMPXCHG64
---help---
This driver supports Intel(R) Ethernet Controller XL710 Family of
devices. For more information on how to identify your adapter, go

View File

@ -96,7 +96,6 @@ bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/i40e-build-for-64-bit-targets-only.patch
bugfix/all/netfilter-ipvs-Fix-invalid-bytes-in-IP_VS_MH_TAB_IND.patch
bugfix/all/mac80211-don-t-update-the-PM-state-of-a-peer-upon-a-.patch