Merge linux-tools from trunk to sid

svn path=/dists/sid/linux-tools/; revision=20188
This commit is contained in:
Ben Hutchings 2013-06-03 12:26:08 +00:00
parent cc2ca471cd
commit d686671722
6 changed files with 31 additions and 24 deletions

View File

@ -9,6 +9,22 @@ include $(top_srcdir)/debian/build/Makefile.inc
modpost.real-$(TYPE): file2alias.real-$(TYPE).o modpost.real-$(TYPE).o sumversion.real-$(TYPE).o
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
%.real-$(TYPE).o: $(SOURCEDIR)/%.c
$(CC) -I real-$(TYPE) $(CFLAGS) -c -o $@ $^
%.real-$(TYPE).o: $(SOURCEDIR)/%.c real-$(TYPE)/devicetable-offsets.h
$(CC) -I real-$(TYPE) $(CFLAGS) -c -o $@ $<
WORD_SIZE := $(subst lsb-,,$(subst msb-,,$(TYPE)))
# XXX This doesn't quite work, because if we cross-build between 64-bit
# architectures they may have different alignment for pointers (aka
# kernel_ulong_t). This particularly affects i2c_device_id and
# platform_device_id.
real-$(TYPE)/devicetable-offsets.s: $(SOURCEDIR)/devicetable-offsets.c
$(CC) $(CFLAGS) -include linux/types.h -Dkernel_ulong_t=__u$(WORD_SIZE) -S -o $@ $<
real-$(TYPE)/devicetable-offsets.h: real-$(TYPE)/devicetable-offsets.s
echo >$@ "#define __DEVICEVTABLE_OFFSETS_H__"
sed -ne "/^->/{s:->#\(.*\):/* \1 */:; \
s:^->\([^ ]*\) [\$$#]*\([-0-9]*\) \(.*\):#define \1 \2 /* \3 */:; \
s:^->\([^ ]*\) [\$$#]*\([^ ]*\) \(.*\):#define \1 \2 /* \3 */:; \
s:->::; p;}" $< >>$@

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux-tools (3.9.3-1~experimental.1) UNRELEASED; urgency=low
* New upstream release
-- Ben Hutchings <ben@decadent.org.uk> Tue, 21 May 2013 02:15:28 +0100
linux-tools (3.8.11-1) unstable; urgency=low
* New upstream stable update

View File

@ -1,5 +1,4 @@
modpost-symbol-prefix.patch
tools-perf-version.patch
tools-perf-install.patch
usbip-update-man-pages.patch
usbip-document-tcp-wrappers.patch

View File

@ -1,6 +1,6 @@
--- a/tools/perf/Makefile
+++ b/tools/perf/Makefile
@@ -1105,20 +1105,20 @@ install: all try-install-man
@@ -1145,20 +1145,20 @@ install-bin: all
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'
$(INSTALL) $(OUTPUT)perf-archive -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)'
@ -26,5 +26,5 @@
- $(INSTALL) tests/attr/* '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'
+ $(INSTALL) -m 644 tests/attr/* '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'
install-python_ext:
$(PYTHON_WORD) util/setup.py --quiet install --root='/$(DESTDIR_SQ)'
install: install-bin try-install-man

View File

@ -1,15 +1,15 @@
--- a/tools/perf/Makefile
+++ b/tools/perf/Makefile
@@ -1101,7 +1101,7 @@ perfexec_instdir_SQ = $(subst ','\'',$(p
@@ -1141,7 +1141,7 @@ perfexec_instdir_SQ = $(subst ','\'',$(p
install: all try-install-man
install-bin: all
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'
- $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)/perf_$(VERSION)'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'
$(INSTALL) $(OUTPUT)perf-archive -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)'
@@ -1114,7 +1114,7 @@ install: all try-install-man
@@ -1154,7 +1154,7 @@ install-bin: all
$(INSTALL) scripts/python/*.py -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python'
$(INSTALL) scripts/python/bin/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/bin'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d'
@ -18,7 +18,7 @@
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'
$(INSTALL) tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'
@@ -1125,7 +1125,7 @@ install-python_ext:
@@ -1167,7 +1167,7 @@ install-python_ext:
# 'make install-doc' should call 'make -C Documentation install'
$(INSTALL_DOC_TARGETS):

View File

@ -1,14 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: Update man pages for merging of commands
usbip_bind_driver (formerly usbip_attach_driver) was merged into the
usbip command. Remove the separate man page for it. Update examples
and references accordingly.
--- a/drivers/staging/usbip/userspace/Makefile.am
+++ b/drivers/staging/usbip/userspace/Makefile.am
@@ -3,4 +3,4 @@
include_HEADERS := $(addprefix libsrc/, \
usbip_common.h vhci_driver.h usbip_host_driver.h)
-dist_man_MANS := $(addprefix doc/, usbip.8 usbipd.8 usbip_bind_driver.8)
+dist_man_MANS := $(addprefix doc/, usbip.8 usbipd.8)