add fix so binutils notes sections will be stripped. Otherwise you end up

with a 3 GB kernel image on ARM.

svn path=/dists/trunk/linux-2.6/; revision=9652
This commit is contained in:
Martin Michlmayr 2007-10-13 17:27:15 +00:00
parent 40bedbb5fe
commit d59c87c62a
2 changed files with 20 additions and 0 deletions

View File

@ -0,0 +1,19 @@
Needed otherwise you get a 3 GB kernel file
From: Lennert Buytenhek <buytenh@wantstofly.org>
Subject: Re: What's queued for 2.6.24
Date: Wed, 3 Oct 2007 16:12:06 +0200
diff -ur linux-2.6.23-rc4.orig/arch/arm/Makefile linux-2.6.23-rc4/arch/arm/Makefile
--- linux-2.6.23-rc4.orig/arch/arm/Makefile 2007-08-28 11:07:38.000000000 +0200
+++ linux-2.6.23-rc4/arch/arm/Makefile 2007-10-03 16:09:12.000000000 +0200
@@ -12,7 +12,7 @@
LDFLAGS_vmlinux :=-p --no-undefined -X
CPPFLAGS_vmlinux.lds = -DTEXT_OFFSET=$(TEXT_OFFSET)
-OBJCOPYFLAGS :=-O binary -R .note -R .comment -S
+OBJCOPYFLAGS :=-O binary -R .note -R .note.gnu.build-id -R .comment -S
GZFLAGS :=-9
#CFLAGS +=-pipe
# Explicitly specifiy 32-bit ARM ISA since toolchain default can be -mthumb:

View File

@ -41,6 +41,7 @@
+ bugfix/arm/disable-chelsio_t3.patch
+ bugfix/arm/disable-video_bt848.patch
+ bugfix/arm/disable-bcm43xx.patch
+ bugfix/arm/binutils-notes.patch
+ bugfix/all/git-ieee1394.patch
+ features/all/v7-iwlwifi-add-iwlwifi-wireless-drivers.patch
+ features/all/e1000e-20070806.patch