Update and reenable aufs

Include a fix for a nasty bug in aufs/TOMOYO interaction.
(The fix is not required in squeeze.)

svn path=/dists/trunk/linux-2.6/; revision=17013
This commit is contained in:
Ben Hutchings 2011-03-06 23:39:03 +00:00
parent 2ec9d30f39
commit d512f3dbd1
8 changed files with 442 additions and 223 deletions

2
debian/changelog vendored
View File

@ -11,6 +11,8 @@ linux-2.6 (2.6.38~rc7-1~experimental.1) UNRELEASED; urgency=low
firmware-linux-nonfree 0.29) (Closes: #568454)
* perf: Build with libdwarf for improved analysis capabilities
* perf: Build with newt for improved user interface (Closes: #615868)
* aufs: Update for 2.6.38
* aufs: Fix device numbers passed to security_path_mknod()
-- maximilian attems <maks@debian.org> Thu, 03 Mar 2011 16:00:38 +0100

30
debian/config/config vendored
View File

@ -2926,21 +2926,21 @@ CONFIG_AFS_FSCACHE=y
##
## file: fs/aufs/Kconfig
##
# CONFIG_AUFS_FS=m
# ## choice: Maximum number of branches
# CONFIG_AUFS_BRANCH_MAX_127=y
# # CONFIG_AUFS_BRANCH_MAX_511 is not set
# # CONFIG_AUFS_BRANCH_MAX_1023 is not set
# # CONFIG_AUFS_BRANCH_MAX_32767 is not set
# ## end choice
# # CONFIG_AUFS_HNOTIFY is not set
# # CONFIG_AUFS_EXPORT is not set
# # CONFIG_AUFS_RDU is not set
# # CONFIG_AUFS_SP_IATTR is not set
# # CONFIG_AUFS_SHWH is not set
# # CONFIG_AUFS_BR_RAMFS is not set
# # CONFIG_AUFS_BR_FUSE is not set
# # CONFIG_AUFS_DEBUG is not set
CONFIG_AUFS_FS=m
## choice: Maximum number of branches
CONFIG_AUFS_BRANCH_MAX_127=y
# CONFIG_AUFS_BRANCH_MAX_511 is not set
# CONFIG_AUFS_BRANCH_MAX_1023 is not set
# CONFIG_AUFS_BRANCH_MAX_32767 is not set
## end choice
# CONFIG_AUFS_HNOTIFY is not set
# CONFIG_AUFS_EXPORT is not set
# CONFIG_AUFS_RDU is not set
# CONFIG_AUFS_SP_IATTR is not set
# CONFIG_AUFS_SHWH is not set
# CONFIG_AUFS_BR_RAMFS is not set
# CONFIG_AUFS_BR_FUSE is not set
# CONFIG_AUFS_DEBUG is not set
##
## file: fs/autofs4/Kconfig

View File

@ -0,0 +1,31 @@
Date: Thu, 24 Feb 2011 09:40:31 -0800
From: John Johansen <john.johansen@canonical.com>
Subject: [natty] Fix aufs calling of security_path_mknod
Fix aufs calling of security_path_mknod
BugLink: http://launchpad.net/bugs/724456
The security_path_mknod hook requires an encoded 'dev' for its 'dev' paramet
but aufs is calling security_path_mknod with a 'dev' that was already
converted by 'new_decode_dev(dev)'. However security_path_mknod and its
consumer TOMOYO is expecting 'dev' rather than 'new_decode_dev(dev)'.
This will result in TOMOYO doing new_decode_dev(new_decode_dev(dev))
(which is wrong) when security_path_mknod() is called from aufs' vfsub_mknod
Signed-off-by: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>
Signed-off-by: John Johansen <john.johansen@canonical.com>
[bwh: Change source paths for Debian]
--- a/fs/aufs/vfsub.c
+++ b/fs/aufs/vfsub.c
@@ -276,7 +276,7 @@ int vfsub_mknod(struct inode *dir, struct path *path, int mo
d = path->dentry;
path->dentry = d->d_parent;
- err = security_path_mknod(path, d, mode, dev);
+ err = security_path_mknod(path, d, mode, new_encode_dev(dev));
path->dentry = d;
if (unlikely(err))
goto out;

File diff suppressed because it is too large Load Diff

View File

@ -1,10 +1,10 @@
aufs2.1 base patch for linux-2.6.37
aufs2.1 base patch for linux-2.6.
diff --git a/fs/namei.c b/fs/namei.c
index 4ff7ca5..a8c583f 100644
index 0087cf9..cd39cdf 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1161,12 +1161,12 @@ out:
@@ -1841,12 +1841,12 @@ out:
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
@ -20,10 +20,10 @@ index 4ff7ca5..a8c583f 100644
{
unsigned long hash;
diff --git a/fs/splice.c b/fs/splice.c
index ce2f025..ff0ae69 100644
index 50a5d97..886e942 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1092,8 +1092,8 @@ EXPORT_SYMBOL_GPL(generic_splice_sendpage);
@@ -1081,8 +1081,8 @@ EXPORT_SYMBOL_GPL(generic_splice_sendpage);
/*
* Attempt to initiate a splice from pipe to file.
*/
@ -34,7 +34,7 @@ index ce2f025..ff0ae69 100644
{
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
loff_t *, size_t, unsigned int);
@@ -1120,9 +1120,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@@ -1109,9 +1109,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from a file to a pipe.
*/
@ -48,10 +48,10 @@ index ce2f025..ff0ae69 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/namei.h b/include/linux/namei.h
index 05b441d..91bc74e 100644
index f276d4f..4eb5fcb 100644
--- a/include/linux/namei.h
+++ b/include/linux/namei.h
@@ -73,6 +73,9 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
@@ -79,6 +79,9 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry *dentry,
int (*open)(struct inode *, struct file *));
@ -60,7 +60,7 @@ index 05b441d..91bc74e 100644
+ struct dentry *base, int len);
extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
extern int follow_down(struct path *);
extern int follow_down_one(struct path *);
diff --git a/include/linux/splice.h b/include/linux/splice.h
index 997c3b4..be9a153 100644
--- a/include/linux/splice.h

View File

@ -1,10 +1,10 @@
aufs2.1 kbuild patch for linux-2.6.37
aufs2.1 kbuild patch for linux-2.6.
diff --git a/fs/Kconfig b/fs/Kconfig
index 771f457..bb1a52f 100644
index 3db9caa..c9e1f11 100644
--- a/fs/Kconfig
+++ b/fs/Kconfig
@@ -191,6 +191,7 @@ source "fs/romfs/Kconfig"
@@ -190,6 +190,7 @@ source "fs/romfs/Kconfig"
source "fs/sysv/Kconfig"
source "fs/ufs/Kconfig"
source "fs/exofs/Kconfig"
@ -22,10 +22,10 @@ index a7f7cef..95dd4d3 100644
obj-$(CONFIG_CEPH_FS) += ceph/
+obj-$(CONFIG_AUFS_FS) += aufs/
diff --git a/include/linux/Kbuild b/include/linux/Kbuild
index 97319a8..7ebb4b4 100644
index b0ada6f..5cb5837 100644
--- a/include/linux/Kbuild
+++ b/include/linux/Kbuild
@@ -60,6 +60,7 @@ header-y += atmppp.h
@@ -64,6 +64,7 @@ header-y += atmppp.h
header-y += atmsap.h
header-y += atmsvc.h
header-y += audit.h

View File

@ -1,7 +1,7 @@
aufs2.1 standalone patch for linux-2.6.37
aufs2.1 standalone patch for linux-2.6.
diff --git a/fs/file_table.c b/fs/file_table.c
index c3dee38..f529e4d 100644
index eb36b6b..12f2809 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -393,6 +393,8 @@ void file_sb_list_del(struct file *file)
@ -14,7 +14,7 @@ index c3dee38..f529e4d 100644
/*
diff --git a/fs/inode.c b/fs/inode.c
index ae2727a..2c8071a 100644
index da85e56..b3dc5d8 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -82,6 +82,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
@ -26,10 +26,10 @@ index ae2727a..2c8071a 100644
/*
* iprune_sem provides exclusion between the kswapd or try_to_free_pages
diff --git a/fs/namei.c b/fs/namei.c
index a8c583f..b020c45 100644
index cd39cdf..db4290c 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -347,6 +347,7 @@ int deny_write_access(struct file * file)
@@ -353,6 +353,7 @@ int deny_write_access(struct file * file)
return 0;
}
@ -37,7 +37,7 @@ index a8c583f..b020c45 100644
/**
* path_get - get a reference to a path
@@ -1165,6 +1166,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
@@ -1845,6 +1846,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
@ -45,7 +45,7 @@ index a8c583f..b020c45 100644
int __lookup_one_len(const char *name, struct qstr *this,
struct dentry *base, int len)
@@ -1187,6 +1189,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
@@ -1867,6 +1869,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
this->hash = end_name_hash(hash);
return 0;
}
@ -54,10 +54,10 @@ index a8c583f..b020c45 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
index 3dbfc07..3998762 100644
index 7b0b953..b304f68 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -1321,6 +1321,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1465,6 +1465,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -127,7 +127,7 @@ index 325185e..adede09 100644
static int fsnotify_mark_destroy(void *ignored)
{
diff --git a/fs/open.c b/fs/open.c
index 4197b9e..912817a 100644
index 5a2c6eb..f0fa5b2 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -139,10 +139,10 @@ index 4197b9e..912817a 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
index ff0ae69..1c9e9b0 100644
index 886e942..9a77a3e 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1116,6 +1116,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@@ -1105,6 +1105,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@ -150,7 +150,7 @@ index ff0ae69..1c9e9b0 100644
/*
* Attempt to initiate a splice from a file to a pipe.
@@ -1142,6 +1143,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
@@ -1131,6 +1132,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@ -180,10 +180,10 @@ index 8d9c48f..29108aa 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index 1b798d3..3b7d2ca 100644
index 7b7308a..140afc7 100644
--- a/security/security.c
+++ b/security/security.c
@@ -360,6 +360,7 @@ int security_path_mkdir(struct path *dir, struct dentry *dentry, int mode)
@@ -359,6 +359,7 @@ int security_path_mkdir(struct path *dir, struct dentry *dentry, int mode)
return 0;
return security_ops->path_mkdir(dir, dentry, mode);
}
@ -191,7 +191,7 @@ index 1b798d3..3b7d2ca 100644
int security_path_rmdir(struct path *dir, struct dentry *dentry)
{
@@ -367,6 +368,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
@@ -366,6 +367,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
return 0;
return security_ops->path_rmdir(dir, dentry);
}
@ -199,7 +199,7 @@ index 1b798d3..3b7d2ca 100644
int security_path_unlink(struct path *dir, struct dentry *dentry)
{
@@ -374,6 +376,7 @@ int security_path_unlink(struct path *dir, struct dentry *dentry)
@@ -373,6 +375,7 @@ int security_path_unlink(struct path *dir, struct dentry *dentry)
return 0;
return security_ops->path_unlink(dir, dentry);
}
@ -207,7 +207,7 @@ index 1b798d3..3b7d2ca 100644
int security_path_symlink(struct path *dir, struct dentry *dentry,
const char *old_name)
@@ -382,6 +385,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
@@ -381,6 +384,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
return 0;
return security_ops->path_symlink(dir, dentry, old_name);
}
@ -215,7 +215,7 @@ index 1b798d3..3b7d2ca 100644
int security_path_link(struct dentry *old_dentry, struct path *new_dir,
struct dentry *new_dentry)
@@ -390,6 +394,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
@@ -389,6 +393,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
return 0;
return security_ops->path_link(old_dentry, new_dir, new_dentry);
}
@ -223,7 +223,7 @@ index 1b798d3..3b7d2ca 100644
int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
struct path *new_dir, struct dentry *new_dentry)
@@ -400,6 +405,7 @@ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
@@ -399,6 +404,7 @@ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
return security_ops->path_rename(old_dir, old_dentry, new_dir,
new_dentry);
}
@ -231,7 +231,7 @@ index 1b798d3..3b7d2ca 100644
int security_path_truncate(struct path *path)
{
@@ -407,6 +413,7 @@ int security_path_truncate(struct path *path)
@@ -406,6 +412,7 @@ int security_path_truncate(struct path *path)
return 0;
return security_ops->path_truncate(path);
}
@ -239,7 +239,7 @@ index 1b798d3..3b7d2ca 100644
int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
mode_t mode)
@@ -415,6 +422,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
@@ -414,6 +421,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
return 0;
return security_ops->path_chmod(dentry, mnt, mode);
}
@ -247,7 +247,7 @@ index 1b798d3..3b7d2ca 100644
int security_path_chown(struct path *path, uid_t uid, gid_t gid)
{
@@ -422,6 +430,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
@@ -421,6 +429,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
return 0;
return security_ops->path_chown(path, uid, gid);
}
@ -255,7 +255,7 @@ index 1b798d3..3b7d2ca 100644
int security_path_chroot(struct path *path)
{
@@ -498,6 +507,7 @@ int security_inode_readlink(struct dentry *dentry)
@@ -497,6 +506,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return security_ops->inode_readlink(dentry);
}
@ -263,15 +263,15 @@ index 1b798d3..3b7d2ca 100644
int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
{
@@ -512,6 +522,7 @@ int security_inode_permission(struct inode *inode, int mask)
@@ -511,6 +521,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return security_ops->inode_permission(inode, mask);
}
+EXPORT_SYMBOL_GPL(security_inode_permission);
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
int security_inode_exec_permission(struct inode *inode, unsigned int flags)
{
@@ -611,6 +622,7 @@ int security_file_permission(struct file *file, int mask)
@@ -619,6 +630,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -279,7 +279,7 @@ index 1b798d3..3b7d2ca 100644
int security_file_alloc(struct file *file)
{
@@ -638,6 +650,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
@@ -646,6 +658,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
return ret;
return ima_file_mmap(file, prot);
}

View File

@ -7,13 +7,15 @@
+ features/all/sound-pci-cs46xx-request_firmware.patch
# patches from aufs2 repository, with s/EXPORT_SYMBOL/&_GPL/
#+ features/all/aufs2/aufs2-base.patch
#+ features/all/aufs2/aufs2-standalone.patch
#+ features/all/aufs2/aufs2-kbuild.patch
# content of fs/ and include/ from aufs2 repository
#+ features/all/aufs2/aufs2-add.patch
+ features/all/aufs2/aufs2-base.patch
+ features/all/aufs2/aufs2-standalone.patch
+ features/all/aufs2/aufs2-kbuild.patch
# content of fs/ and include/linux/aufs_types.h from aufs2 repository
+ features/all/aufs2/aufs2-add.patch
# mark as staging/crap
#+ features/all/aufs2/mark-as-staging.patch
+ features/all/aufs2/mark-as-staging.patch
# fix not upstream yet
+ features/all/aufs2/Fix-aufs-calling-of-security_path_mknod.patch
+ bugfix/ia64/hardcode-arch-script-output.patch
+ bugfix/mips/disable-advansys.patch