[x86] Correct typos in label names in two asm functions (Closes: #616426)

svn path=/dists/trunk/linux-2.6/; revision=16989
This commit is contained in:
Ben Hutchings 2011-03-06 00:36:36 +00:00
parent d38707ed9f
commit d366256e94
4 changed files with 65 additions and 0 deletions

3
debian/changelog vendored
View File

@ -4,6 +4,9 @@ linux-2.6 (2.6.38~rc7-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate
* x86: Set DRM_I915_KMS on request by xorg team.
[ Ben Hutchings ]
* [x86] Correct typos in label names in two asm functions (Closes: #616426)
-- maximilian attems <maks@debian.org> Thu, 03 Mar 2011 16:00:38 +0100
linux-2.6 (2.6.38~rc6-1~experimental.1) experimental; urgency=low

View File

@ -0,0 +1,41 @@
Subject: [BUG] as of trunk build Linux kernel trunk entry_32.S got error
Date: Thu, 03 Mar 2011 14:30:51 -0000
From: Alan Modra <amodra@gmail.com>
X-Patchwork-Id: 606241
On Thu, Mar 03, 2011 at 05:48:01AM -0800, H.J. Lu wrote:
> On Wed, Mar 2, 2011 at 10:16 PM, Hui Zhu <teawater@gmail.com> wrote:
> > as -version
> > GNU assembler (GNU Binutils) 2.21.51.20110303
> >  AS      arch/x86/kernel/entry_32.o
> > /home/teawater/big/kernel/linux-2.6/arch/x86/kernel/entry_32.S:
> > Assembler messages:
> > /home/teawater/big/kernel/linux-2.6/arch/x86/kernel/entry_32.S:1422:
> > Error: .size expression does not evaluate to a constant
> >
> > When I change back to the as of system, everything is OK.
> >
> > Because I always use the as of trunk, so I think a recent PATCH caused
> > the problem.
> >
>
> You need
>
> http://git.kernel.org/?p=linux/kernel/git/hjl/linux-2.6.37.y.git;a=commitdiff;h=2c5ce9c1b8eb927c131a31d4466e24e00647e9cb
That doesn't fix the similar entry_32.S problem. Here you go.
diff --git a/arch/x86/kernel/entry_32.S b/arch/x86/kernel/entry_32.S
index c8b4efa..9ca3b0e 100644
--- a/arch/x86/kernel/entry_32.S
+++ b/arch/x86/kernel/entry_32.S
@@ -1413,7 +1413,7 @@ ENTRY(async_page_fault)
CFI_ADJUST_CFA_OFFSET 4
jmp error_code
CFI_ENDPROC
-END(apf_page_fault)
+END(async_page_fault)
#endif
/*

View File

@ -0,0 +1,19 @@
From: H.J. Lu <hjl.tools@gmail.com>
Date: Sat, 26 Feb 2011 20:37:08 +0000 (-0800)
Subject: Correct a typo in xen_do_hypervisor_callback label.
Correct a typo in xen_do_hypervisor_callback label.
---
diff --git a/arch/x86/kernel/entry_64.S b/arch/x86/kernel/entry_64.S
index 44a99bb..3571494 100644
--- a/arch/x86/kernel/entry_64.S
+++ b/arch/x86/kernel/entry_64.S
@@ -1270,7 +1270,7 @@ ENTRY(xen_do_hypervisor_callback) # do_hypervisor_callback(struct *pt_regs)
decl PER_CPU_VAR(irq_count)
jmp error_exit
CFI_ENDPROC
-END(do_hypervisor_callback)
+END(xen_do_hypervisor_callback)
/*
* Hypervisor uses this for application faults while it executes.

View File

@ -44,3 +44,5 @@
+ bugfix/all/rtc-rtc-ds1511-world-writable-sysfs-nvram-file.patch
+ bugfix/all/scsi-aic94xx-world-writable-sysfs-update_bios-file.patch
+ bugfix/all/scsi-iscsi-world-writable-sysfs-priv_sess-file.patch
+ bugfix/x86/Correct-a-typo-in-xen_do_hypervisor_callback-label.patch
+ bugfix/x86/Correct-a-typo-in-async_page_fault-label.patch