locking/lockdep: Delete unnecesary #include (fixes liblockdep build)

This commit is contained in:
Ben Hutchings 2018-08-28 22:05:00 +01:00
parent 0349f8f365
commit d34b1c8943
3 changed files with 35 additions and 0 deletions

1
debian/changelog vendored
View File

@ -5,6 +5,7 @@ linux (4.19~rc1-1~exp1) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* aufs: Disable until it is updated for Linux 4.19
* debian/rules.d: Update for move of bin2c back up to scripts
* locking/lockdep: Delete unnecesary #include (fixes liblockdep build)
-- Ben Hutchings <ben@decadent.org.uk> Mon, 27 Aug 2018 14:36:54 +0100

View File

@ -0,0 +1,33 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 28 Aug 2018 18:47:31 +0100
Subject: locking/lockdep: Delete unnecesary #include
Forwarded: https://lore.kernel.org/lkml/20180828203315.GD18030@decadent.org.uk/T/#u
Commit c3bc8fd637a9 ("tracing: Centralize preemptirq tracepoints and u
nify their usage") added the inclusion of <trace/events/preemptirq.h>.
liblockdep doesn't have a stub version of that header so now fails to
build.
However, commit bff1b208a5d1 ("tracing: Partial revert of "tracing:
Centralize preemptirq tracepoints and unify their usage"") removed the
use of functions declared in that header. So delete the #include.
Fixes: c3bc8fd637a9 ("tracing: Centralize preemptirq tracepoints ...")
Fixes: bff1b208a5d1 ("tracing: Partial revert of "tracing: Centralize ...")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
kernel/locking/lockdep.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index e406c5fdb41e..dd13f865ad40 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -55,7 +55,6 @@
#include "lockdep_internals.h"
-#include <trace/events/preemptirq.h>
#define CREATE_TRACE_POINTS
#include <trace/events/lock.h>

View File

@ -147,6 +147,7 @@ bugfix/all/cpupower-bump-soname-version.patch
bugfix/all/cpupower-fix-checks-for-cpu-existence.patch
bugfix/all/lockdep-stub-nmi-watchdog-reset.patch
bugfix/all/lockdep-stub-task_struct-state.patch
bugfix/all/locking-lockdep-delete-unnecesary-include.patch
bugfix/all/tools-lib-api-fs-fs.c-fix-misuse-of-strncpy.patch
bugfix/all/usbip-fix-misuse-of-strncpy.patch