mipsel: Drop DECstation support (both r3k-kn02 and r4k-kn04).

svn path=/dists/trunk/linux-2.6/; revision=7830
This commit is contained in:
Martin Michlmayr 2006-11-19 14:35:09 +00:00
parent 6200cd20ed
commit d13746218e
8 changed files with 2 additions and 2725 deletions

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

View File

@ -3,8 +3,6 @@ flavours:
r5k-cobalt
sb1-bcm91250a
sb1a-bcm91480b
r3k-kn02
r4k-kn04
qemu
kernel-arch: mips
kernel-header-dirs: mips
@ -24,15 +22,6 @@ longclass: Broadcom BCM91250A (aka SWARM)
class: BCM91480B
longclass: Broadcom BCM91480B (aka BigSur)
[r3k-kn02]
class: R3000 based DECstation
longclass: R3000 based DECstations with KN02 mainboard, such as the DECstation 5000/1xx series with xx=20,25,33 and the DECstation 5000/240
[r4k-kn04]
class: R4x00 based DECstation
longclass: R4x00 based DECstations with KN04 mainboard, such as the DECstation 5000/150, the
Personal DECstation 5000/50 and the DECstation 5000/260
[qemu]
class: QEMU
longclass: QEMU virtual machine

3
debian/changelog vendored
View File

@ -1,6 +1,7 @@
linux-2.6 (2.6.19~rc6-1~experimental.1) UNRELEASED; urgency=low
*
[ Martin Michlmayr ]
* mipsel: Drop DECstation support (both r3k-kn02 and r4k-kn04).
-- Bastian Blank <waldi@debian.org> Sun, 19 Nov 2006 12:05:33 +0100

View File

@ -1,32 +0,0 @@
# Upstream status: in linux-mips tree; someone needs to figure out how to
# integrate this into the Linux tree...
From: Maciej W. Rozycki <macro@linux-mips.org>
--- a/drivers/scsi/NCR53C9x.h 2006-03-05 20:35:04.000000000 +0100
+++ b/drivers/scsi/NCR53C9x.h 2006-03-05 19:51:16.000000000 +0100
@@ -145,12 +145,7 @@
#ifndef MULTIPLE_PAD_SIZES
-#ifdef CONFIG_CPU_HAS_WB
-#include <asm/wbflush.h>
-#define esp_write(__reg, __val) do{(__reg) = (__val); wbflush();} while(0)
-#else
-#define esp_write(__reg, __val) ((__reg) = (__val))
-#endif
+#define esp_write(__reg, __val) do{(__reg) = (__val); iob();} while(0)
#define esp_read(__reg) (__reg)
struct ESP_regs {
--- a/drivers/scsi/dec_esp.c
+++ b/drivers/scsi/dec_esp.c
@@ -230,7 +230,7 @@ static int dec_esp_detect(struct scsi_ho
mem_start = get_tc_base_addr(slot);
/* Store base addr into esp struct */
- esp->slot = CPHYSADDR(mem_start);
+ esp->slot = mem_start;
esp->dregs = 0;
esp->eregs = (void *)CKSEG1ADDR(mem_start +

View File

@ -1,197 +0,0 @@
# Upstream status: won't go into Linus' tree like this but is in the
# linux-mips tree. The drivers/char serial drivers need to be converted to
# real serial drivers in drivers/serial
# Author: Martin Michlmayr <tbm@cyrius.com>, mostly taken from the
# linux-mips tree, with some updates by Maciej W. Rozycki.
--- b/drivers/char/Kconfig~ 2006-05-25 12:51:58.000000000 +0200
+++ b/drivers/char/Kconfig 2006-05-25 12:53:03.000000000 +0200
@@ -362,6 +362,41 @@
bool "Console on BCM1xxx DUART"
depends on SIBYTE_SB1250_DUART
+config SERIAL_DEC
+ bool "DECstation serial support"
+ depends on MACH_DECSTATION
+ default y
+ help
+ This selects whether you want to be asked about drivers for
+ DECstation serial ports.
+
+ Note that the answer to this question won't directly affect the
+ kernel: saying N will just cause the configurator to skip all
+ the questions about DECstation serial ports.
+
+ If unsure, say Y.
+
+config SERIAL_DEC_CONSOLE
+ bool "Support for console on a DECstation serial port"
+ depends on SERIAL_DEC
+ default y
+ help
+ If you say Y here, it will be possible to use a serial port as the
+ system console (the system console is the device which receives all
+ kernel messages and warnings and which allows logins in single user
+ mode). Note that the firmware uses ttyS0 as the serial console on
+ the Maxine and ttyS2 on the others.
+
+ If unsure, say Y.
+
+config ZS
+ bool "Z85C30 Serial Support"
+ depends on SERIAL_DEC
+ default y
+ help
+ Documentation on the Zilog 85C350 serial communications controller
+ is downloadable at <http://www.zilog.com/pdfs/serial/z85c30.pdf>.
+
config QTRONIX_KEYBOARD
bool "Enable Qtronix 990P Keyboard Support"
depends on IT8712
--- b/drivers/char/Makefile~ 2006-05-25 12:51:52.000000000 +0200
+++ b/drivers/char/Makefile 2006-05-25 12:52:27.000000000 +0200
@@ -50,6 +50,7 @@
obj-$(CONFIG_VIOTAPE) += viotape.o
obj-$(CONFIG_HVCS) += hvcs.o
obj-$(CONFIG_SGI_MBCS) += mbcs.o
+obj-$(CONFIG_SERIAL_DEC) += decserial.o
obj-$(CONFIG_PRINTER) += lp.o
obj-$(CONFIG_TIPAR) += tipar.o
--- a/drivers/char/decserial.c
+++ b/drivers/char/decserial.c
@@ -14,86 +14,84 @@
* device. Added support for PROM console in drivers/char/tty_io.c
* instead. Although it may work to enable more than one
* console device I strongly recommend to use only one.
+ *
+ * Copyright (C) 2004 Maciej W. Rozycki
*/
+#include <linux/errno.h>
#include <linux/init.h>
-#include <asm/dec/machtype.h>
-
-#ifdef CONFIG_ZS
-extern int zs_init(void);
-#endif
-#ifdef CONFIG_DZ
-extern int dz_init(void);
-#endif
+#include <asm/dec/machtype.h>
+#include <asm/dec/serial.h>
-#ifdef CONFIG_SERIAL_CONSOLE
+extern int register_zs_hook(unsigned int channel,
+ struct dec_serial_hook *hook);
+extern int unregister_zs_hook(unsigned int channel);
+int register_dec_serial_hook(unsigned int channel,
+ struct dec_serial_hook *hook)
+{
#ifdef CONFIG_ZS
-extern void zs_serial_console_init(void);
-#endif
-
-#ifdef CONFIG_DZ
-extern void dz_serial_console_init(void);
+ if (IOASIC)
+ return register_zs_hook(channel, hook);
#endif
+ return 0;
+}
+int unregister_dec_serial_hook(unsigned int channel)
+{
+#ifdef CONFIG_ZS
+ if (IOASIC)
+ return unregister_zs_hook(channel);
#endif
+ return 0;
+}
-/* rs_init - starts up the serial interface -
- handle normal case of starting up the serial interface */
-#ifdef CONFIG_SERIAL
+extern int zs_init(void);
+extern int dz_init(void);
+/*
+ * rs_init - starts up the serial interface -
+ * handle normal case of starting up the serial interface
+ */
int __init rs_init(void)
{
-
-#if defined(CONFIG_ZS) && defined(CONFIG_DZ)
- if (IOASIC)
- return zs_init();
- else
- return dz_init();
-#else
-
#ifdef CONFIG_ZS
- return zs_init();
+ if (IOASIC)
+ return zs_init();
#endif
-
#ifdef CONFIG_DZ
- return dz_init();
-#endif
-
+ if (!IOASIC)
+ return dz_init();
#endif
+ return -ENXIO;
}
__initcall(rs_init);
-#endif
-#ifdef CONFIG_SERIAL_CONSOLE
+#ifdef CONFIG_SERIAL_DEC_CONSOLE
-/* serial_console_init handles the special case of starting
- * up the console on the serial port
+extern void zs_serial_console_init(void);
+extern void dz_serial_console_init(void);
+
+/*
+ * dec_serial_console_init handles the special case of starting
+ * up the console on the serial port
*/
-static int __init decserial_console_init(void)
+static int __init dec_serial_console_init(void)
{
-#if defined(CONFIG_ZS) && defined(CONFIG_DZ)
- if (IOASIC)
- zs_serial_console_init();
- else
- dz_serial_console_init();
-#else
-
#ifdef CONFIG_ZS
- zs_serial_console_init();
+ if (IOASIC)
+ zs_serial_console_init();
#endif
-
#ifdef CONFIG_DZ
- dz_serial_console_init();
-#endif
-
+ if (!IOASIC)
+ dz_serial_console_init();
#endif
return 0;
}
-console_initcall(decserial_console_init);
+console_initcall(dec_serial_console_init);
#endif

View File

@ -1,21 +0,0 @@
# Upstream status: in linux-mips tree; someone needs to figure out how to
# integrate this into the Linux tree...
From: Maciej W. Rozycki <macro@linux-mips.org>
--- a/drivers/scsi/NCR53C9x.h 2006-03-05 20:35:04.000000000 +0100
+++ b/drivers/scsi/NCR53C9x.h 2006-03-05 19:51:16.000000000 +0100
@@ -145,12 +145,7 @@
#ifndef MULTIPLE_PAD_SIZES
-#ifdef CONFIG_CPU_HAS_WB
-#include <asm/wbflush.h>
-#define esp_write(__reg, __val) do{(__reg) = (__val); wbflush();} while(0)
-#else
-#define esp_write(__reg, __val) ((__reg) = (__val))
-#endif
+#define esp_write(__reg, __val) do{(__reg) = (__val); iob();} while(0)
#define esp_read(__reg) (__reg)
struct ESP_regs {

View File

@ -1,135 +0,0 @@
# Upstream status: won't go into Linus' tree like this but is in the
# linux-mips tree. The drivers/char serial drivers need to be converted to
# real serial drivers in drivers/serial
# Author: Martin Michlmayr <tbm@cyrius.com>, mostly taken from the
# linux-mips tree
--- b/drivers/char/Kconfig~ 2006-05-25 12:51:58.000000000 +0200
+++ b/drivers/char/Kconfig 2006-05-25 12:53:03.000000000 +0200
@@ -362,6 +362,41 @@
bool "Console on BCM1xxx DUART"
depends on SIBYTE_SB1250_DUART
+config SERIAL_DEC
+ bool "DECstation serial support"
+ depends on MACH_DECSTATION
+ default y
+ help
+ This selects whether you want to be asked about drivers for
+ DECstation serial ports.
+
+ Note that the answer to this question won't directly affect the
+ kernel: saying N will just cause the configurator to skip all
+ the questions about DECstation serial ports.
+
+ If unsure, say Y.
+
+config SERIAL_DEC_CONSOLE
+ bool "Support for console on a DECstation serial port"
+ depends on SERIAL_DEC
+ default y
+ help
+ If you say Y here, it will be possible to use a serial port as the
+ system console (the system console is the device which receives all
+ kernel messages and warnings and which allows logins in single user
+ mode). Note that the firmware uses ttyS0 as the serial console on
+ the Maxine and ttyS2 on the others.
+
+ If unsure, say Y.
+
+config ZS
+ bool "Z85C30 Serial Support"
+ depends on SERIAL_DEC
+ default y
+ help
+ Documentation on the Zilog 85C350 serial communications controller
+ is downloadable at <http://www.zilog.com/pdfs/serial/z85c30.pdf>.
+
config QTRONIX_KEYBOARD
bool "Enable Qtronix 990P Keyboard Support"
depends on IT8712
--- b/drivers/char/Makefile~ 2006-05-25 12:51:52.000000000 +0200
+++ b/drivers/char/Makefile 2006-05-25 12:52:27.000000000 +0200
@@ -50,6 +50,7 @@
obj-$(CONFIG_VIOTAPE) += viotape.o
obj-$(CONFIG_HVCS) += hvcs.o
obj-$(CONFIG_SGI_MBCS) += mbcs.o
+obj-$(CONFIG_SERIAL_DEC) += decserial.o
obj-$(CONFIG_PRINTER) += lp.o
obj-$(CONFIG_TIPAR) += tipar.o
--- a/drivers/char/decserial.c
+++ b/drivers/char/decserial.c
@@ -24,17 +24,17 @@
extern int zs_init(void);
#endif
-#ifdef CONFIG_DZ
+#ifdef CONFIG_SERIAL_DZ
extern int dz_init(void);
#endif
-#ifdef CONFIG_SERIAL_CONSOLE
+#ifdef CONFIG_SERIAL_CORE_CONSOLE
#ifdef CONFIG_ZS
extern void zs_serial_console_init(void);
#endif
-#ifdef CONFIG_DZ
+#ifdef CONFIG_SERIAL_DZ
extern void dz_serial_console_init(void);
#endif
@@ -43,12 +43,12 @@ extern void dz_serial_console_init(void)
/* rs_init - starts up the serial interface -
handle normal case of starting up the serial interface */
-#ifdef CONFIG_SERIAL
+#ifdef CONFIG_SERIAL_CORE
int __init rs_init(void)
{
-#if defined(CONFIG_ZS) && defined(CONFIG_DZ)
+#if defined(CONFIG_ZS) && defined(CONFIG_SERIAL_DZ)
if (IOASIC)
return zs_init();
else
@@ -59,7 +59,7 @@ int __init rs_init(void)
return zs_init();
#endif
-#ifdef CONFIG_DZ
+#ifdef CONFIG_SERIAL_DZ
return dz_init();
#endif
@@ -70,14 +70,14 @@ __initcall(rs_init);
#endif
-#ifdef CONFIG_SERIAL_CONSOLE
+#ifdef CONFIG_SERIAL_CORE_CONSOLE
/* serial_console_init handles the special case of starting
* up the console on the serial port
*/
static int __init decserial_console_init(void)
{
-#if defined(CONFIG_ZS) && defined(CONFIG_DZ)
+#if defined(CONFIG_ZS) && defined(CONFIG_SERIAL_DZ)
if (IOASIC)
zs_serial_console_init();
else
@@ -88,7 +88,7 @@ static int __init decserial_console_init
zs_serial_console_init();
#endif
-#ifdef CONFIG_DZ
+#ifdef CONFIG_SERIAL_DZ
dz_serial_console_init();
#endif