efi: Expose underlying UEFI firmware platform size to userland, to support installation on Bay Trail systems (Closes: #775191)

svn path=/dists/sid/linux/; revision=22256
This commit is contained in:
Ben Hutchings 2015-01-12 14:34:44 +00:00
parent c3a49aefa1
commit cf3dd6dd9a
3 changed files with 52 additions and 0 deletions

2
debian/changelog vendored
View File

@ -105,6 +105,8 @@ linux (3.16.7-ckt3-1) UNRELEASED; urgency=medium
* [x86] ACPI / video: Run _BCL before deciding registering backlight
(regression in 3.16) (Closes: #762285)
* [amd64] Enable EFI_MIXED to support Bay Trail systems
* efi: Expose underlying UEFI firmware platform size to userland, to
support installation on Bay Trail systems (Closes: #775191)
* [x86] tls: Validate TLS entries to protect espfix (CVE-2014-8133)
* [x86] kvm: Clear paravirt_enabled on KVM guests for espfix32's benefit
(CVE-2014-8134)

View File

@ -0,0 +1,49 @@
From: Steve McIntyre <steve@einval.com>
Date: Fri, 9 Jan 2015 15:29:53 +0000
Subject: efi: Expose underlying UEFI firmware platform size to userland
Origin: https://git.kernel.org/cgit/linux/kernel/git/mfleming/efi.git//commit?id=2859dff97e54db4795b8b7d9606cb8efcec722ff
In some cases (e.g. Intel Bay Trail machines), the kernel will happily
run in 64-bit even if the underlying UEFI firmware platform is
32-bit. That's great, but it's difficult for userland utilities like
grub-install to do the right thing in such a situation.
The kernel already knows about the size of the firmware via
efi_enabled(EFI_64BIT). Add an extra sysfs interface
/sys/firmware/efi/fw_platform_size to expose that information to
userland for low-level utilities to use.
Signed-off-by: Steve McIntyre <steve@einval.com>
Cc: Matthew Garrett <mjg59@srcf.ucam.org>
Signed-off-by: Matt Fleming <matt.fleming@intel.com>
---
drivers/firmware/efi/efi.c | 9 +++++++++
1 file changed, 9 insertions(+)
--- a/drivers/firmware/efi/efi.c
+++ b/drivers/firmware/efi/efi.c
@@ -90,15 +90,24 @@ EFI_ATTR_SHOW(fw_vendor);
EFI_ATTR_SHOW(runtime);
EFI_ATTR_SHOW(config_table);
+static ssize_t fw_platform_size_show(struct kobject *kobj,
+ struct kobj_attribute *attr, char *buf)
+{
+ return sprintf(buf, "%d\n", efi_enabled(EFI_64BIT) ? 64 : 32);
+}
+
static struct kobj_attribute efi_attr_fw_vendor = __ATTR_RO(fw_vendor);
static struct kobj_attribute efi_attr_runtime = __ATTR_RO(runtime);
static struct kobj_attribute efi_attr_config_table = __ATTR_RO(config_table);
+static struct kobj_attribute efi_attr_fw_platform_size =
+ __ATTR_RO(fw_platform_size);
static struct attribute *efi_subsys_attrs[] = {
&efi_attr_systab.attr,
&efi_attr_fw_vendor.attr,
&efi_attr_runtime.attr,
&efi_attr_config_table.attr,
+ &efi_attr_fw_platform_size.attr,
NULL,
};

View File

@ -195,6 +195,7 @@ features/all/of-Enable-console-on-serial-ports-specified-by-chose.patch
features/all/of-correct-of_console_check-s-return-value.patch
features/all/of-add-optional-options-parameter-to-of_find_node_by.patch
features/all/of-support-passing-console-options-with-stdout-path.patch
features/all/efi-expose-underlying-uefi-firmware-platform-size-to.patch
# Update r8723au to 3.17
features/all/r8723au/0001-staging-rtl8723au-rtw_get_wps_ie23a-Remove-unused-de.patch