[m68k] Add patch to build with -ffreestanding to fix FTBFS

This commit is contained in:
John Paul Adrian Glaubitz 2018-12-27 13:45:26 +01:00
parent 77c3f59731
commit ce458bb4d5
3 changed files with 36 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux (4.19.13-2) UNRELEASED; urgency=medium
[ John Paul Adrian Glaubitz ]
* [m68k] Add patch to build with -ffreestanding to fix FTBFS
-- John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de> Sun, 30 Dec 2018 10:30:57 +0100
linux (4.19.13-1) unstable; urgency=medium
* New upstream stable update:

View File

@ -0,0 +1,28 @@
From: Finn Thain <fthain@telegraphics.com.au>
Date: Fri, 21 Dec 2018 17:21:43 +1100 (AEDT)
Subject: Build with -ffreestanding on m68k to avoid
risky optimizations involving libc
Origin: https://marc.info/?l=linux-m68k&m=154537329920545&w=2
diff --git a/arch/m68k/Makefile b/arch/m68k/Makefile
index 997c9f20ea0f..c318afd15e33 100644
--- a/arch/m68k/Makefile
+++ b/arch/m68k/Makefile
@@ -58,1 +58,1 @@ cpuflags-$(CONFIG_M5206e) := $(call cc-option,-mcpu=5206e,-m5200)
cpuflags-$(CONFIG_M5206) := $(call cc-option,-mcpu=5206,-m5200)
KBUILD_AFLAGS += $(cpuflags-y)
-KBUILD_CFLAGS += $(cpuflags-y) -pipe
+KBUILD_CFLAGS += $(cpuflags-y)
ifdef CONFIG_MMU
# without -fno-strength-reduce the 53c7xx.c driver fails ;-(
KBUILD_CFLAGS += -fno-strength-reduce -ffixed-a2
@@ -69,2 +69,2 @@ KBUILD_CFLAGS += -D__uClinux__
KBUILD_AFLAGS += -D__uClinux__
endif
+KBUILD_CFLAGS += -pipe -ffreestanding
+
KBUILD_LDFLAGS := -m m68kelf
KBUILD_LDFLAGS_MODULE += -T $(srctree)/arch/m68k/kernel/module.lds

View File

@ -80,6 +80,7 @@ bugfix/x86/x86-32-disable-3dnow-in-generic-config.patch
bugfix/x86/x86-mm-Fix-guard-hole-handling.patch
bugfix/arm/gpio-mvebu-only-fail-on-missing-clk-if-pwm-is-actual.patch
bugfix/powerpc/powerpc-fix-mcpu-options-for-spe-only-compiler.patch
bugfix/m68k/m68k-build-with-ffreestanding.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch