Fix MIPS build with CONFIG_DYNAMIC_DEBUG=y

svn path=/dists/sid/linux/; revision=21590
This commit is contained in:
Aurelien Jarno 2014-07-20 17:45:55 +00:00
parent e25aa84833
commit ccced8e9f8
2 changed files with 49 additions and 0 deletions

View File

@ -0,0 +1,48 @@
From: Aurelien Jarno <aurelien@aurel32.net>
Date: Sun, 20 Jul 2014 19:25:33 +0200
Subject: MIPS: ZBOOT: add missing <linux/string.h> include
Forwarded: http://www.linux-mips.org/archives/linux-mips/2014-07/msg00374.html
Commit dc4d7b37 moves the string related functions into a separate file,
which might cause the following build error, depending on the
configuration:
| CC arch/mips/boot/compressed/decompress.o
| In file included from linux/arch/mips/boot/compressed/../../../../lib/decompress_unxz.c:234:0,
| from linux/arch/mips/boot/compressed/decompress.c:67:
| linux/arch/mips/boot/compressed/../../../../lib/xz/xz_dec_stream.c: In function 'fill_temp':
| linux/arch/mips/boot/compressed/../../../../lib/xz/xz_dec_stream.c:162:2: error: implicit declaration of function 'memcpy' [-Werror=implicit-function-declaration]
| cc1: some warnings being treated as errors
| linux/scripts/Makefile.build:308: recipe for target 'arch/mips/boot/compressed/decompress.o' failed
| make[6]: *** [arch/mips/boot/compressed/decompress.o] Error 1
| linux/arch/mips/Makefile:308: recipe for target 'vmlinuz' failed
It doesn't not fail with the standard configuration, as when
CONFIG_DYNAMIC_DEBUG is not set <linux/string.h> gets included in
include/linux/dynamic_debug.h. There might be other way for it to
get indirectly included.
We can't add the include should not be added directly in xz_dec_stream.c
as some architectures might want to use a different version for the
boot/ directory (see for example arch/x86/boot/string.h).
Signed-off-by: Aurelien Jarno <aurelien@aurel32.net>
---
arch/mips/boot/compressed/decompress.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/arch/mips/boot/compressed/decompress.c b/arch/mips/boot/compressed/decompress.c
index c00c4dd..5244cec 100644
--- a/arch/mips/boot/compressed/decompress.c
+++ b/arch/mips/boot/compressed/decompress.c
@@ -13,6 +13,7 @@
#include <linux/types.h>
#include <linux/kernel.h>
+#include <linux/string.h>
#include <asm/addrspace.h>
--
2.0.0

View File

@ -62,6 +62,7 @@ bugfix/m68k/ethernat-kconfig.patch
bugfix/arm/bfa-Replace-large-udelay-with-mdelay.patch
bugfix/powerpc/ppc64el-powernv-calls-to-support-little-endian.patch
bugfix/mips/MIPS-SB1-Fix-excessive-kernel-warnings.patch
bugfix/mips/MIPS-ZBOOT-add-missing-linux-string.h-include.patch
# Miscellaneous bug fixes
bugfix/all/misc-bmp085-Enable-building-as-a-module.patch