armel: drop ixp4xx

Image doesn't fit, old hardware, no one cares.

Suggested-by: Ben Hutchings <ben@decadent.org.uk>
Signed-off-by: maximilian attems <maks@debian.org>

svn path=/dists/trunk/linux/; revision=21875
This commit is contained in:
Maximilian Attems 2014-09-19 14:48:01 +00:00
parent 3766aaee75
commit cc574aa6f9
4 changed files with 5 additions and 119 deletions

5
debian/changelog vendored
View File

@ -1,3 +1,8 @@
linux (3.17~rc5-l~exp2) UNRELEASED; urgency=medium
* armel: Drop ixp4xx image.
-- maximilian attems <maks@debian.org> Thu, 18 Sep 2014 23:50:00 +0200
linux (3.17~rc5-1~exp1) experimental; urgency=medium
* New upstream release candidate

View File

@ -1,6 +1,5 @@
[base]
flavours:
ixp4xx
kirkwood
orion5x
versatile
@ -19,17 +18,6 @@ install-stem: vmlinuz
[relations]
headers%gcc-4.8: linux-compiler-gcc-4.8-arm
[ixp4xx_description]
hardware: IXP4xx
hardware-long: IXP4xx based systems (Linksys NSLU2, etc)
[ixp4xx_image]
# Linksys NSLU2: 1441792 - 16 - 16 = 1441760
check-size: 1441760
configs:
armel/config-reduced
armel/config.ixp4xx
[kirkwood_description]
hardware: Marvell Kirkwood
hardware-long: Marvell Kirkwood based systems (SheevaPlug, QNAP TS-119/TS-219, etc)

View File

@ -1,106 +0,0 @@
From: Arnaud Patard <arnaud.patard@rtp-net.org>
Subject: ixp4xx: add io{read,write}{16,32}be functions
Date: 2011-11-13 19:27:56 +0000
Forwarded: http://thread.gmane.org/gmane.linux.ports.arm.kernel/142249
Some driver are now requiring some be io functions, add noted in
commit (06901bd83412db5a31de7526e637101ed0c2c472). Otherwise, it may lead
to build errors like this one :
drivers/net/mlx4/en_tx.c: In function mlx4_en_xmit:
drivers/net/mlx4/en_tx.c:815: error: implicit declaration of function iowrite32be
make[3]: *** [drivers/net/mlx4/en_tx.o] Error 1
make[2]: *** [drivers/net/mlx4] Error 2
make[1]: *** [drivers/net] Error 2
Signed-off-by: Arnaud Patard <arnaud.patard@rtp-net.org>
Index: linux-3.1/arch/arm/mach-ixp4xx/include/mach/io.h
===================================================================
--- linux-3.1.orig/arch/arm/mach-ixp4xx/include/mach/io.h 2011-11-13 14:14:50.662853902 +0100
+++ linux-3.1/arch/arm/mach-ixp4xx/include/mach/io.h 2011-11-13 14:19:38.522841236 +0100
@@ -387,6 +387,20 @@ static inline unsigned int ioread16(cons
#endif
}
+#define ioread16be(p) ioread16be(p)
+static inline unsigned int ioread16be(const void __iomem *addr)
+{
+ unsigned long port = (unsigned long __force)addr;
+ if (__is_io_address(port))
+ return (unsigned int)inw(port & PIO_MASK);
+ else
+#ifndef CONFIG_IXP4XX_INDIRECT_PCI
+ return be16_to_cpu((__force __be16)__raw_readw(addr));
+#else
+ return be16_to_cpu((__force __le16)(unsigned int)__indirect_readw(addr));
+#endif
+}
+
#define ioread16_rep(p, v, c) ioread16_rep(p, v, c)
static inline void ioread16_rep(const void __iomem *addr, void *vaddr,
u32 count)
@@ -417,6 +431,21 @@ static inline unsigned int ioread32(cons
}
}
+#define ioread32be(p) ioread32be(p)
+static inline unsigned int ioread32be(const void __iomem *addr)
+{
+ unsigned long port = (unsigned long __force)addr;
+ if (__is_io_address(port))
+ return (unsigned int)inl(port & PIO_MASK);
+ else {
+#ifndef CONFIG_IXP4XX_INDIRECT_PCI
+ return be32_to_cpu((__force __be32)__raw_readl(addr));
+#else
+ return be32_to_cpu((__force __be32)(unsigned int)__indirect_readl(addr));
+#endif
+ }
+}
+
#define ioread32_rep(p, v, c) ioread32_rep(p, v, c)
static inline void ioread32_rep(const void __iomem *addr, void *vaddr,
u32 count)
@@ -475,6 +504,20 @@ static inline void iowrite16(u16 value,
#endif
}
+#define iowrite16be(v, p) iowrite16be(v, p)
+static inline void iowrite16be(u16 value, void __iomem *addr)
+{
+ unsigned long port = (unsigned long __force)addr;
+ if (__is_io_address(port))
+ outw(value, port & PIO_MASK);
+ else
+#ifndef CONFIG_IXP4XX_INDIRECT_PCI
+ __raw_writew(cpu_to_be16(value), addr);
+#else
+ __indirect_writew(cpu_to_be16(value), addr);
+#endif
+}
+
#define iowrite16_rep(p, v, c) iowrite16_rep(p, v, c)
static inline void iowrite16_rep(void __iomem *addr, const void *vaddr,
u32 count)
@@ -504,6 +547,20 @@ static inline void iowrite32(u32 value,
#endif
}
+#define iowrite32be(v, p) iowrite32be(v, p)
+static inline void iowrite32be(u32 value, void __iomem *addr)
+{
+ unsigned long port = (unsigned long __force)addr;
+ if (__is_io_address(port))
+ outl(value, port & PIO_MASK);
+ else
+#ifndef CONFIG_IXP4XX_INDIRECT_PCI
+ __raw_writel((u32 __force)cpu_to_be32(value), addr);
+#else
+ __indirect_writel((u32 __force)cpu_to_be32(value), addr);
+#endif
+}
+
#define iowrite32_rep(p, v, c) iowrite32_rep(p, v, c)
static inline void iowrite32_rep(void __iomem *addr, const void *vaddr,
u32 count)

View File

@ -49,7 +49,6 @@ bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch
# Arch bug fixes
bugfix/arm/omap-musb-choice.patch
bugfix/mips/disable-advansys.patch
bugfix/arm/ixp4xx_iobe.patch
bugfix/m68k/ethernat-kconfig.patch
bugfix/mips/MIPS-ZBOOT-add-missing-linux-string.h-include.patch
bugfix/x86/x86-reject-x32-executables-if-x32-abi-not-supported.patch