fix alsa opl3 oops

svn path=/dists/trunk/linux-2.6/; revision=5320
This commit is contained in:
maximilian attems 2006-01-06 20:07:35 +00:00
parent 803beb43b0
commit cb5c2f20d5
3 changed files with 54 additions and 1 deletions

4
debian/changelog vendored
View File

@ -3,6 +3,8 @@ linux-2.6 (2.6.15-2) UNRELEASED; urgency=low
[ maximilian attems ]
* Default to initramfs-tools as initramfs generator.
(Closes: #346141, #343147, #341524)
* Backport alsa patch for opl3 - Fix the unreleased resources.
(Closes: #346273)
[ dann frazier ]
* [ia64] Update config for 2.6.15.
@ -14,7 +16,7 @@ linux-2.6 (2.6.15-2) UNRELEASED; urgency=low
[ Sven Luther ]
* Removed spurious file from powerpc-apus patch. (Closes: #346159)
-- Sven Luther <luther@debian.org> Fri, 6 Jan 2006 07:56:52 +0000
-- maximilian attems <maks@sternwelten.at> Fri, 6 Jan 2006 21:06:39 +0100
linux-2.6 (2.6.15-1) unstable; urgency=low

50
debian/patches/alsa-opl3-oops.patch vendored Normal file
View File

@ -0,0 +1,50 @@
tree 353750772b10adbfa8eed9a09fea94b72f8f55ad
parent 3e23c658833f135508127c955d40d7c9387f71dd
author Takashi Iwai <tiwai@suse.de> Tue, 03 Jan 2006 19:56:55 +0100
committer Jaroslav Kysela <perex@suse.cz> Wed, 04 Jan 2006 10:13:52 +0100
[ALSA] opl3 - Fix the unreleased resources
Modules: OPL3
Fix the unreleased resources in the error path of snd_opl3_create().
Signed-off-by: Takashi Iwai <tiwai@suse.de>
sound/drivers/opl3/opl3_lib.c | 6 +++---
1 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/sound/drivers/opl3/opl3_lib.c b/sound/drivers/opl3/opl3_lib.c
index 650f3b8..1e0c76b 100644
--- a/sound/drivers/opl3/opl3_lib.c
+++ b/sound/drivers/opl3/opl3_lib.c
@@ -407,13 +407,13 @@ int snd_opl3_create(struct snd_card *car
if (! integrated) {
if ((opl3->res_l_port = request_region(l_port, 2, "OPL2/3 (left)")) == NULL) {
snd_printk(KERN_ERR "opl3: can't grab left port 0x%lx\n", l_port);
- snd_opl3_free(opl3);
+ snd_device_free(card, opl3);
return -EBUSY;
}
if (r_port != 0 &&
(opl3->res_r_port = request_region(r_port, 2, "OPL2/3 (right)")) == NULL) {
snd_printk(KERN_ERR "opl3: can't grab right port 0x%lx\n", r_port);
- snd_opl3_free(opl3);
+ snd_device_free(card, opl3);
return -EBUSY;
}
}
@@ -432,7 +432,7 @@ int snd_opl3_create(struct snd_card *car
if ((err = snd_opl3_detect(opl3)) < 0) {
snd_printd("OPL2/3 chip not detected at 0x%lx/0x%lx\n",
opl3->l_port, opl3->r_port);
- snd_opl3_free(opl3);
+ snd_device_free(card, opl3);
return err;
}
/* detect routine returns correct hardware type */
-
To unsubscribe from this list: send the line "unsubscribe git-commits-head" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html

View File

@ -1,2 +1,3 @@
- powerpc-arch-default-powerpc.patch
+ alsa-opl3-oops.patch