Use libata-based drivers for most PATA controllers (Closes: #444182)

Add transition script to linux-base and make all images depend on it.
Add NEWS explaining the transition.

svn path=/dists/sid/linux-2.6/; revision=15395
This commit is contained in:
Ben Hutchings 2010-03-16 05:40:15 +00:00
commit ca56472176
10 changed files with 1815 additions and 25 deletions

22
debian/NEWS vendored Normal file
View File

@ -0,0 +1,22 @@
linux-2.6 (2.6.32-10) unstable; urgency=low
* The old IDE (PATA) drivers are no longer developed, but most PATA
controllers can be handled by new drivers using 'libata', which is
already used for SATA controllers. This release enables all the new
drivers that are considered stable and disables the old drivers that
they replace.
While the old drivers presented device names beginning with 'hd',
libata makes PATA drives appear as SCSI devices and presents device
names beginning with 'sd' (hard drive), 'sr' (optical) or 'st' (tape).
In a system that already has other SCSI or SCSI-like devices, names
may change unpredictably.
During the upgrade from earlier versions, you will be prompted to
update configuration files which refer to device names that may
change. You can choose to do this yourself or to follow an automatic
upgrade process. Unfortunately the automatic upgrade process does not
cover tape drives. All changed configuration files are backed up with
a suffix of '.old' (or '^old' in one case).
-- Ben Hutchings <ben@decadent.org.uk> Tue, 16 Mar 2010 04:15:37 +0000

26
debian/changelog vendored
View File

@ -1,4 +1,6 @@
linux-2.6 (2.6.32-10) UNRELEASED; urgency=low
* The "Big Bang" release
[ maximilian attems]
* tcp: fix ICMP-RTO war.
@ -46,6 +48,30 @@ linux-2.6 (2.6.32-10) UNRELEASED; urgency=low
* Remove /usr/include/drm from linux-libc-dev; let libdrm-dev provide it
again
* [x86] Enable rtl8192su driver using external firmware
* Use libata-based drivers for most PATA controllers (Closes: #444182):
- pata_triflex replaces triflex
- pata_atiixp replaces atiixp
- pata_ns87415 replaces ns87415
- pata_sc1200 replaces sc1200
- pata_cs5536 replaces cs5536
- pata_amd replaces amd74xx
- pata_sis replaces sis5513
- pata_rz1000 replaces rz1000
- pata_efar replaces slc90e66
- pata_pdc202xx_old replaces pdc202xx_old
- pata_pdc2027x replaces pdc202xx_new
- pata_cs5520 replaces cs5520
- pata_cs5530 replaces cs5530
- pata_cmd64x replaces cmd64x
- pata_sil680 replaces siimage
- pata_ali replaces alim15x3
- pata_via replaces via82cxxx
- pata_serverworks replaces serverworks
- pata_artop replaces aec62xx
- pata_it821x replaces it821x
- ata_piix, pata_oldpiix, pata_mpiix mostly replace piix
- ata_generic, pata_ns87410, pata_netcell replace ide-pci-generic
* linux-base: Add libata transition script
-- maximilian attems <maks@debian.org> Thu, 25 Feb 2010 13:07:47 +0100

View File

@ -144,7 +144,26 @@ CONFIG_ACPI_SBS=m
##
## file: drivers/ata/Kconfig
##
# CONFIG_PATA_SIS is not set
CONFIG_PATA_ALI=m
CONFIG_PATA_AMD=m
CONFIG_PATA_ATIIXP=m
CONFIG_PATA_CMD64X=m
CONFIG_PATA_CS5520=m
CONFIG_PATA_CS5530=m
CONFIG_PATA_EFAR=m
CONFIG_PATA_TRIFLEX=m
CONFIG_PATA_MPIIX=m
CONFIG_PATA_OLDPIIX=m
CONFIG_PATA_NETCELL=m
CONFIG_PATA_NS87410=m
CONFIG_PATA_NS87415=m
CONFIG_PATA_PDC_OLD=m
CONFIG_PATA_RZ1000=m
CONFIG_PATA_SC1200=m
CONFIG_PATA_SERVERWORKS=m
CONFIG_PATA_PDC2027X=m
CONFIG_PATA_SIL680=m
CONFIG_PATA_VIA=m
##
## file: drivers/atm/Kconfig
@ -461,36 +480,36 @@ CONFIG_IDE_GD=m
CONFIG_BLK_DEV_IDECS=m
CONFIG_BLK_DEV_IDECD=m
CONFIG_BLK_DEV_IDETAPE=m
CONFIG_BLK_DEV_IDEACPI=y
# CONFIG_BLK_DEV_IDEACPI is not set
CONFIG_IDE_GENERIC=m
CONFIG_BLK_DEV_CMD640=y
# CONFIG_BLK_DEV_CMD640 is not set
# CONFIG_BLK_DEV_CMD640_ENHANCED is not set
CONFIG_BLK_DEV_IDEPNP=y
# CONFIG_BLK_DEV_OFFBOARD is not set
CONFIG_BLK_DEV_GENERIC=m
# CONFIG_BLK_DEV_GENERIC is not set
CONFIG_BLK_DEV_OPTI621=m
CONFIG_BLK_DEV_RZ1000=m
CONFIG_BLK_DEV_AEC62XX=m
CONFIG_BLK_DEV_ALI15X3=m
CONFIG_BLK_DEV_AMD74XX=m
CONFIG_BLK_DEV_ATIIXP=m
CONFIG_BLK_DEV_CMD64X=m
CONFIG_BLK_DEV_TRIFLEX=m
# CONFIG_BLK_DEV_RZ1000 is not set
# CONFIG_BLK_DEV_AEC62XX is not set
# CONFIG_BLK_DEV_ALI15X3 is not set
# CONFIG_BLK_DEV_AMD74XX is not set
# CONFIG_BLK_DEV_ATIIXP is not set
# CONFIG_BLK_DEV_CMD64X is not set
# CONFIG_BLK_DEV_TRIFLEX is not set
CONFIG_BLK_DEV_CY82C693=m
CONFIG_BLK_DEV_CS5520=m
CONFIG_BLK_DEV_CS5530=m
# CONFIG_BLK_DEV_CS5520 is not set
# CONFIG_BLK_DEV_CS5530 is not set
CONFIG_BLK_DEV_HPT366=m
CONFIG_BLK_DEV_SC1200=m
# CONFIG_BLK_DEV_SC1200 is not set
CONFIG_BLK_DEV_PIIX=m
CONFIG_BLK_DEV_NS87415=m
CONFIG_BLK_DEV_PDC202XX_OLD=m
CONFIG_BLK_DEV_PDC202XX_NEW=m
CONFIG_BLK_DEV_SVWKS=m
CONFIG_BLK_DEV_SIIMAGE=m
CONFIG_BLK_DEV_SIS5513=m
CONFIG_BLK_DEV_SLC90E66=m
# CONFIG_BLK_DEV_NS87415 is not set
# CONFIG_BLK_DEV_PDC202XX_OLD is not set
# CONFIG_BLK_DEV_PDC202XX_NEW is not set
# CONFIG_BLK_DEV_SVWKS is not set
# CONFIG_BLK_DEV_SIIMAGE is not set
# CONFIG_BLK_DEV_SIS5513 is not set
# CONFIG_BLK_DEV_SLC90E66 is not set
CONFIG_BLK_DEV_TRM290=m
CONFIG_BLK_DEV_VIA82CXXX=m
# CONFIG_BLK_DEV_VIA82CXXX is not set
##
## file: drivers/input/Kconfig

1632
debian/linux-base.postinst vendored Normal file

File diff suppressed because it is too large Load Diff

48
debian/linux-base.templates vendored Normal file
View File

@ -0,0 +1,48 @@
Template: linux-base/disk-id-convert-auto
Type: boolean
Default: true
Description: Update disk device ids in system configuration?
The new Linux kernel version provides different drivers for some
PATA (IDE) controllers. The names of some hard disk, CD-ROM and
tape devices may change.
.
You are recommended to identify disk devices in configuration files
by label or UUID (unique identifier) rather than by device name,
which will work with both old and new kernel versions. Your system
configuration can be updated automatically in most cases.
Template: linux-base/disk-id-convert-plan
Type: boolean
Default: true
Description: Apply these configuration changes to disk device ids?
These devices will be assigned UUIDs or labels:
.
${relabel}
.
These configuration files will be updated:
.
${files}
.
The device ids will be changed as follows:
.
${id_map}
Template: linux-base/disk-id-convert-plan-no-relabel
Type: boolean
Default: true
Description: Apply these configuration changes to disk device ids?
These configuration files will be updated:
.
${files}
.
The device ids will be changed as follows:
.
${id_map}
Template: linux-base/disk-id-manual
Type: note
Description: Please check these configuration files before rebooting
These configuration files still use some device names that may
change when using the new kernel:
.
${unconverted}

View File

@ -0,0 +1,37 @@
--- a/drivers/ide/piix.c
+++ b/drivers/ide/piix.c
@@ -416,8 +416,14 @@
static const struct pci_device_id piix_pci_tbl[] = {
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82371FB_0), 1 },
+#if !defined(CONFIG_PATA_OLDPIIX) && !defined(CONFIG_PATA_OLDPIIX_MODULE)
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82371FB_1), 1 },
+#endif
+#if !defined(CONFIG_PATA_MPIIX) && !defined(CONFIG_PATA_MPIIX_MODULE)
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82371MX), 0 },
+#endif
+ { PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82801DB_1), 6 },
+#if !defined(CONFIG_ATA_PIIX) && !defined(CONFIG_ATA_PIIX_MODULE)
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82371SB_1), 1 },
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82371AB), 2 },
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82801AB_1), 3 },
@@ -433,15 +439,15 @@
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82801EB_11), 6 },
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82801E_11), 6 },
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82801DB_10), 6 },
-#ifdef CONFIG_BLK_DEV_IDE_SATA
- { PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82801EB_1), 6 },
-#endif
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_ESB_2), 6 },
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_ICH6_19), 6 },
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_ICH7_21), 6 },
- { PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82801DB_1), 6 },
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_ESB2_18), 6 },
{ PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_ICH8_6), 6 },
+#endif
+#ifdef CONFIG_BLK_DEV_IDE_SATA
+ { PCI_VDEVICE(INTEL, PCI_DEVICE_ID_INTEL_82801EB_1), 6 },
+#endif
{ 0, },
};
MODULE_DEVICE_TABLE(pci, piix_pci_tbl);

View File

@ -40,3 +40,8 @@
+ bugfix/all/drm-ttm-handle-oom-in-ttm_tt_swapout.patch
+ bugfix/all/drm-radeon-kms-atom-fix-shr-shl-ops.patch
+ features/all/rtl8192su-always-use-request_firmware.patch
# libata transition
- debian/drivers-ata-pata_sis-postpone-pata.patch
- debian/drivers-ata-ata_piix-postpone-pata.patch
+ debian/piix-disable-redundant-devids.patch

3
debian/rules.real vendored
View File

@ -50,7 +50,7 @@ binary-indep: install-patch
binary-indep: install-source
binary-indep: install-support
binary-indep: install-firmware
#binary-indep: install-linux-base
binary-indep: install-linux-base
build: $(STAMPS_DIR)/build_$(ARCH)_$(FEATURESET)_$(FLAVOUR)_$(TYPE)
@ -478,6 +478,7 @@ install-linux-base:
dh_testroot
dh_prep
dh_install -X.svn
dh_installdebconf
+$(MAKE_SELF) install-base
# vim: filetype=make

View File

@ -1,7 +1,7 @@
Package: linux-image-@upstreamversion@@abiname@@localversion@
Provides: linux-image, linux-image-@major@, linux-modules-@upstreamversion@@abiname@@localversion@
Pre-Depends: debconf | debconf-2.0
Depends: module-init-tools, ${shlibs:Depends}
Depends: module-init-tools, linux-base (>= @source_upstream@), ${shlibs:Depends}
Recommends: firmware-linux-free (>= @source_upstream@)
Suggests: linux-doc-@version@
Description: Linux @upstreamversion@ for @class@

View File

@ -79,7 +79,7 @@ Description: Support files for Linux @upstreamversion@
Package: linux-base
Architecture: all
Depends: ${misc:Depends}
Depends: libapt-pkg-perl, libuuid-perl, ${misc:Depends}
Description: Linux image base package
This package contains files and support scripts for all Linux
images.