Update to 3.1.2

svn path=/dists/sid/linux-2.6/; revision=18300
This commit is contained in:
Ben Hutchings 2011-11-22 05:37:48 +00:00
parent be78e2ff73
commit c94be70e01
3 changed files with 7 additions and 35 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux-2.6 (3.1.2-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.1.2
-- Ben Hutchings <ben@decadent.org.uk> Tue, 22 Nov 2011 05:26:25 +0000
linux-2.6 (3.1.1-1) unstable; urgency=high
* New upstream stable update:

View File

@ -1,34 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 13 Nov 2011 18:42:46 +0000
Subject: [PATCH] block: Always check length of all iov entries in
blk_rq_map_user_iov()
Even after commit 5478755616ae2ef1ce144dded589b62b2a50d575
("block: check for proper length of iov entries earlier ...")
we still won't check for zero-length entries after an unaligned
entry. Remove the break-statement, so all entries are checked.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
block/blk-map.c | 4 +---
1 files changed, 1 insertions(+), 3 deletions(-)
diff --git a/block/blk-map.c b/block/blk-map.c
index e663ac2..2e852a4 100644
--- a/block/blk-map.c
+++ b/block/blk-map.c
@@ -204,10 +204,8 @@ int blk_rq_map_user_iov(struct request_queue *q, struct request *rq,
if (!iov[i].iov_len)
return -EINVAL;
- if (uaddr & queue_dma_alignment(q)) {
+ if (uaddr & queue_dma_alignment(q))
unaligned = 1;
- break;
- }
}
if (unaligned || (q->dma_pad_mask & len) || map_data)
--
1.7.7.2

View File

@ -57,7 +57,6 @@
+ bugfix/all/PM-Freezer-Reimplement-wait_event_freezekillable-usi.patch
+ bugfix/all/hfs-fix-hfs_find_init-sb-ext_tree-NULL-ptr-oops.patch
+ bugfix/all/vmscan-fix-shrinker-callback-bug-in-fs-super.c.patch
+ bugfix/all/block-Always-check-length-of-all-iov-entries-in-blk_.patch
+ features/x86/x86-Add-amilo-rfkill-driver-for-some-Fujitsu-Siemens.patch
# Defer until we're sure about the system call number