aufs: Update support patchset to aufs4.18-20180827 (no functional change)

This commit is contained in:
Ben Hutchings 2018-08-27 15:38:40 +01:00
parent 9d3878242c
commit c8c103a72c
4 changed files with 91 additions and 69 deletions

1
debian/changelog vendored
View File

@ -3,6 +3,7 @@ linux (4.18.5-1) UNRELEASED; urgency=medium
* Set ABI to 1
* [x86,arm64] Disable code signing for upload to unstable
* [rt] Update to 4.18-rc8-rt1 and re-enable
* aufs: Update support patchset to aufs4.18-20180827 (no functional change)
-- Ben Hutchings <ben@decadent.org.uk> Mon, 27 Aug 2018 14:22:41 +0100

View File

@ -1,16 +1,16 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sun Jul 1 12:48:09 2018 +0900
Subject: aufs4.x-rcN base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/439651f04f6a359ccfe63c399162a000c4684ca9
Date: Tue Aug 14 17:10:38 2018 +0900
Subject: aufs4.18 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/799ee5199f279477d2a5e1cff2c3f9dc44fcb3af
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN base patch
aufs4.18 base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 6cfd167..f60bb6e 100644
index 544cac8..aaa1c7a 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2541,6 +2541,19 @@ F: include/linux/audit.h
@ -34,7 +34,7 @@ index 6cfd167..f60bb6e 100644
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
S: Maintained
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index d6b6f43..c0898a4 100644
index 4cb1d1b..5678bf8 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -741,6 +741,24 @@ static int loop_change_fd(struct loop_device *lo, struct block_device *bdev,
@ -63,10 +63,10 @@ index d6b6f43..c0898a4 100644
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/dcache.c b/fs/dcache.c
index 0e8e5de..88de3b6 100644
index ceb7b49..88a1514 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1240,7 +1240,7 @@ enum d_walk_ret {
@@ -1237,7 +1237,7 @@ enum d_walk_ret {
*
* The @enter() callbacks are called with d_lock held.
*/
@ -98,7 +98,7 @@ index 12273b6..545e686 100644
return error;
diff --git a/fs/inode.c b/fs/inode.c
index 2c300e9..1b04ac4 100644
index 8c86c80..af894e7 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1649,7 +1649,7 @@ EXPORT_SYMBOL(generic_update_time);
@ -111,10 +111,10 @@ index 2c300e9..1b04ac4 100644
int (*update_time)(struct inode *, struct timespec64 *, int);
diff --git a/fs/namespace.c b/fs/namespace.c
index 8ddd148..ee649e0 100644
index bd2f4c6..eb7cd21 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -846,6 +846,12 @@ static inline int check_mnt(struct mount *mnt)
@@ -855,6 +855,12 @@ static inline int check_mnt(struct mount *mnt)
return mnt->mnt_ns == current->nsproxy->mnt_ns;
}
@ -214,7 +214,7 @@ index 279720d..76e38ea 100644
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 5c91108..4addb46 100644
index 805bf22..0d0d247f 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1273,6 +1273,7 @@ extern void fasync_free(struct fasync_struct *);
@ -225,7 +225,7 @@ index 5c91108..4addb46 100644
extern void __f_setown(struct file *filp, struct pid *, enum pid_type, int force);
extern int f_setown(struct file *filp, unsigned long arg, int force);
extern void f_delown(struct file *filp);
@@ -1735,6 +1736,7 @@ struct file_operations {
@@ -1733,6 +1734,7 @@ struct file_operations {
ssize_t (*sendpage) (struct file *, struct page *, int, size_t, loff_t *, int);
unsigned long (*get_unmapped_area)(struct file *, unsigned long, unsigned long, unsigned long, unsigned long);
int (*check_flags)(int);
@ -233,7 +233,7 @@ index 5c91108..4addb46 100644
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1805,6 +1807,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
@@ -1803,6 +1805,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -246,7 +246,7 @@ index 5c91108..4addb46 100644
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_write(struct file *, const char __user *, size_t, loff_t *);
@@ -2220,6 +2228,7 @@ extern int current_umask(void);
@@ -2218,6 +2226,7 @@ extern int current_umask(void);
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec64 *, int);
@ -254,7 +254,7 @@ index 5c91108..4addb46 100644
/* /sys/fs */
extern struct kobject *fs_kobj;
@@ -2506,6 +2515,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
@@ -2505,6 +2514,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
return false;
}
#endif

View File

@ -1,17 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sun Jul 1 12:48:09 2018 +0900
Subject: aufs4.x-rcN mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/439651f04f6a359ccfe63c399162a000c4684ca9
Date: Tue Aug 14 17:10:38 2018 +0900
Subject: aufs4.18 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/799ee5199f279477d2a5e1cff2c3f9dc44fcb3af
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN mmap patch
aufs4.18 mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index aaffc0c..ab72941 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -2004,7 +2004,7 @@ static int map_files_get_link(struct den
@@ -2004,7 +2004,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -20,9 +22,11 @@ aufs4.x-rcN mmap patch
path_get(path);
rc = 0;
}
diff --git a/fs/proc/nommu.c b/fs/proc/nommu.c
index 3b63be6..fb9913b 100644
--- a/fs/proc/nommu.c
+++ b/fs/proc/nommu.c
@@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_
@@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_file *m, struct vm_region *region)
file = region->vm_file;
if (file) {
@ -34,9 +38,11 @@ aufs4.x-rcN mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index dfd73a4..ed2ce10 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -306,7 +306,10 @@ show_map_vma(struct seq_file *m, struct
@@ -306,7 +306,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
const char *name = NULL;
if (file) {
@ -48,7 +54,7 @@ aufs4.x-rcN mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1734,7 +1737,7 @@ static int show_numa_map(struct seq_file
@@ -1734,7 +1737,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -57,9 +63,11 @@ aufs4.x-rcN mmap patch
struct mm_struct *mm = vma->vm_mm;
struct mm_walk walk = {
.hugetlb_entry = gather_hugetlb_stats,
diff --git a/fs/proc/task_nommu.c b/fs/proc/task_nommu.c
index 5b62f57..dfb4a3b 100644
--- a/fs/proc/task_nommu.c
+++ b/fs/proc/task_nommu.c
@@ -156,7 +156,10 @@ static int nommu_vma_show(struct seq_fil
@@ -156,7 +156,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma,
file = vma->vm_file;
if (file) {
@ -71,9 +79,11 @@ aufs4.x-rcN mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index 68a5121..d7dd986 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1431,6 +1431,28 @@ static inline void unmap_shared_mapping_
@@ -1448,6 +1448,28 @@ static inline void unmap_shared_mapping_range(struct address_space *mapping,
unmap_mapping_range(mapping, holebegin, holelen, 0);
}
@ -102,6 +112,8 @@ aufs4.x-rcN mmap patch
extern int access_process_vm(struct task_struct *tsk, unsigned long addr,
void *buf, int len, unsigned int gup_flags);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index 99ce070..8babe35 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -236,6 +236,7 @@ struct vm_region {
@ -120,9 +132,11 @@ aufs4.x-rcN mmap patch
void * vm_private_data; /* was vm_pte (shared mem) */
atomic_long_t swap_readahead_info;
diff --git a/kernel/fork.c b/kernel/fork.c
index 1b27bab..382f45d 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -506,7 +506,7 @@ static __latent_entropy int dup_mmap(str
@@ -504,7 +504,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -131,9 +145,11 @@ aufs4.x-rcN mmap patch
if (tmp->vm_flags & VM_DENYWRITE)
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index 8716bda..68afd6d 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -39,7 +39,7 @@ obj-y := filemap.o mempool.o oom_kill.
@@ -39,7 +39,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
mm_init.o mmu_context.o percpu.o slab_common.o \
compaction.o vmacache.o \
interval_tree.o list_lru.o workingset.o \
@ -142,9 +158,11 @@ aufs4.x-rcN mmap patch
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index 52517f2..250f675 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2700,7 +2700,7 @@ vm_fault_t filemap_page_mkwrite(struct v
@@ -2700,7 +2700,7 @@ vm_fault_t filemap_page_mkwrite(struct vm_fault *vmf)
vm_fault_t ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb);
@ -153,9 +171,11 @@ aufs4.x-rcN mmap patch
lock_page(page);
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/mmap.c b/mm/mmap.c
index 17bbf4d..a31c3e1 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -180,7 +180,7 @@ static struct vm_area_struct *remove_vma
@@ -180,7 +180,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -164,7 +184,7 @@ aufs4.x-rcN mmap patch
mpol_put(vma_policy(vma));
vm_area_free(vma);
return next;
@@ -905,7 +905,7 @@ again:
@@ -905,7 +905,7 @@ int __vma_adjust(struct vm_area_struct *vma, unsigned long start,
if (remove_next) {
if (file) {
uprobe_munmap(next, next->vm_start, next->vm_end);
@ -173,7 +193,7 @@ aufs4.x-rcN mmap patch
}
if (next->anon_vma)
anon_vma_merge(vma, next);
@@ -1818,8 +1818,8 @@ out:
@@ -1820,8 +1820,8 @@ unsigned long mmap_region(struct file *file, unsigned long addr,
return addr;
unmap_and_free_vma:
@ -183,7 +203,7 @@ aufs4.x-rcN mmap patch
/* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2638,7 +2638,7 @@ int __split_vma(struct mm_struct *mm, st
@@ -2640,7 +2640,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
goto out_free_mpol;
if (new->vm_file)
@ -192,7 +212,7 @@ aufs4.x-rcN mmap patch
if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new);
@@ -2657,7 +2657,7 @@ int __split_vma(struct mm_struct *mm, st
@@ -2659,7 +2659,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new);
if (new->vm_file)
@ -201,7 +221,7 @@ aufs4.x-rcN mmap patch
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2819,7 +2819,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsign
@@ -2821,7 +2821,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -210,7 +230,7 @@ aufs4.x-rcN mmap patch
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.rst.\n",
current->comm, current->pid);
@@ -2894,10 +2894,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsign
@@ -2896,10 +2896,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
}
@ -239,7 +259,7 @@ aufs4.x-rcN mmap patch
out:
up_write(&mm->mmap_sem);
if (populate)
@@ -3204,7 +3221,7 @@ struct vm_area_struct *copy_vma(struct v
@@ -3207,7 +3224,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
if (anon_vma_clone(new_vma, vma))
goto out_free_mempol;
if (new_vma->vm_file)
@ -248,9 +268,11 @@ aufs4.x-rcN mmap patch
if (new_vma->vm_ops && new_vma->vm_ops->open)
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index 9fc9e43..25d4c49 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -629,7 +629,7 @@ static void __put_nommu_region(struct vm
@@ -629,7 +629,7 @@ static void __put_nommu_region(struct vm_region *region)
up_write(&nommu_region_sem);
if (region->vm_file)
@ -259,7 +281,7 @@ aufs4.x-rcN mmap patch
/* IO memory and memory shared directly out of the pagecache
* from ramfs/tmpfs mustn't be released here */
@@ -767,7 +767,7 @@ static void delete_vma(struct mm_struct
@@ -767,7 +767,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -268,7 +290,7 @@ aufs4.x-rcN mmap patch
put_nommu_region(vma->vm_region);
vm_area_free(vma);
}
@@ -1288,7 +1288,7 @@ unsigned long do_mmap(struct file *file,
@@ -1290,7 +1290,7 @@ unsigned long do_mmap(struct file *file,
goto error_just_free;
}
}
@ -277,7 +299,7 @@ aufs4.x-rcN mmap patch
kmem_cache_free(vm_region_jar, region);
region = pregion;
result = start;
@@ -1363,10 +1363,10 @@ error_just_free:
@@ -1365,7 +1365,7 @@ unsigned long do_mmap(struct file *file,
up_write(&nommu_region_sem);
error:
if (region->vm_file)
@ -285,16 +307,15 @@ aufs4.x-rcN mmap patch
+ vmr_fput(region);
kmem_cache_free(vm_region_jar, region);
if (vma->vm_file)
- fput(vma->vm_file);
+ vma_fput(vma);
vm_area_free(vma);
return ret;
fput(vma->vm_file);
diff --git a/mm/prfile.c b/mm/prfile.c
new file mode 100644
index 0000000..a27ac36
--- /dev/null
+++ b/mm/prfile.c
@@ -0,0 +1,86 @@
+// SPDX-License-Identifier: GPL-2.0
+/*
+ * SPDX-License-Identifier: GPL-2.0
+ * Mainly for aufs which mmap(2) different file and wants to print different
+ * path in /proc/PID/maps.
+ * Call these functions via macros defined in linux/mm.h.

View File

@ -1,19 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sun Jul 1 12:48:09 2018 +0900
Subject: aufs4.x-rcN standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/439651f04f6a359ccfe63c399162a000c4684ca9
Date: Tue Aug 14 17:10:38 2018 +0900
Subject: aufs4.18 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/799ee5199f279477d2a5e1cff2c3f9dc44fcb3af
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN standalone patch
aufs4.18 standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index 88de3b6..de0091a 100644
index 88a1514..e3f500a 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1345,6 +1345,7 @@ void d_walk(struct dentry *parent, void *data,
@@ -1342,6 +1342,7 @@ void d_walk(struct dentry *parent, void *data,
seq = 1;
goto again;
}
@ -21,7 +21,7 @@ index 88de3b6..de0091a 100644
struct check_mount {
struct vfsmount *mnt;
@@ -2891,6 +2892,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
@@ -2890,6 +2891,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
write_sequnlock(&rename_lock);
}
@ -30,7 +30,7 @@ index 88de3b6..de0091a 100644
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index 2d4e007..7adbf282 100644
index bdd0eac..edd3405 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path)
@ -90,7 +90,7 @@ index 7ec0b3e..819ee07 100644
void __init files_init(void)
{
diff --git a/fs/inode.c b/fs/inode.c
index 1b04ac4..d65a5e9 100644
index af894e7..169811b 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1658,6 +1658,7 @@ int update_time(struct inode *inode, struct timespec64 *time, int flags)
@ -102,7 +102,7 @@ index 1b04ac4..d65a5e9 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index ee649e0..10923cb 100644
index eb7cd21..c536458 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -517,6 +517,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
@ -113,7 +113,7 @@ index ee649e0..10923cb 100644
/**
* mnt_drop_write - give up write access to a mount
@@ -851,6 +852,7 @@ int is_current_mnt_ns(struct vfsmount *mnt)
@@ -860,6 +861,7 @@ int is_current_mnt_ns(struct vfsmount *mnt)
{
return check_mnt(real_mount(mnt));
}
@ -121,7 +121,7 @@ index ee649e0..10923cb 100644
/*
* vfsmount lock must be held for write
@@ -1893,6 +1895,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1917,6 +1919,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -166,17 +166,17 @@ index aa5468f2..b38d224 100644
int fsnotify_fasync(int fd, struct file *file, int on)
{
diff --git a/fs/notify/mark.c b/fs/notify/mark.c
index 61f4c5f..b20a16c 100644
index 61f4c5f..855c655 100644
--- a/fs/notify/mark.c
+++ b/fs/notify/mark.c
@@ -108,6 +108,7 @@ void fsnotify_get_mark(struct fsnotify_mark *mark)
WARN_ON_ONCE(!refcount_read(&mark->refcnt));
refcount_inc(&mark->refcnt);
@@ -245,6 +245,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark)
queue_delayed_work(system_unbound_wq, &reaper_work,
FSNOTIFY_REAPER_DELAY);
}
+EXPORT_SYMBOL_GPL(fsnotify_put_mark);
static void __fsnotify_recalc_mask(struct fsnotify_mark_connector *conn)
{
/*
* Get mark reference when we found the mark via lockless traversal of object
@@ -399,6 +400,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark,
mutex_unlock(&group->mark_mutex);
fsnotify_free_mark(mark);
@ -185,14 +185,14 @@ index 61f4c5f..b20a16c 100644
/*
* Sorting function for lists of fsnotify marks.
@@ -612,6 +614,7 @@ int fsnotify_add_mark_locked(struct fsnotify_mark *mark, struct inode *inode,
fsnotify_put_mark(mark);
@@ -624,6 +626,7 @@ int fsnotify_add_mark(struct fsnotify_mark *mark, struct inode *inode,
mutex_unlock(&group->mark_mutex);
return ret;
}
+EXPORT_SYMBOL_GPL(fsnotify_add_mark);
int fsnotify_add_mark(struct fsnotify_mark *mark, struct inode *inode,
struct vfsmount *mnt, int allow_dups)
/*
* Given a list of marks, find the mark associated with given group. If found
@@ -747,6 +750,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
fsnotify_get_group(group);
mark->group = group;