Merge changes from sid up to 3.2.17-1

svn path=/dists/trunk/linux-tools/; revision=19666
This commit is contained in:
Jonathan Nieder 2012-12-30 07:34:29 +00:00
commit c80b6d4d54
13 changed files with 155 additions and 2 deletions

View File

@ -39,6 +39,7 @@ class gencontrol(object):
def do_main_setup(self, vars, makeflags):
makeflags.update({
'VERSION': self.version.linux_version,
'VERSION_DEBIAN': self.version.complete,
'UPSTREAMVERSION': self.version.linux_upstream,
})

View File

@ -145,6 +145,7 @@ class Main(object):
'arch/*/Makefile',
'arch/x86/lib/memcpy_64.S',
'arch/x86/lib/memset_64.S',
'drivers/staging/usbip/userspace/',
'include/',
'lib/rbtree.c',
'scripts/',

View File

@ -3,6 +3,7 @@ DATA = \
Makefile \
SUBDIRS = \
drivers/staging/usbip \
scripts \
tools

View File

@ -0,0 +1,24 @@
srcdir := $(top_srcdir)/drivers/staging/usbip/userspace
# Make sure we don't override top_srcdir in the sub-make. 'unexport
# top_srcdir' is *not* sufficient; nor is adding 'MAKEFLAGS=' to the
# sub-make command line.
unexport MAKEFLAGS
all:
cd $(srcdir) && ./autogen.sh
mkdir -p userspace
cd userspace && $(srcdir)/configure \
--prefix=/usr \
--with-tcp-wrappers \
--with-usbids-dir=/usr/share/misc \
--disable-shared
$(MAKE) -C userspace
install:
$(MAKE) -C userspace install
clean:
rm -rf $(addprefix $(srcdir)/,autom4te.cache aclocal.m4 config.guess config.h.in config.sub configure depcomp install-sh ltmain.sh missing)
find $(srcdir)/ -name Makefile.in -delete
rm -rf userspace

22
debian/changelog vendored
View File

@ -1,3 +1,7 @@
linux-tools (3.7.1-1~experimental.2) UNRELEASED; urgency=low
-- Jonathan Nieder <jrnieder@gmail.com> Sat, 29 Dec 2012 22:51:43 -0800
linux-tools (3.7.1-1~experimental.1) experimental; urgency=low
* New upstream release
@ -47,6 +51,24 @@ linux-tools (3.3-1~experimental.1) experimental; urgency=low
-- Ben Hutchings <ben@decadent.org.uk> Sat, 24 Mar 2012 23:15:59 +0000
linux-tools (3.2.17-1) unstable; urgency=low
* New upstream stable updates:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.15
- modpost: fix ALL_INIT_DATA_SECTIONS
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.16
- perf hists: Catch and handle out-of-date hist entry maps.
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.17
- Perf: fix build breakage
* Fix version insertion in perf man pages
* Build usbip userland packages (Closes: #568362)
- Do not build a shared library package; the API and ABI have changed
from libusbip0 but there has been no upstream soversion change
* usbipd: Enable TCP wrappers for access control
-- Ben Hutchings <ben@decadent.org.uk> Sun, 24 Jun 2012 02:52:26 +0100
linux-tools (3.2.7-2) unstable; urgency=high
* Apply upstream changes to fix various buffer overflow bugs:

3
debian/libusbip-dev.install vendored Normal file
View File

@ -0,0 +1,3 @@
usr/lib/libusbip.la
usr/lib/libusbip.a
usr/include/usbip/*

View File

@ -1,3 +1,5 @@
modpost-symbol-prefix.patch
tools-perf-version.patch
tools-perf-install.patch
usbip-update-man-pages.patch
usbip-document-tcp-wrappers.patch

View File

@ -0,0 +1,27 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: usbip: Document TCP wrappers
Add references to TCP wrappers configuration in the manual page.
--- a/drivers/staging/usbip/userspace/doc/usbipd.8
+++ b/drivers/staging/usbip/userspace/doc/usbipd.8
@@ -14,7 +14,8 @@
before usbipd makes them available to other hosts.
The daemon accepts connections from USB/IP clients
-on TCP port 3240.
+on TCP port 3240. The clients authorised to connect may be
+configured as documented in hosts_access(5).
.SH OPTIONS
.HP
@@ -44,7 +45,8 @@
.B usbipd
offers no authentication or authorization for USB/IP. Any
-USB/IP client can connect and use exported devices.
+USB/IP client running on an authorised host can connect and
+use exported devices.
.SH EXAMPLES

View File

@ -0,0 +1,14 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: Update man pages for merging of commands
usbip_bind_driver (formerly usbip_attach_driver) was merged into the
usbip command. Remove the separate man page for it. Update examples
and references accordingly.
--- a/drivers/staging/usbip/userspace/Makefile.am
+++ b/drivers/staging/usbip/userspace/Makefile.am
@@ -3,4 +3,4 @@
include_HEADERS := $(addprefix libsrc/, \
usbip_common.h vhci_driver.h usbip_host_driver.h)
-dist_man_MANS := $(addprefix doc/, usbip.8 usbipd.8 usbip_bind_driver.8)
+dist_man_MANS := $(addprefix doc/, usbip.8 usbipd.8)

23
debian/rules.real vendored
View File

@ -5,7 +5,7 @@ include debian/rules.defs
DEB_BUILD_ARCH := $(shell dpkg-architecture -qDEB_BUILD_ARCH)
HAVE_MULTIARCH := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH 2>/dev/null)
binary-arch: install-kbuild
binary-arch: install-kbuild install-usbip
ifneq ($(filter alpha amd64 armel armhf hppa i386 powerpc ppc64 s390 s390x sh4 sparc sparc64,$(DEB_BUILD_ARCH)),)
binary-arch: install-tools
endif
@ -63,3 +63,24 @@ install-tools: $(STAMPS_DIR)/build
dh_md5sums
dh_builddeb
install-usbip: DH_OPTIONS = -plibusbip-dev -pusbip
install-usbip: DIR = $(CURDIR)/debian/tmp
install-usbip: override VERSION := $(shell sed -ne 's,^#define PACKAGE_VERSION "\(.*\)"$$,\1,p' $(BUILD_DIR)/drivers/staging/usbip/userspace/config.h)
install-usbip: $(STAMPS_DIR)/build
dh_testdir
dh_testroot
dh_clean -k -d
$(MAKE) -C $(BUILD_DIR)/drivers/staging/usbip install top_srcdir=$(CURDIR) DESTDIR=$(DIR)
dh_install
dh_installchangelogs
dh_installdocs
dh_lintian
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
test -n "$(VERSION)" -a -n "$(VERSION_DEBIAN)"
dh_gencontrol -- -v$(VERSION)+$(VERSION_DEBIAN)
dh_md5sums
dh_builddeb

View File

@ -17,3 +17,35 @@ Description: Performance analysis tools for Linux @upstreamversion@
.
The linux-base package contains a 'perf' command which will invoke the
appropriate version for the running kernel.
Package: libusbip-dev
Architecture: linux-any
Depends: ${misc:Depends}
Section: libdevel
Description: USB device sharing system over IP network (development files)
USB/IP is a system for sharing USB devices over the network.
.
This package provides headers for the libusbip library and
the library itself for static linking.
Package: usbip
Architecture: linux-any
Depends: usbutils, ${shlibs:Depends}, ${misc:Depends}
Section: admin
Description: USB device sharing system over IP network
USB/IP is a system for sharing USB devices over the network.
.
To share USB devices between computers with their full
functionality, USB/IP encapsulates "USB requests" into IP
packets and transmits them between computers.
.
Original USB device drivers and applications can be used
for remote USB devices without any modification of them. A
computer can use remote USB devices as if they were
directly attached.
.
Currently USB/IP provides no access control or encryption.
It should only be used in trusted environments.
.
This package provides the server component 'usbipd' and the
client tool 'usbip'.

View File

@ -6,6 +6,7 @@ Uploaders: Bastian Blank <waldi@debian.org>, Ben Hutchings <ben@decadent.org.uk>
Standards-Version: 3.9.2
Build-Depends:
debhelper (>> 7), python,
asciidoc, binutils-dev, bison, flex, libdw-dev, libelf-dev, libnewt-dev, libperl-dev, python-dev, xmlto
asciidoc, binutils-dev, bison, flex, libdw-dev, libelf-dev, libnewt-dev, libperl-dev, python-dev, xmlto,
autoconf, automake, libtool, libglib2.0-dev, libsysfs-dev, libwrap0-dev
Vcs-Svn: svn://svn.debian.org/svn/kernel/dists/trunk/linux-tools/
Vcs-Browser: http://anonscm.debian.org/viewvc/kernel/dists/trunk/linux-tools/

4
debian/usbip.install vendored Normal file
View File

@ -0,0 +1,4 @@
usr/sbin/usbip
usr/sbin/usbipd
usr/share/man/man8/usbip.8
usr/share/man/man8/usbipd.8