media: imon: Fix null-ptr-deref in imon_probe (CVE-2017-16537)

This commit is contained in:
Ben Hutchings 2017-11-16 18:04:43 +00:00
parent a06739ccd2
commit c718be9d81
3 changed files with 33 additions and 0 deletions

1
debian/changelog vendored
View File

@ -127,6 +127,7 @@ linux (4.13.13-1) UNRELEASED; urgency=medium
* usb: usbtest: fix NULL pointer dereference (CVE-2017-16532)
* media: cx231xx-cards: fix NULL-deref on missing association descriptor
(CVE-2017-16536)
* media: imon: Fix null-ptr-deref in imon_probe (CVE-2017-16537)
-- Salvatore Bonaccorso <carnil@debian.org> Sat, 04 Nov 2017 09:54:41 +0100

View File

@ -0,0 +1,31 @@
From: Arvind Yadav <arvind.yadav.cs@gmail.com>
Date: Mon, 9 Oct 2017 20:14:48 +0200
Subject: media: imon: Fix null-ptr-deref in imon_probe
Origin: https://git.kernel.org/linus/58fd55e838276a0c13d1dc7c387f90f25063cbf3
Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2017-16537
It seems that the return value of usb_ifnum_to_if() can be NULL and
needs to be checked.
Signed-off-by: Arvind Yadav <arvind.yadav.cs@gmail.com>
Tested-by: Andrey Konovalov <andreyknvl@google.com>
Signed-off-by: Sean Young <sean@mess.org>
Signed-off-by: Mauro Carvalho Chehab <mchehab@osg.samsung.com>
---
drivers/media/rc/imon.c | 5 +++++
1 file changed, 5 insertions(+)
--- a/drivers/media/rc/imon.c
+++ b/drivers/media/rc/imon.c
@@ -2516,6 +2516,11 @@ static int imon_probe(struct usb_interfa
mutex_lock(&driver_lock);
first_if = usb_ifnum_to_if(usbdev, 0);
+ if (!first_if) {
+ ret = -ENODEV;
+ goto fail;
+ }
+
first_if_ctx = usb_get_intfdata(first_if);
if (ifnum == 0) {

View File

@ -119,6 +119,7 @@ bugfix/all/mac80211-don-t-compare-tkip-tx-mic-key-in-reinstall-.patch
bugfix/all/sctp-do-not-peel-off-an-assoc-from-one-netns-to-anot.patch
bugfix/all/usb-usbtest-fix-NULL-pointer-dereference.patch
bugfix/all/media-cx231xx-cards-fix-null-deref-on-missing-associ.patch
bugfix/all/media-imon-fix-null-ptr-deref-in-imon_probe.patch
# Fix exported symbol versions
bugfix/alpha/alpha-restore-symbol-versions-for-symbols-exported-f.patch