Add a build fix for the Cobalt early console support.

svn path=/dists/trunk/linux-2.6/; revision=6909
This commit is contained in:
Martin Michlmayr 2006-06-27 09:31:46 +00:00
parent 7bf6de02ea
commit c618859087
3 changed files with 24 additions and 0 deletions

1
debian/changelog vendored
View File

@ -13,6 +13,7 @@ linux-2.6 (2.6.17-2) UNRELEASED; urgency=low
[ Martin Michlmayr ]
* [mipsel] Fix compilation error in dz serial driver.
* [mipsel] Update configs.
* [mipsel] Add a build fix for the Cobalt early console support.
-- Jurij Smakov <jurij@debian.org> Sat, 24 Jun 2006 10:54:59 -0700

View File

@ -0,0 +1,22 @@
From: Yoichi Yuasa <yoichi_yuasa@tripeaks.co.jp>
Date: Wed, 7 Jun 2006 00:53:34 +0000 (+0900)
Subject: [MIPS] Cobalt: Fix undefined reference to disable_early_printk.
X-Git-Url: http://www.linux-mips.org/git?p=linux.git;a=commitdiff;h=973c789742b4dc957cd7feb96cae98988dd0cf01
[MIPS] Cobalt: Fix undefined reference to disable_early_printk.
Signed-off-by: Yoichi Yuasa <yoichi_yuasa@tripeaks.co.jp>
Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
---
--- a/arch/mips/cobalt/console.c
+++ b/arch/mips/cobalt/console.c
@@ -41,3 +41,8 @@ void __init cobalt_early_console(void)
printk("Cobalt: early console registered\n");
}
+
+void __init disable_early_printk(void)
+{
+ unregister_console(&cons_info);
+}

View File

@ -1 +1,2 @@
+ serial-dz.patch
+ mips-cobalt-console.patch