Update to 4.3

This commit is contained in:
Ben Hutchings 2015-11-02 10:29:06 +00:00
parent 465d398a64
commit c5e06b9078
4 changed files with 4 additions and 46 deletions

4
debian/changelog vendored
View File

@ -1,4 +1,6 @@
linux (4.3~rc7-1~exp2) UNRELEASED; urgency=medium
linux (4.3-1~exp1) UNRELEASED; urgency=medium
* New upstream release
[ Ben Hutchings ]
* netfilter: Enable NFT_DUP_IPV4, NFT_DUP_IPV6 as modules (Closes: #803370)

View File

@ -1,5 +1,5 @@
[abi]
abiname: 1
abiname: trunk
[base]
arches:

View File

@ -1,43 +0,0 @@
From: David Howells <dhowells@redhat.com>
Date: Fri, 18 Sep 2015 11:45:12 +0100
Subject: ovl: conditionally use O_LARGEFILE in ovl_copy_up()
Origin: https://git.kernel.org/cgit/linux/kernel/git/mszeredi/vfs.git/commit?id=bb00c2cd01c27e037900a28dcd01b00317a42fdb
Open the lower file with O_LARGEFILE in ovl_copy_up() if the lower file
is >= 4GiB in size.
Reported-by: Ulrich Obergfell <uobergfe@redhat.com>
Signed-off-by: David Howells <dhowells@redhat.com>
Signed-off-by: Miklos Szeredi <miklos@szeredi.hu>
Cc: <stable@vger.kernel.org> # v3.18+
---
fs/overlayfs/copy_up.c | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/fs/overlayfs/copy_up.c b/fs/overlayfs/copy_up.c
index 84d693d..391c359 100644
--- a/fs/overlayfs/copy_up.c
+++ b/fs/overlayfs/copy_up.c
@@ -76,16 +76,19 @@ static int ovl_copy_up_data(struct path *old, struct path *new, loff_t len)
struct file *new_file;
loff_t old_pos = 0;
loff_t new_pos = 0;
- int error = 0;
+ int error = 0, o_flag = 0;
if (len == 0)
return 0;
- old_file = ovl_path_open(old, O_RDONLY);
+ if (i_size_read(d_inode(old->dentry)) > MAX_NON_LFS)
+ o_flag |= O_LARGEFILE;
+
+ old_file = ovl_path_open(old, o_flag | O_RDONLY);
if (IS_ERR(old_file))
return PTR_ERR(old_file);
- new_file = ovl_path_open(new, O_WRONLY);
+ new_file = ovl_path_open(new, o_flag | O_WRONLY);
if (IS_ERR(new_file)) {
error = PTR_ERR(new_file);
goto out_fput;

View File

@ -80,7 +80,6 @@ features/all/grsecurity/grsecurity-kconfig.patch
features/all/grsecurity/grkernsec_perf_harden.patch
bugfix/all/media-uvcvideo-disable-hardware-timestamps-by-defaul.patch
bugfix/all/ovl-conditionally-use-o_largefile-in-ovl_copy_up.patch
bugfix/all/selftests-add-missing-include-directives.patch
bugfix/all/selftests-memfd-stop-unnecessary-rebuilds.patch