another r8169 upstream fix

svn path=/dists/trunk/linux-2.6/; revision=7647
This commit is contained in:
maximilian attems 2006-10-24 15:21:00 +00:00
parent 7d1173290d
commit c4cb2abbeb
3 changed files with 39 additions and 1 deletions

3
debian/changelog vendored
View File

@ -22,8 +22,9 @@ linux-2.6 (2.6.18-4) UNRELEASED; urgency=low
* Add upstream forcedeth swsusp support.
* r8169: PCI ID for Corega Gigabit network card.
* r8169: the MMIO region of the 8167 stands behin BAR#1.
* r8169: Add upstream fix for infinite loop during hotplug.
-- maximilian attems <maks@sternwelten.at> Tue, 24 Oct 2006 17:15:59 +0200
-- maximilian attems <maks@sternwelten.at> Tue, 24 Oct 2006 17:19:51 +0200
linux-2.6 (2.6.18-3) unstable; urgency=low

View File

@ -0,0 +1,36 @@
From netdev-owner@vger.kernel.org Fri Oct 13 07:35:57 2006
Date: Thu, 12 Oct 2006 22:30:46 +0200
From: Francois Romieu <romieu@fr.zoreil.com>
Arnaud Patard:
r8169: fix infinite loop during hotplug
diff --git a/drivers/net/r8169.c b/drivers/net/r8169.c
index 4c47c5b..c2c9a86 100644
--- a/drivers/net/r8169.c
+++ b/drivers/net/r8169.c
@@ -2701,6 +2702,7 @@ static void rtl8169_down(struct net_devi
struct rtl8169_private *tp = netdev_priv(dev);
void __iomem *ioaddr = tp->mmio_addr;
unsigned int poll_locked = 0;
+ unsigned int intrmask;
rtl8169_delete_timer(dev);
@@ -2739,8 +2741,11 @@ core_down:
* 2) dev->change_mtu
* -> rtl8169_poll can not be issued again and re-enable the
* interruptions. Let's simply issue the IRQ down sequence again.
+ *
+ * No loop if hotpluged or major error (0xffff).
*/
- if (RTL_R16(IntrMask))
+ intrmask = RTL_R16(IntrMask);
+ if (intrmask && (intrmask != 0xffff))
goto core_down;
rtl8169_tx_clear(tp);
--
Ueimor

View File

@ -6,3 +6,4 @@
+ features/net-forcedeth-swsusp.patch
+ bugfix/net-r8169-mmio8167.patch
+ features/net-r8169-pci_id-corega.patch
+ bugfix/net-r8169-hotplug_loop.patch