Update to 3.10.2

svn path=/dists/sid/linux/; revision=20401
This commit is contained in:
Ben Hutchings 2013-07-22 02:36:36 +00:00
parent 6c6ec64859
commit c330b2ac02
3 changed files with 40 additions and 45 deletions

41
debian/changelog vendored
View File

@ -1,4 +1,43 @@
linux (3.10.1-2) UNRELEASED; urgency=low
linux (3.10.2-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.10.2
- CIFS: Fix a deadlock when a file is reopened
- jbd2: move superblock checksum calculation to jbd2_write_superblock()
- jbd2: fix theoretical race in jbd2__journal_restart
- ext4: fix corruption when online resizing a fs with 1K block size
- ext3,ext4: don't mess with dir_file->f_pos in htree_dirblock_to_tree()
- ext4: check error return from ext4_write_inline_data_end()
- xhci: check for failed dma pool allocation
- [x86] drivers: hv: switch to use mb() instead of smp_mb()
- cgroup: fix umount vs cgroup_event_remove() race
- cgroup: fix RCU accesses to task->cgroups
- [hppa] Fix gcc miscompilation in pa_memcpy()
- [hppa] Ensure volatile space register %sr1 is not clobbered
- genirq: Fix can_request_irq() for IRQs without an action
(Closes: #709647)
- [x86] ACPI: Fix HP Folio 13 EC register access (Closes: #684186)
+ ACPI: Add CMOS RTC Operation Region handler support
+ ACPI / EC: Add HP Folio 13 to ec_dmi_table in order to skip DSDT scan
- ocfs2: xattr: fix inlined xattr reflink
- iwlwifi: pcie: fix race in queue unmapping
- Btrfs: fix estale with btrfs send
- Btrfs: hold the tree mod lock in __tree_mod_log_rewind
- Btrfs: only do the tree_mod_log_free_eb if this is our last ref
- ext4: fix data offset overflow on 32-bit archs in
ext4_inline_data_fiemap()
- ext4: fix overflows in SEEK_HOLE, SEEK_DATA implementations
- ext4: fix data offset overflow in ext4_xattr_fiemap() on 32-bit archs
- ext4: fix overflow when counting used blocks on 32-bit architectures
- ext4: fix ext4_get_group_number()
- ext4: don't allow ext4_free_blocks() to fail due to ENOMEM
- [arm] 7767/1: let the ASID allocator handle suspended animation
- [arm] 7768/1: prevent risks of out-of-bound access in ASID allocator
- [arm] 7769/1: Cortex-A15: fix erratum 798181 implementation
- [arm] 7778/1: smp_twd: twd_update_frequency need be run on all online CPUs
- [armhf] dts: imx: cpus/cpu nodes dts updates
- [armhf] drivers/dma/pl330.c: fix locking in pl330_free_chan_resources()
- memcg, kmem: fix reference count handling on the error path
[ Arnaud Patard ]
* udeb: add ehci-pci to usb-modules

View File

@ -1,43 +0,0 @@
From: Larry Finger <Larry.Finger@lwfinger.net>
Date: Sun, 23 Jun 2013 18:14:43 -0500
Subject: rtlwifi: rtl8723ae: Fix typo in firmware names
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Origin: https://git.kernel.org/linus/73e088ed17c2880a963cc760a78af8a06d4a4d9d
The driver loads its firmware from files rtlwifi/rtl8723fw*.bin, but the
MODULE_FIRMWARE macros refer to rtlwifi/RTL8723aefw*.bin.
Signed-off-by: Larry Finger <Larry.Finger@lwfinger.net>
Cc: Stable <stable@vger.kernel.org> [3.8+]
Reported-by: Axel Köllhofer <AxelKoellhofer@web.de>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/net/wireless/rtlwifi/rtl8723ae/sw.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/net/wireless/rtlwifi/rtl8723ae/sw.c b/drivers/net/wireless/rtlwifi/rtl8723ae/sw.c
index e4c4cdc..d9ee2ef 100644
--- a/drivers/net/wireless/rtlwifi/rtl8723ae/sw.c
+++ b/drivers/net/wireless/rtlwifi/rtl8723ae/sw.c
@@ -251,7 +251,7 @@ static struct rtl_hal_cfg rtl8723ae_hal_cfg = {
.bar_id = 2,
.write_readback = true,
.name = "rtl8723ae_pci",
- .fw_name = "rtlwifi/rtl8723aefw.bin",
+ .fw_name = "rtlwifi/rtl8723fw.bin",
.ops = &rtl8723ae_hal_ops,
.mod_params = &rtl8723ae_mod_params,
.maps[SYS_ISO_CTRL] = REG_SYS_ISO_CTRL,
@@ -353,8 +353,8 @@ MODULE_AUTHOR("Realtek WlanFAE <wlanfae@realtek.com>");
MODULE_AUTHOR("Larry Finger <Larry.Finger@lwfinger.net>");
MODULE_LICENSE("GPL");
MODULE_DESCRIPTION("Realtek 8723E 802.11n PCI wireless");
-MODULE_FIRMWARE("rtlwifi/rtl8723aefw.bin");
-MODULE_FIRMWARE("rtlwifi/rtl8723aefw_B.bin");
+MODULE_FIRMWARE("rtlwifi/rtl8723fw.bin");
+MODULE_FIRMWARE("rtlwifi/rtl8723fw_B.bin");
module_param_named(swenc, rtl8723ae_mod_params.sw_crypto, bool, 0444);
module_param_named(debug, rtl8723ae_mod_params.debug, int, 0444);

View File

@ -107,6 +107,5 @@ bugfix/all/alx-fix-lockdep-annotation.patch
bugfix/all/xen-blkback-Check-device-permissions-before-allowing.patch
bugfix/all/be2net-Fix-to-avoid-hardware-workaround-when-not-nee.patch
features/all/iwlwifi-mvm-support-BSS-only.patch
bugfix/all/rtlwifi-rtl8723ae-Fix-typo-in-firmware-names.patch
features/all/iwlwifi-mvm-adjust-firmware-D3-configuration-API.patch
features/all/iwlwifi-bump-required-firmware-API-version-for-3160-.patch