[arm64] correct voltage selector for Firefly-RK3399 (Closes: #900799)

This commit is contained in:
Romain Perier 2018-06-15 18:48:48 +02:00 committed by Romain Perier
parent ce045ef43e
commit c2d82aa53d
3 changed files with 49 additions and 0 deletions

3
debian/changelog vendored
View File

@ -29,6 +29,9 @@ linux (4.17.1-1~exp1) UNRELEASED; urgency=medium
* [cloud-amd64] Enable VIRTUALIZATION. (closes: #900861)
* [cloud-amd64] Enable MEMORY_HOTPLUG.
[ Romain Perier ]
* [arm64] correct voltage selector for Firefly-RK3399 (Closes: #900799)
-- Vagrant Cascadian <vagrant@debian.org> Sat, 02 Jun 2018 22:06:13 -0700
linux (4.17~rc7-1~exp1) experimental; urgency=medium

View File

@ -0,0 +1,45 @@
From: Heinrich Schuchardt <xypron.glpk@gmx.de>
Date: Mon, 4 Jun 2018 19:15:23 +0200
Subject: arm64: dts: rockchip: correct voltage selector on Firefly-RK3399
Bug-Debian: https://bugs.debian.org/900799
Origin: https://git.kernel.org/pub/scm/linux/kernel/git/mmind/linux-rockchip.git/patch/?id=710e8c4a54be82ee8a97324e7b4330bf191e08bf
Without this patch the Firefly-RK3399 board boot process hangs after these
lines:
fan53555-regulator 0-0040: FAN53555 Option[8] Rev[1] Detected!
fan53555-reg: supplied by vcc_sys
vcc1v8_s3: supplied by vcc_1v8
Blacklisting driver fan53555 allows booting.
The device tree uses a value of fcs,suspend-voltage-selector different to
any other board.
Changing this setting to the usual value is sufficient to enable booting
and also matches the value used in the vendor kernel.
Fixes: 171582e00db1 ("arm64: dts: rockchip: add support for firefly-rk3399 board")
Cc: stable@vger.kernel.org
Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
Signed-off-by: Heiko Stuebner <heiko@sntech.de>
---
arch/arm64/boot/dts/rockchip/rk3399-firefly.dts | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
index 86ff1eb..d8a2f0b 100644
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
@@ -421,7 +421,7 @@
vdd_cpu_b: regulator@40 {
compatible = "silergy,syr827";
reg = <0x40>;
- fcs,suspend-voltage-selector = <0>;
+ fcs,suspend-voltage-selector = <1>;
regulator-name = "vdd_cpu_b";
regulator-min-microvolt = <712500>;
regulator-max-microvolt = <1500000>;
--
cgit v1.1

View File

@ -53,6 +53,7 @@ debian/btrfs-warn-about-raid5-6-being-experimental-at-mount.patch
# Arch bug fixes
bugfix/arm/arm-dts-kirkwood-fix-sata-pinmux-ing-for-ts419.patch
bugfix/arm64/dts-rockchip-correct-voltage-selector-firefly-RK3399.patch
bugfix/x86/platform-x86-ideapad-laptop-add-ideapad-310-15ikb-to.patch
bugfix/x86/platform-x86-ideapad-laptop-add-ideapad-v310-15isk-t.patch
bugfix/x86/platform-x86-ideapad-laptop-add-y520-15ikbn-to-no_hw.patch