Update to 3.2.27

Drop 2 patches that went into this update.

Drop the rt patch that disables use of add_interrupt_randomness().  It
conflicts with the RNG changes in 3.2.27, and those include a change
that makes it lockless specifically so it will be usable with rt.

svn path=/dists/sid/linux/; revision=19315
This commit is contained in:
Ben Hutchings 2012-08-10 01:42:19 +00:00
parent 3797ba1690
commit c2ae6a23b9
6 changed files with 24 additions and 196 deletions

26
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (3.2.26-1) UNRELEASED; urgency=low
linux (3.2.27-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.24
@ -40,6 +40,29 @@ linux (3.2.26-1) UNRELEASED; urgency=low
- drm/radeon: fix bo creation retry path
- Btrfs: call the ordered free operation without any locks held
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.26
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.27
- lirc_sir: make device registration work (Closes: #680762)
- random: Improve random number generation on non-interactive systems
+ random: Use arch_get_random_int instead of cycle counter if avail
+ random: Use arch-specific RNG to initialize the entropy store
+ random: make 'add_interrupt_randomness()' do something sane
+ usb: feed USB device information to the /dev/random driver
+ net: feed /dev/random with the MAC address when registering a device
+ rtc: wm831x: Feed the write counter into device_add_randomness()
+ mfd: wm831x: Feed the device UUID into device_add_randomness()
- futex: Test for pi_mutex on fault in futex_wait_requeue_pi()
- futex: Forbid uaddr == uaddr2 in futex_wait_requeue_pi()
- s390/mm: downgrade page table after fork of a 31 bit process
- asus-wmi: use ASUS_WMI_METHODID_DSTS2 as default DSTS ID.
(Closes: #679158)
- md/raid1: don't abort a resync on the first badblock.
- [arm] 7467/1: mutex: use generic xchg-based implementation for ARMv6+
- [arm] 7476/1: vfp: only clear vfp state for current cpu in vfp_pm_suspend
- [arm] 7477/1: vfp: Always save VFP state in vfp_pm_suspend on UP
- [arm] 7478/1: errata: extend workaround for erratum #720789
- [arm] Fix undefined instruction exception handling
- mm: mmu_notifier: fix freed page still mapped in secondary MMU
- mm: hugetlbfs: close race during teardown of hugetlbfs shared page tables
[ Ben Hutchings ]
* Bump ABI to 4
@ -61,7 +84,6 @@ linux (3.2.26-1) UNRELEASED; urgency=low
- Drop kconfig options; restrictions can only be disabled by sysctl
- Change the audit message type from AUDIT_AVC (1400) to
AUDIT_ANON_LINK (1702)
* lirc_sir: make device registration work (Closes: #680762)
* [rt] Update to 3.2.26-rt39:
- time/rt: Fix up leap-second backport for RT changes

View File

@ -1,126 +0,0 @@
From: Jarod Wilson <jarod@redhat.com>
Date: Mon, 4 Jun 2012 13:05:24 -0300
Subject: [media] lirc_sir: make device registration work
commit 4b71ca6bce8fab3d08c61bf330e781f957934ae1 upstream.
For one, the driver device pointer needs to be filled in, or the lirc core
will refuse to load the driver. And we really need to wire up all the
platform_device bits. This has been tested via the lirc sourceforge tree
and verified to work, been sitting there for months, finally getting
around to sending it. :\
CC: Josh Boyer <jwboyer@redhat.com>
Signed-off-by: Jarod Wilson <jarod@redhat.com>
Signed-off-by: Mauro Carvalho Chehab <mchehab@redhat.com>
---
drivers/staging/media/lirc/lirc_sir.c | 60 +++++++++++++++++++++++++++++++--
1 file changed, 58 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/media/lirc/lirc_sir.c b/drivers/staging/media/lirc/lirc_sir.c
index 945d962..4afc3b4 100644
--- a/drivers/staging/media/lirc/lirc_sir.c
+++ b/drivers/staging/media/lirc/lirc_sir.c
@@ -52,6 +52,7 @@
#include <linux/io.h>
#include <asm/irq.h>
#include <linux/fcntl.h>
+#include <linux/platform_device.h>
#ifdef LIRC_ON_SA1100
#include <asm/hardware.h>
#ifdef CONFIG_SA1100_COLLIE
@@ -487,9 +488,11 @@ static struct lirc_driver driver = {
.owner = THIS_MODULE,
};
+static struct platform_device *lirc_sir_dev;
static int init_chrdev(void)
{
+ driver.dev = &lirc_sir_dev->dev;
driver.minor = lirc_register_driver(&driver);
if (driver.minor < 0) {
printk(KERN_ERR LIRC_DRIVER_NAME ": init_chrdev() failed.\n");
@@ -1215,20 +1218,71 @@ static int init_lirc_sir(void)
return 0;
}
+static int __devinit lirc_sir_probe(struct platform_device *dev)
+{
+ return 0;
+}
+
+static int __devexit lirc_sir_remove(struct platform_device *dev)
+{
+ return 0;
+}
+
+static struct platform_driver lirc_sir_driver = {
+ .probe = lirc_sir_probe,
+ .remove = __devexit_p(lirc_sir_remove),
+ .driver = {
+ .name = "lirc_sir",
+ .owner = THIS_MODULE,
+ },
+};
static int __init lirc_sir_init(void)
{
int retval;
+ retval = platform_driver_register(&lirc_sir_driver);
+ if (retval) {
+ printk(KERN_ERR LIRC_DRIVER_NAME ": Platform driver register "
+ "failed!\n");
+ return -ENODEV;
+ }
+
+ lirc_sir_dev = platform_device_alloc("lirc_dev", 0);
+ if (!lirc_sir_dev) {
+ printk(KERN_ERR LIRC_DRIVER_NAME ": Platform device alloc "
+ "failed!\n");
+ retval = -ENOMEM;
+ goto pdev_alloc_fail;
+ }
+
+ retval = platform_device_add(lirc_sir_dev);
+ if (retval) {
+ printk(KERN_ERR LIRC_DRIVER_NAME ": Platform device add "
+ "failed!\n");
+ retval = -ENODEV;
+ goto pdev_add_fail;
+ }
+
retval = init_chrdev();
if (retval < 0)
- return retval;
+ goto fail;
+
retval = init_lirc_sir();
if (retval) {
drop_chrdev();
- return retval;
+ goto fail;
}
+
return 0;
+
+fail:
+ platform_device_del(lirc_sir_dev);
+pdev_add_fail:
+ platform_device_put(lirc_sir_dev);
+pdev_alloc_fail:
+ platform_driver_unregister(&lirc_sir_driver);
+ return retval;
}
static void __exit lirc_sir_exit(void)
@@ -1236,6 +1290,8 @@ static void __exit lirc_sir_exit(void)
drop_hardware();
drop_chrdev();
drop_port();
+ platform_device_unregister(lirc_sir_dev);
+ platform_driver_unregister(&lirc_sir_driver);
printk(KERN_INFO LIRC_DRIVER_NAME ": Uninstalled.\n");
}

View File

@ -1,33 +0,0 @@
From: Jesse Barnes <jbarnes@virtuousgeek.org>
Date: Thu, 21 Jun 2012 15:13:50 -0700
Subject: drm/i915: prefer wide & slow to fast & narrow in DP configs
commit 2514bc510d0c3aadcc5204056bb440fa36845147 upstream.
High frequency link configurations have the potential to cause trouble
with long and/or cheap cables, so prefer slow and wide configurations
instead. This patch has the potential to cause trouble for eDP
configurations that lie about available lanes, so if we run into that we
can make it conditional on eDP.
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=45801
Tested-by: peter@colberg.org
Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
---
drivers/gpu/drm/i915/intel_dp.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- a/drivers/gpu/drm/i915/intel_dp.c
+++ b/drivers/gpu/drm/i915/intel_dp.c
@@ -708,8 +708,8 @@ intel_dp_mode_fixup(struct drm_encoder *
bpp = adjusted_mode->private_flags & INTEL_MODE_DP_FORCE_6BPC ? 18 : 24;
- for (lane_count = 1; lane_count <= max_lane_count; lane_count <<= 1) {
- for (clock = 0; clock <= max_clock; clock++) {
+ for (clock = 0; clock <= max_clock; clock++) {
+ for (lane_count = 1; lane_count <= max_lane_count; lane_count <<= 1) {
int link_avail = intel_dp_max_data_rate(intel_dp_link_clock(bws[clock]), lane_count);
if (intel_dp_link_required(mode->clock, bpp)

View File

@ -1,32 +0,0 @@
From a882291087c4201b04019099dc066e78673a0d83 Mon Sep 17 00:00:00 2001
From: Thomas Gleixner <tglx@linutronix.de>
Date: Tue, 21 Jul 2009 16:07:37 +0200
Subject: [PATCH 097/282] genirq: Disable random call on preempt-rt
The random call introduces high latencies and is almost
unused. Disable it for -rt.
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
---
kernel/irq/handle.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/kernel/irq/handle.c b/kernel/irq/handle.c
index 470d08c..634620c 100644
--- a/kernel/irq/handle.c
+++ b/kernel/irq/handle.c
@@ -156,8 +156,11 @@ handle_irq_event_percpu(struct irq_desc *desc, struct irqaction *action)
action = action->next;
} while (action);
+#ifndef CONFIG_PREEMPT_RT_FULL
+ /* FIXME: Can we unbreak that ? */
if (random & IRQF_SAMPLE_RANDOM)
add_interrupt_randomness(irq);
+#endif
if (!noirqdebug)
note_interrupt(irq, desc, retval);
--
1.7.10

View File

@ -350,7 +350,6 @@ features/all/fermi-accel/drm-nvd0-disp-ignore-clock-set-if-no-pclk.patch
features/all/fermi-accel/drm-nouveau-bump-version-to-1.0.0.patch
bugfix/all/net-e100-ucode-is-optional-in-some-cases.patch
bugfix/x86/drm-i915-prefer-wide-slow-to-fast-narrow-in-DP-confi.patch
bugfix/all/cipso-don-t-follow-a-NULL-pointer-when-setsockopt-is.patch
features/all/debugfs-add-mode-uid-and-gid-options.patch
@ -387,4 +386,3 @@ features/all/bql/net-fix-issue-with-netdev_tx_reset_queue-not-resetting-queue-fr
features/all/bql/ixgbe-add-support-for-byte-queue-limits.patch
features/all/bql/igb-ixgbe-netdev_tx_reset_queue-incorrectly-called-from-tx-init.patch
features/all/bql/skge-add-byte-queue-limit-support.patch
bugfix/all/media-lirc_sir-make-device-registration-work.patch

View File

@ -94,7 +94,6 @@ features/all/rt/0093-mm-Replace-cgroup_page-bit-spinlock.patch
features/all/rt/0094-buffer_head-Replace-bh_uptodate_lock-for-rt.patch
features/all/rt/0095-fs-jbd-jbd2-Make-state-lock-and-journal-head-lock-rt.patch
features/all/rt/0096-genirq-Disable-DEBUG_SHIRQ-for-rt.patch
features/all/rt/0097-genirq-Disable-random-call-on-preempt-rt.patch
features/all/rt/0098-genirq-disable-irqpoll-on-rt.patch
features/all/rt/0099-genirq-force-threading.patch.patch
features/all/rt/0100-drivers-net-fix-livelock-issues.patch