[powerpc/powerpc64] Add missing #include to LPAR console selection fix

svn path=/dists/trunk/linux-2.6/; revision=18134
This commit is contained in:
Ben Hutchings 2011-09-27 05:04:39 +00:00
parent c461bc35f7
commit c1989e9e35
2 changed files with 16 additions and 3 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux-2.6 (3.1.0~rc7-1~experimental.2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [powerpc/powerpc64] Add missing #include to LPAR console selection fix
-- Ben Hutchings <ben@decadent.org.uk> Tue, 27 Sep 2011 06:02:56 +0100
linux-2.6 (3.1.0~rc7-1~experimental.1) experimental; urgency=low
* New upstream release candidate

View File

@ -1,8 +1,14 @@
diff --git a/drivers/tty/hvc/hvc_vio.c b/drivers/tty/hvc/hvc_vio.c
index 130aace..028349a 100644
--- a/drivers/tty/hvc/hvc_vio.c
+++ b/drivers/tty/hvc/hvc_vio.c
@@ -446,7 +446,9 @@ void __init hvc_vio_init_early(void)
@@ -48,6 +48,7 @@
#include <asm/firmware.h>
#include <asm/hvsi.h>
#include <asm/udbg.h>
+#include <asm/machdep.h>
#include "hvc_console.h"
@@ -446,7 +447,9 @@ void __init hvc_vio_init_early(void)
if (hvterm_priv0.proto == HV_PROTOCOL_HVSI)
goto out;
#endif