libata: LITE-ON CX1-JB256-HP needs lower max_sectors

Closes: #830971
This commit is contained in:
Salvatore Bonaccorso 2016-08-05 15:39:22 +02:00
parent c2a8f662b5
commit c0e269c0cd
3 changed files with 37 additions and 0 deletions

1
debian/changelog vendored
View File

@ -212,6 +212,7 @@ linux (4.6.5-1) UNRELEASED; urgency=medium
[ Salvatore Bonaccorso ]
* vfs: ioctl: prevent double-fetch in dedupe ioctl (CVE-2016-6516)
* libata: LITE-ON CX1-JB256-HP needs lower max_sectors (Closes: #830971)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 30 Jul 2016 14:23:58 +0100

View File

@ -0,0 +1,35 @@
From: Tejun Heo <tj@kernel.org>
Date: Mon, 18 Jul 2016 18:40:00 -0400
Subject: libata: LITE-ON CX1-JB256-HP needs lower max_sectors
Origin: https://git.kernel.org/linus/1488a1e3828d60d74c9b802a05e24c0487babe4e
Since 34b48db66e08 ("block: remove artifical max_hw_sectors cap"),
max_sectors is no longer limited to BLK_DEF_MAX_SECTORS and LITE-ON
CX1-JB256-HP keeps timing out with higher max_sectors. Revert it to
the previous value.
Signed-off-by: Tejun Heo <tj@kernel.org>
Reported-by: dgerasimov@gmail.com
Link: https://bugzilla.kernel.org/show_bug.cgi?id=121671
Cc: stable@vger.kernel.org # v3.19+
Fixes: 34b48db66e08 ("block: remove artifical max_hw_sectors cap")
Signed-off-by: Tejun Heo <tj@kernel.org>
---
drivers/ata/libata-core.c | 6 ++++++
1 file changed, 6 insertions(+)
--- a/drivers/ata/libata-core.c
+++ b/drivers/ata/libata-core.c
@@ -4141,6 +4141,12 @@ static const struct ata_blacklist_entry
*/
{ "ST380013AS", "3.20", ATA_HORKAGE_MAX_SEC_1024 },
+ /*
+ * Device times out with higher max sects.
+ * https://bugzilla.kernel.org/show_bug.cgi?id=121671
+ */
+ { "LITEON CX1-JB256-HP", NULL, ATA_HORKAGE_MAX_SEC_1024 },
+
/* Devices we expect to fail diagnostics */
/* Devices where NCQ should be avoided */

View File

@ -66,6 +66,7 @@ bugfix/all/rtsx_usb_ms-use-msleep_interruptible-in-polling-loop.patch
bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/module-invalidate-signatures-on-force-loaded-modules.patch
bugfix/all/videobuf2-core-fix-crash-after-fixing-cve-2016-4568.patch
bugfix/all/libata-LITE-ON-CX1-JB256-HP-needs-lower-max_sectors.patch
# Miscellaneous features