* [sh4] Export cpu_core_map to fix build failure with CONFIG_SFC=m.

svn path=/dists/trunk/linux-2.6/; revision=16842
This commit is contained in:
Aurelien Jarno 2011-01-20 09:28:20 +00:00
parent 1ef6bac89f
commit c0b4964a04
3 changed files with 34 additions and 0 deletions

3
debian/changelog vendored
View File

@ -4,6 +4,9 @@ linux-2.6 (2.6.37-1~experimental.2) UNRELEASED; urgency=low
* [arm] ixp4xx: Revert build fix, now applied upstream which resulted
in another build failure
[ Aurelien Jarno ]
* [sh4] Export cpu_core_map to fix build failure with CONFIG_SFC=m.
-- Ben Hutchings <ben@decadent.org.uk> Mon, 10 Jan 2011 00:39:29 +0000
linux-2.6 (2.6.37-1~experimental.1) experimental; urgency=low

View File

@ -0,0 +1,30 @@
From 24ee7d79c5885275a531431c3b687b3a7919eee4 Mon Sep 17 00:00:00 2001
From: Aurelien Jarno <aurelien@aurel32.net>
Date: Tue, 18 Jan 2011 20:55:34 +0000
Subject: [PATCH] sh: Fix sh build failure when CONFIG_SFC=m
CONFIG_SFC=m uses topology_core_cpumask() which, for sh, expects
cpu_core_map to be exported. It is not. This patch exports the needed
symbol.
Signed-off-by: Aurelien Jarno <aurelien@aurel32.net>
Signed-off-by: Paul Mundt <lethal@linux-sh.org>
---
arch/sh/kernel/topology.c | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/arch/sh/kernel/topology.c b/arch/sh/kernel/topology.c
index 948fdb6..38e8628 100644
--- a/arch/sh/kernel/topology.c
+++ b/arch/sh/kernel/topology.c
@@ -17,6 +17,7 @@
static DEFINE_PER_CPU(struct cpu, cpu_devices);
cpumask_t cpu_core_map[NR_CPUS];
+EXPORT_SYMBOL(cpu_core_map);
static cpumask_t cpu_coregroup_map(unsigned int cpu)
{
--
1.7.3.5

View File

@ -1 +1,2 @@
- bugfix/arm/ixp4xx-add-missing-export.patch
+ bugfix/sh4/sh-export-topology-core-cpumask.patch